X
Tap here to go to the mobile version of the site.

Support Forum

When I go to close Firefow it doesn't ask me to save my tabs. I tried the online help already and that didn't fix the problem

Posted

I have a few tabs open and did some updates not related to Firefox so I need to restart my computer. When I go to close Firefox it doesn't ask me if I want to save my tabs. I know I can change my settings to just have my tabs open upon restart but I would just like for the problem to be solved so everything is back to normal.

I have a few tabs open and did some updates not related to Firefox so I need to restart my computer. When I go to close Firefox it doesn't ask me if I want to save my tabs. I know I can change my settings to just have my tabs open upon restart but I would just like for the problem to be solved so everything is back to normal.

Chosen solution

  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Uncheck: [ ] "Automatically start Firefox in a private browsing session"

You can reset the warn prefs on the about:config page via the right-click context menu.

browser.tabs.warnOnClose , see http://kb.mozillazine.org/About%3Aconfig_entries
browser.warnOnQuit , see http://kb.mozillazine.org/browser.warnOnQuit
browser.warnOnRestart , see http://kb.mozillazine.org/browser.warnOnRestart


To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • getplusplusadobe16263
  • D'Fusion @Home Web Plug-In (2.20.10609.0)
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 10.1 r82
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • 4.0.50826.0
  • NPWLPG
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17531 solutions 158524 answers

Chosen Solution

  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Uncheck: [ ] "Automatically start Firefox in a private browsing session"

You can reset the warn prefs on the about:config page via the right-click context menu.

browser.tabs.warnOnClose , see http://kb.mozillazine.org/About%3Aconfig_entries
browser.warnOnQuit , see http://kb.mozillazine.org/browser.warnOnQuit
browser.warnOnRestart , see http://kb.mozillazine.org/browser.warnOnRestart


To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

* Make sure that you not run Firefox in [[Private Browsing]] mode * You are in Private Browsing mode if you see "Tools > Stop Private Browsing", possibly grayed * You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History" * To see all History settings, choose: Tools > Options > Privacy, choose the setting <b>Firefox will: Use custom settings for history</b> * Uncheck: [ ] "Automatically start Firefox in a private browsing session" ---- You can reset the warn prefs on the about:config page via the right-click context menu. browser.tabs.warnOnClose , see http://kb.mozillazine.org/About%3Aconfig_entries browser.warnOnQuit , see http://kb.mozillazine.org/browser.warnOnQuit browser.warnOnRestart , see http://kb.mozillazine.org/browser.warnOnRestart To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br /> If you see a warning then you can confirm that you want to access that page.<br />

Question owner

I am not sure what exactly fixed it, but everything is working fine now. Thanks.

I am not sure what exactly fixed it, but everything is working fine now. Thanks.