X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Text in 4b5 is somewhat blurry on most sites; text was clear in 4b4 and earlier. How can I fix this?

Posted

http://imgur.com/av4aa.png

On the left is FF 4b5, with slightly blurry text on Lifehacker. On the right is Chrome 6.0.472.59 beta, without the blurry text.

I should note that the blurry text was not an issue in FF 4b4 or earlier.

I have also upgraded just now to 4b6, and the same issue is present.

Modified by RCDuke

Chosen solution

if you set mozilla.widget.render-mode in about:config to 0 (default is -1) your text will also look nice again.

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 10.1 r82
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.50524.0
  • Office Live Update v1.5
  • Version 1.0.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

More Information

Application Basics
Name
Firefox
Version
4.0b6
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
AeroBuddy
1.05
false
AeroBuddy@ReduxTeam
Xmarks
3.7.8
false
foxmarks@kei.com
Linkification
1.3.8
true
{35106bca-6c78-48c7-ac28-56df30b51d2a}
Greasemonkey
0.8.20100408.6
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
Adblock Plus
1.2.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Add-on Compatibility Reporter
0.6
true
compatibility@addons.mozilla.org
Download Statusbar
0.9.7.1
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
GameFOX
0.7.9pre20100913
false
{6dd0bdba-0a02-429e-b595-87a7dfdca7a1}
Feedback
1.0.3
true
testpilot@labs.mozilla.com
Java Console
6.0.21
true
{CAFEEFAC-0016-0000-0021-ABCDEFFEDCBA}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.history_expire_days_min
0
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
lifehacker.com
browser.startup.homepage_override.buildID
20100914073604
browser.startup.homepage_override.mstone
rv:2.0b6
browser.tabs.closeWindowWithLastTab
false
browser.tabs.warnOnClose
false
extensions.checkCompatibility
false
extensions.checkCompatibility.3.6
false
extensions.checkCompatibility.3.6b
false
extensions.checkCompatibility.3.6p
false
extensions.checkCompatibility.3.6pre
false
extensions.checkCompatibility.3.7a
false
extensions.checkCompatibility.4.0b
false
extensions.checkCompatibility.4.0p
false
extensions.checkCompatibility.4.0pre
false
extensions.lastAppVersion
4.0b6
network.cookie.prefsMigrated
true
network.http.pipelining
true
network.http.pipelining.maxrequests
20
places.history.enabled
false
places.history.expiration.transient_current_max_pages
127602
places.last_vacuum
1273720673
privacy.cpd.cache
false
privacy.cpd.cookies
false
privacy.cpd.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.sanitizeOnShutdown
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
Mobile Intel(R) 4 Series Express Chipset Family
Vendor ID
8086
Device ID
2a42
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version
8.15.10.2119
Driver Date
4-21-2010
Direct2D Enabled
true
DirectWrite Enabled
true

TonyE
  • Moderator
1041 solutions 8840 answers

Helpful Reply

This is caused by hardware acceleration. You can resort to the previous font rendering by turning off hardware acceleration. To do that open the options dialog (Click on the Firefox button, then select Options...), go to the Advanced panel then select the General tab, then de-select the setting to use hardware acceleration.

0x0x 1 solutions 1 answers

Chosen Solution

if you set mozilla.widget.render-mode in about:config to 0 (default is -1) your text will also look nice again.

POQbum 0 solutions 1 answers

Neither of these fix the problem.

cor-el
  • Top 10 Contributor
  • Moderator
10748 solutions 96724 answers

See also http://hacks.mozilla.org/2010/09/hardware-acceleration/