X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

On Firefox 4.0 Beta 5 text on web sites looks blurry.

Posted

I didn't notice this issue with earlier betas of FF 4 so I guess the problem came up when I upgraded from version FF 4.0 Beta 4 to Beta 5. I don't have this problem on Chrome 7.0.517.0 dev or IE 8.

Just an FYI: My video card is an XFX Radeon HD 5850 running the ATI Catalyst version 10.8 driver.

Modified by alvester

Additional System Details

Installed Plug-ins

  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • Google Update
  • Shockwave Flash 10.1 r82
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • Foxit Reader Plug-In For Firefox and Netscape
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.50826.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

Helpful Reply

The font rendering has changed due to hardware acceleration, you can revert to the old fonts by turning off hardware acceleration.

In the Options dialog, select the Advanced panel. Then open the General tab for the setting to turn off hardware acceleration.

Question owner

Thanks, TonyE. I did what you advised and yes that corrected the blurriness issue. However, by disabling hardware acceleration am I losing out on the benefits of that feature or is the improvement so slight it's not that helpful to run HA? If i am losing out on performance by turning off HA I hope that FF can work out this issue.

(The blurriness before I turned off HA reminded me of what it looks like when too much font smoothing is applied.)

Just a bit more info on my system if needed: Processor - Intel i7-930; RAM - 6 GB Corsair Dominator.

cor-el
  • Top 10 Contributor
  • Moderator
10778 solutions 97004 answers

See this MozillaZine forums thread:
Direct2D & DirectWrite HW Acceleration For Minefield - Info: http://forums.mozillazine.org/viewtopic.php?f=23&t=1775755

gotchi 0 solutions 1 answers

Hi,

I do have the same problem with Firefox 4 Beta 7 on Mac Snow Leopard!

Switching of makes the font normal readable, switching on Hardware Acceleration makes the font blurry! I followed the links and have not seen the issues on the thested sites in the Forum Thread mentioned.

Nevertheless on my personal blog http://blog.gotchi.at there this problem still exists and I do not know how to fix that.

malacath 0 solutions 3 answers

It looks aweful.

I've used firefox for over 5 years but this text issue is what is going to make me switch to another browser.

Even IE9 beta which also has hardware accelleration doesn't have this problem.

cor-el
  • Top 10 Contributor
  • Moderator
10778 solutions 97004 answers

You can set the pref gfx.font_rendering.directwrite.enabled to false on the about:config page.

ellisbodds 0 solutions 1 answers

I have this same problem on Firefox Beta 7 - it's making my eyes hurt after using it for about half an hour.

I can't even disable hardware acceleration because Firefox crashes every time I try to.

scoobidiver 12 solutions 286 answers

If you want to disable HW acceleration without crash, type about:blank in the location bar and then disable HW acceleration in Options window.

But the better workaround is the one with gfx.font_rendering.directwrite.enabled pref (font rendering) as it keeps Direct2D acceleration (image and video rendering).

SgtLegend 0 solutions 4 answers

I have read through everything but i simply just can't enjoy FF 4 BETA 8 because the font just won't render correctly like in FF 3.6 and below. I have tried disabling HW acceleration but i loose the full power of the browser which i don't like and if i disable gfx.font_rendering.directwrite.enabled it still shows up the same for me.

I would love to move forward but its just very hard on my eyes trying to read blurry text.

David B. 0 solutions 1 answers

Using version 4.0b8, you can just head to the options menu->advanced tab, and un-check "Use hardware acceleration when available". This fixes it for now until Mozilla or Microsoft (Direct2D) can figure out what is going with the font rendering.

dansgotdepth 0 solutions 1 answers

Hey,

This is urgent.

This needs fixing. I know Hardware Acceleration is the bomb. The unability to read.

what you are searching for.

Is more important. To me. At least. dansgotdepth

DRK3 0 solutions 6 answers

I am very frustrated by the horrible text rendering too. Please Mozilla, don't let the finished Firefox ship with DirectWrite. It is HORRIBLE!

lulzchicken 0 solutions 7 answers

Final FF4 version DID ship with DW fucked up I agree, I also have this issue. I've tried every fix/remedy there is on the internet. However, NOTHING works. The ONLY way I can keep Hardware Acceleration enabled while enjoying crisp fonts is while in Safe Mode. That's the ONLY way. Once I get back on my home computer I'll upload an image to show you. I'm currently browsing with HA turned off, which blows. This may not be a VERY widespread issue, but it still is an issue! Someone needs to work this out with Microsoft, or whoever is responsible. Just for the record, my windows is up to date (SP1) and all the DirectWrite patches say they are already installed. Same with video card drivers. They're up to date as well. wtf?

maxone 0 solutions 1 answers

Same for me, just updated to Firefox 4.0 (With Win7 without SP1 and Proc : Intel ULV SU7300 and a Mobile Intel 4 Series Express Chipset) and the fonts are sort of blurry. I desactivated the hardware acceleration option for now, but why release FF 4.0 if you didn't even found a solution to this problem? Depressing...

Modified by maxone

chacobo 0 solutions 1 answers

K so my question is, is HA the deal with FF4? meaning is the claimed speed increase from 3.6 all about HA? if not, in what area/to what extent does it help accelerating something?


further research solved my question, please ignore

Modified by chacobo

wildcard1974 0 solutions 3 answers

I was able to correct this and still have hardware acceleration without the Anti-aliasing addon. The issue seems to be that during an upgrade from 3.x, the 'key' that controls DirectWrite may not be added.

To see if this is your problem type in 'about:support' (without the quotes) in the Firefox address bar. You will get info about the browser. Under the section labeled Graphics, confirm that you have the following:

Direct2D enabled=true DirectWrite enabled=true

If DirectWrite enabled=false, you will need to type 'about:config' (without the quotes into the address bar. This will take you to the Firefox config window. Look for the following key: mozilla.widget.render-mode

That key is probably not present. To add it, right-click on an empty section of that window, choose New, and then Integer. Type in 'mozilla.widget.render-mode' (without the quotes) and assign it a value of 6. If you have this key and the value is anything other than 6, right click on the key and choose Modify, and change the value to 6

Close and reopen your browser, and your fonts should look better. You may want to type in 'about:support' again and confirm that DirectWrite enabled changed from false to true.

This worked on Windows 7; it's worth trying for other operating systems and *shouldn't* break anything regardless of whether it works or not.

scrubs 0 solutions 2 answers

@wildcard1974

both Direct2D enabled and DirectWrite enabled were set to true on my machine, but there was no "mozilla.widget.render-mode" key, so i added it, set it to 6, but still no change.. text still look terribly blurry

only turning off hardware acceleration fix the problem for me.

Modified by scrubs

BigXYZ 0 solutions 1 answers

Helpful Reply

Tell me, has anyone tried turning off morphological Anti-Aliasing for their ATI cards, who have this problem? Because that fixed it for me. I hadn't realized that FF was a 3D application, but it makes sense now that I know it uses AA for rendering. Maybe the devs should look into this.

ezetroc 0 solutions 1 answers

NICE! That worked for me. That was what was stopping me from using FF4 too. I can now start using it again. Thanks wildcard1974

denoteshappiness 0 solutions 1 answers

I have tried everything on this page and the text in Firefox is still blurry. I don't know what else to do, because using the anti-aliasing add on makes some of the letters overlap and that's just as bad.