X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

xpi file extention plugin needed to install the flash plugin?

Posted

Every time I try to update flash after updating Firefox, I get an error on the install page "Additional plugins are required". When FF looks, no plugins are found. If I try to manual install I get an .xpi file. What plugin is needed?

Additional System Details

Installed Plug-ins

  • npunagi2
  • npdnu
  • npdnupdater2
  • getplusplusadobe16249
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 10.1 r53
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9 ( .NET CLR 3.5.30729)

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

There is no need for an xpi file to install Flash. Adobe have made manual installers for Flash which I find far easier to use to install Flash. The manual installers can be downloaded using any browser. For details see the Adobe troubleshooting guide - http://kb2.adobe.com/cps/191/tn_19166.html#main_ManualInstaller