Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not showing fonts correctly on facebook

  • 23 replies
  • 334 have this problem
  • Last reply by carlosj

more options

All the text on facebook or sites with facebook 'likes' etc do not show up correctly, its the like font is not installed on my computer.

All the text on facebook or sites with facebook 'likes' etc do not show up correctly, its the like font is not installed on my computer.

All Replies (20)

more options

Hopefully this support article is what you need:

more options

From your screenshot it looks like you switched to some UTF-16 encoding.

You can check View > Character Encoding

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).
See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears.
You can use "Disable all add-ons" on the Diagnose Firefox issues using Troubleshoot Mode start window to disable all extensions.
You have to close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

more options

I am unfortunately dealing with a similar issue; I've noticed that all sites displaying Lucida Sans do not display properly. I tried to run FF in safe mode and change character encoding, but the issue still occurs.

more options

Scratch that- update to Beta 5 fixed the issue, although it came with other graphical issues unrelated to this one.

more options

If you have a Firefox 4.0 beta version then try to disable the hardware acceleration: Tools > Options > Advanced : [ ] General: Browsing: "Use hardware acceleration when available"

See also:
Direct2D & DirectWrite HW Acceleration For Minefield - Info:

more options

Thanks for the link and instructions. The graphical issues have disappeared with a disabling of Hardware Acceleration, but now the fonts do not work again. Thanks again though.

more options

To fix this issue:

- Open Mozilla Firefox 4 Beta 5, go to the address bar and type about:config

- Search for the property gfx.direct2d.disabled

- Double click on it to set it to True.

Modified by chevyboy

more options

Thanks for the recommendation.. unfortunately it is already set to true. [I'm using FF Beta 6 now.]

more options

Same problem here - FF 4.0b7 (update from 3.6 installation), Win XP.

All text that has the 'Lucida Grande' font is displayed as "�" symbols.

Applying the above suggestions (safe mode/changing gfx properties) did not help. The only workaround that I see is to disable usage of that font altogether (by deselecting "Allow pages to choose their own fonts, instead of my selections above" in the font preferences).

more options

You can try to disable some gfx. pref settings on the about:config page (Filter: /layers|gfx/ )

more options

changing these settings didn't help

more options

Problem still exists in beta 9 :(

more options

What exactly is your problem and which font is causing it?

Does it help if you disable website fonts? Tools > Options > Content : Fonts & Colors > Advanced > "Allow pages to choose their own fonts, instead of my selections above"

more options

It seems to be a problem with Lucida Sans, as I alluded to earlier in a post above. It does help when I set all website fonts to default to a font of my choosing, such as Arial.. but it makes everything else seem so plain, and more of a workaround than an actual solution to the problem :X

Notably, this does not occur in any other web browser, and in the current stable release of FF. I also ran a Font checker to make sure that my Lucida Sans file was not corrupt. Thanks for all the input, though.

Modified by meimei29

more options

As mentioned above, all text with the "Lucida Grande" font showed up as if the font was missing.

Looking in "c:\Windows\Fonts", I found 2 versions of this font, one TTF and one "Type 1" (Adobe PostScript font, *.pfb/*.pfm) version.

After deleting the Type 1 version, the text got displayed properly.

This is somewhat strange because the font file doesn't seem to be corrupt (gets displayed ok in the windows font properties dialog). I didn't have any such font issues in Firefox 3, IE, Google Chrome or any other application either (and these 2 font versions surely have been on my system for many months).

Maybe this bug entry is related to this issue: ("ATM/Postscript fonts will not display")

Modified by carstensis

more options

Oh, finally! I’ve been filing reports of this bug with the Beta part of the Mozilla site, but it doesn’t seem to have been flagged as a major issue. It’s major for me if I can’t read anything!

My Facebook is all right, as are some of the most popular sites, but my Firefox 4 user interface has this strange character set.

The problem exists in Betas 7 through 10 for me; trialled so far on two Windows XP machines and one Windows Vista one. Each has different font management.

Here is a blog post I made when trialling Beta 9, with screen shots. I should note that AFAIK, these websites are not set to Lucida Grande. I also do not have multiple installations of Lucida Grande, and that font is in TrueType on my systems.

I have posts for Betas 7, 8 and 10, but you get the idea.

Cor-el, I have tried to get in to the menus to implement your settings, but all my menus are displaying in this weird font.

Carstensis, you may be right that it is a Type 1 bug. I was the person who added the latest screen shots, but I wonder if that thread was being ignored because the problem first surfaced in 2002 and the experts dubbed it as fixed. The first time it was filed was in relation to the display quality.

Like all of you above, I confirm that this error does not surface at all in Firefox (versions 1 to 3), IE (versions 5 to 8), Opera (versions 10 and 11) and Chrome (versions 7 and 8). It is exclusive to Firefox 4.

Modified by Jack Yan

more options

The sites Aisleone and ThisNext use the Helvetica font and that is another font that has been mentioned often causing problems, especially if old bitmap versions of that font are installed. So you can try to look for fonts that identify themselves as Helvetica and remove them to see if that helps.

more options

Hi Cor-el, thank you: as always I appreciate your help and your speedy response.

I posted those sites as they are reasonably well known, but there are others that do not specify Helvetica or Neue Helvetica that have this same issue.

I do not have bitmaps of any of these fonts: they are all vector-based.

Adobe Systems’ website specifies Myriad (which I have installed, and have no conflicting versions) and it has this problem for me. Our company’s own websites have this issue, including my own blog—and they do not specify Helvetica (at least not as a first choice). The text at Lucire is set to specify Monotype Dante and Garamond; the text on my blog specifies Century Schoolbook (images of these are attached and no, Lucire’s website isn’t designed to look like it does here!).

I am suspecting it’s an incompatibility between Type 1 fonts and Firefox 4, but perhaps the earlier posters might be able to correct me. Importantly, no Firefox prior to v. 4 has had this problem; in fact, no program I know of has this problem.

The reason Helvetica and Lucida appear to be causing problems is not to do with the fonts, but simply their large installation base and regular specifying in CSS by designers. I haven’t tried your Helvetica-removal suggestion yet, because we use Helvetica at work: the work-around means we have to remove certain fonts just to use Firefox, and reinstall them after we close our browser. (This is not to say that your suggestion does not have merit; I am simply saying that it would not be practical for us.)

My apologies in advance for these screen shot sizes.

Modified by Jack Yan

more options

If you do not see any fonts rendered anywhere, not even on the Menu bar, then Firefox has a problem with the selected system font that is used for the user interface.

You will have to check that in the Windows Control Panel.
Vista: Control Panel > Personalization > Window Color and Appearance XP: Control Panel > Display: Appearance > Advanced

more options

You are right there, Cor-el, thank you. I’m hoping Mozilla can get to the heart of this problem though, since Firefox 4 Beta is the only program that has it.

At the request of one of the Mozilla guys who saw one of my entries, I’ve added a bug to

Modified by Jack Yan

  1. 1
  2. 2