X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I change my default Search Engine from Yahoo to Google permanently?

Posted

Every time I restart Firefox my search engine reverts back to yahoo, how do I fix this permanently. I only want to use google to search for things it is much more efficient. Is there some firefox connection to yahoo that is causing this?

Additional System Details

This happened

Every time Firefox opened

This started when...

Monday Morning 8/23 I noticed it, computer had been off all weekend

Installed Plug-ins

  • Shockwave Flash 10.0 r32
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • 2.0.0048.0
  • Java(TM) Platform SE binary
  • Office Plugin for Netscape Navigator
  • 4.0.50524.0
  • Java Plug-in 1.6.0_11 for Netscape Navigator (DLL Helper)
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.11) Gecko/20100701 Firefox/3.5.11 GTB7.1 (.NET CLR 3.5.30729)

More Information

reddwarf 0 solutions 2 answers

i downloaded youtube downloader recently and next time i open firefox, the search engine goes to yahoo. i tried this first : http://www.technipages.com/firefox-change-address-bar-search-provider.html

but then when i restart the firefox, it goes back to yahoo again. and then i tray this way : click tools --> add-ons --> extensions --> and then i hit the disable button on the Youtube downloader Toolbar. the firefox restart and voila, it goes back to google search engine.

so maybe if you're having the same problem with me, you can try like i did. good luck

reddwarf 0 solutions 2 answers

double post, sorry, it's the connection

Modified by reddwarf

Galaxy Kadiyala 0 solutions 2 answers

Helpful Reply

Type about:config into the location bar and press enter

   Accept the warning message that appears, you will be taken to a list of preferences
   In the filter box type keyword to bring up a small number of preferences
   Right-click on the preference keyword.URL and choose Reset to set it back to Google
lisa_huntington 0 solutions 1 answers

I had the same problem. Went into Control Panel (Windows 7) -> Programs and Features, and uninstalled the youtube downloader *toolbar*. After that, if I reset search in Firefox to Google it stayed reset.

Modified by lisa_huntington

kupus 0 solutions 1 answers

Helpful Reply

None of above worked for me.

This did:

"In your address bar, type in: “about:config”

Inside of the filter search box, type in:

browser.search.defaultenginename

Double click that entry (or right click and choose “Modify”) and then type in the name of the search engine you wish to have as the default search engine. It must be one that you already have installed and also make sure you type in the name correctly.

Now if you type in “Yahoo”, restart Firefox and when your browser comes back up you will see the red Yahoo “Y” and Yahoo as your default search engine." (as found on http://www.searchenginejournal.com/change-your-default-search-engine-in-firefox-google-chrome-ie/24378/)

Since I wanted to be rid of Yahoo and get Google back - in the last part instead of typing "Yahoo" I typed "Google".

That's it.

Prad 0 solutions 1 answers

"Type about:config into the location bar and press enter

  Accept the warning message that appears, you will be taken to a list of preferences
  In the filter box type keyword to bring up a small number of preferences
  Right-click on the preference keyword.URL and choose Reset to set it back to Google

"


Off all the others this one worked just fine. Thanks a lot man.

)

Modified by Prad

Gerike 0 solutions 1 answers

update: nvm i was so angry i did start to reset everything with search and browser not sure wich 1 did it,but got it. firefox started up " as 1st time run " and seems fine.


i did try all of your suggestions none of tham worked for me:(

i would very greatful for a solution for me

using laptop win7x64/latest firefox if it matters. (installed youtube dler also)

so i dont get it... i run firefox home as homepage , he did used google always. even after i installed the the yourtube downloader it was fine for a few more days and now why he started to switch into yahoo just randomly?

Modified by Gerike

saijin 0 solutions 3 answers

uninstall yahoo browser plus