X
Tap here to go to the mobile version of the site.

Support Forum

trying to remove mywebsearch toolbar I cannot get keyword url to reset

Posted

I have removed mywebsearch from programme lists. all helpline instructions tell me to go to about:config and r click on keyword url, then press reset. When I right click I get nothing that remotely describes reset. I have been trying for days

I have removed mywebsearch from programme lists. all helpline instructions tell me to go to about:config and r click on keyword url, then press reset. When I right click I get nothing that remotely describes reset. I have been trying for days

Chosen solution

There is an alternative method but I would advise against it unless you have no other option, it involves manually editing the file that stores the preferences.

  1. Follow the instructions in the Profiles - Where Firefox stores your bookmarks, passwords and other user data article to open your profile folder.
  2. Close Firefox
  3. Copy the file called prefs.js to another location (just creating a backup in case something goes wrong)
  4. Edit prefs.js with a text editor such as notepad
  5. Find the line in that file that contains keyword.URL and delete that line
  6. Save the file and restart Firefox to see if that fixes the problem.
Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.4
  • Google Update
  • Shockwave Flash 10.1 r53
  • McAfee Virtual Technician plugin for Mozilla (Gecko Version: 1.8b1)
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729)

More Information

windows xp adsl plugins adobe reader

TonyE
  • Moderator
1044 solutions 8863 answers

To confirm that you are in the right place, do you get anything like the attached image when you right-click on the keyword.URL line in about:config?

Edit: appears to be a bug in the forum software, it is not letting me upload the image.

To confirm your actions:

  1. Type about:config into the location bar and press Enter
  2. If you get a warning message accept the warning message
  3. You should get a list of preferences appear
  4. In the filter box type keyword
  5. The preference at the top should be keyword.URL
  6. Right-click on that preference and the bottom entry on the right-click menu should be Reset
To confirm that you are in the right place, do you get anything like the attached image when you right-click on the keyword.URL line in about:config? Edit: appears to be a bug in the forum software, it is not letting me upload the image. To confirm your actions: # Type '''about:config''' into the location bar and press Enter # If you get a warning message accept the warning message # You should get a list of preferences appear # In the filter box type '''keyword''' # The preference at the top should be keyword.URL # Right-click on that preference and the bottom entry on the right-click menu should be '''Reset'''

Modified by TonyE

TonyE
  • Moderator
1044 solutions 8863 answers

Chosen Solution

There is an alternative method but I would advise against it unless you have no other option, it involves manually editing the file that stores the preferences.

  1. Follow the instructions in the Profiles - Where Firefox stores your bookmarks, passwords and other user data article to open your profile folder.
  2. Close Firefox
  3. Copy the file called prefs.js to another location (just creating a backup in case something goes wrong)
  4. Edit prefs.js with a text editor such as notepad
  5. Find the line in that file that contains keyword.URL and delete that line
  6. Save the file and restart Firefox to see if that fixes the problem.
There is an alternative method but I would advise against it unless you have no other option, it involves manually editing the file that stores the preferences. # Follow the instructions in the [[profiles]] article to open your profile folder. # Close Firefox # Copy the file called prefs.js to another location (just creating a backup in case something goes wrong) # Edit prefs.js with a text editor such as notepad # Find the line in that file that contains '''keyword.URL''' and delete that line # Save the file and restart Firefox to see if that fixes the problem.
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers
See also http://kb.mozillazine.org/Preferences_not_saved and [[Preferences are not saved]]

Question owner

thank you I did all this and everything appeared exactly as you said it would. Unfortunately this did not fix the problem I still have the my websearch toolbar

thank you I did all this and everything appeared exactly as you said it would. Unfortunately this did not fix the problem I still have the my websearch toolbar

Question owner

thank you I did all this and everything appeared exactly as you said it would. Unfortunately this did not fix the problem I still have the my websearch toolbar re option 2 I do not think I am experienced enough to do this I will have to try and get someone more qualified than I to read your response and try this

thank you I did all this and everything appeared exactly as you said it would. Unfortunately this did not fix the problem I still have the my websearch toolbar re option 2 I do not think I am experienced enough to do this I will have to try and get someone more qualified than I to read your response and try this

Question owner

thanks to your advice I have evrything back to normal. I appreciate your time and trouble

thanks to your advice I have evrything back to normal. I appreciate your time and trouble