X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Ask.com has unwelcomely taken over my home page. How do I get it off? Roland

Posted

For some reason or other whenever I want to search or go on to the internet using Firefox, I get the Ask.com page instead. I do not know how to get rid of this. I do not know what other details I am supposed to provide. Surely the question is simple enough ?

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • Default Plug-in
  • Google Update
  • Shockwave Flash 10.0 r45
  • Windows Activation Technologies Plugin for Mozilla
  • 3.0.50106.0

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 AskTbBLT/3.8.0.12304 Firefox/3.6.8

More Information

I cannot access this as a result of the problem outlined above

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

See http://kb.mozillazine.org/Location_Bar_search

Check the pref keyword.URL on the about:config page: http://kb.mozillazine.org/Keyword%2eURL

See also What to do when searches take you to the wrong search website


You can also try "Reset all user preferences to Firefox defaults" on the Troubleshoot Firefox issues using Safe Mode start window.


http://kb.mozillazine.org/Preferences_not_saved

Question owner

Thanks Cor-el, I appreciate your advice but I probably lack the necessary expertise to take advantage of it. I have moved around your various links in a vain bid to do what it takes, but have just gone around in circles. How do I start Mozilla in safe mode, for example ? Roland

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.

If you see a warning then you can confirm that you want to access that page.

At the top of the page you see a "Filter" bar, where you can type which prefs (selection) that you want to see. Preferences (prefs) that do not have the default value show as bold (user set).

You can open the context menu with a right-click and choose Reset to reset a pref to the default value or Modify if you want to change the value.

Filter: keyword.URL

Right click that pref to open the right-click context menu and select Reset.


There should be a Safe mode entry in the Windows Start menu > Mozilla Firefox to start Firefox in Troubleshoot Firefox issues using Safe Mode