X
Tap here to go to the mobile version of the site.

Support Forum

To make firefox handle mms protocol here is a technique that works well. [SOLVED for some versions]

Posted

Okay folks. Mozilla is playing their cards very close to their chest with this one, though I can't understand why all the secrecy.

2012 EDIT Since version 7, Firefox appears broken and unable to recognize mms protocol. HOWEVER, if you copy your mms:// URL to a tab in the browser and edit it so that it begins http:// instead of mms:// then the browser will successfully hand the task onto your audio player, such as mplayer or vlc. So this provides a way to successfully skirt around the problem. There is nothing further in this thread applicable to versions newer than 7, so you can close this tab and go try it. Good luck!

2011: HERE'S THE SOLUTION for handling mms protocol for Firefox version 3.6 and versions near that, but not version 7 or later. This is Linux specific; I can't help you with Windows solution. Sorry. Windows users maybe look here: http://kb.mozillazine.org/Register_protocol#Firefox_3.5_specif... or try the Gecko suggestion given by cor-el in a reply in this thread.

Linux Solution

I'm using Firefox 3.6.9 with these plugins: mplayer,quicktime,realplayer,shockwave flash,windows media player

In the firefox address box type this simple but weird-looking URL about:config and open it. Then right-click on any entry in the long list that comes up. Right-clicking brings up the menu we will use to create a new entry. Select new and of type boolean. Carefully type in the name of the new preference as network.protocol-handler.expose.mms and then select for its value false. We are finished with this window, so you can close it.

We now need a page with an mms link to click on. (For this step, it really must be a clickable link. It won't work if you just type the URL yourself.) Here's a page http://beelinetv.com/ with plenty of mms links including a delightfully-named Al Karma. Go there now and left-click on Al Karma. You'll see a window open. Double-click on Select an application and navigate through your file system to a media player you have installed which will handle mms streams. I have mplayer, and its pathname is /usr/bin/mplayershell. (You might have gxine, or totem, or VLC, or ... etc.) Click the box to Remember my choice. We're now done. Your new configuration info will get saved when you quit the browser. Now, whenever you click on a mms link, whether it's a movie, or radio or a television channel, the browser should automatically hand the job of playing it to your chosen player. Though I found I had to select the player a few times before it eventually remembered; firefox can be a slow learner.  :(

If you want your browser to also accommodate rtsp:// links, repeat the above. For handling rtsp audio stream, I use the helix player, through many will use realplayer. Don't forget, you'll need to find a page with a clickable rtsp link to set this up. Or you can create your own link, it doesn't need to have an actual stream. To do this, create a text file, say text.html containing this line of code:

<a href="rtsp://1.1.1.1/">rtsp link</a>

and open it in a new TAB in your browser, using a URL something like: file:///path/text.html. You should see a link to click on.

The job is done. You can ignore the remainder of this thread.

Any problems? Add a message to the end of this thread.


Note: my solution has nothing to do with the gecko player

Okay folks. Mozilla is playing their cards very close to their chest with this one, though I can't understand why all the secrecy. <p> '''2012 EDIT''' Since version 7, Firefox appears broken and unable to recognize mms protocol. HOWEVER, if you copy your mms:// URL to a tab in the browser and edit it so that it begins <b>http://</b> instead of <b>mms://</b> then the browser will successfully hand the task onto your audio player, such as mplayer or vlc. So this provides a way to successfully skirt around the problem. There is nothing further in this thread applicable to versions newer than 7, so you can close this tab and go try it. Good luck!</p> <p>'''2011: HERE'S THE SOLUTION''' for handling mms protocol for Firefox version 3.6 and versions near that, but not version 7 or later. '''This is Linux specific; I can't help you with Windows solution. Sorry.''' Windows users maybe look here: [http://kb.mozillazine.org/Register_protocol#Firefox_3.5_specific__.28works_without_installed_Gnome_libraries.29] or try the Gecko suggestion given by cor-el in a reply in this thread.</p> <p> <h3>'''Linux Solution'''</h3> </p> I'm using Firefox 3.6.9 with these plugins: mplayer,quicktime,realplayer,shockwave flash,windows media player In the firefox address box type this simple but weird-looking URL '''about:config''' and open it. Then right-click on any entry in the long list that comes up. Right-clicking brings up the menu we will use to create a new entry. Select '''new''' and of type '''boolean'''. Carefully type in the name of the new preference as '''network.protocol-handler.expose.mms''' and then select for its value '''false'''. We are finished with this window, so you can close it. We now need a page with an mms link to click on. (For this step, it '''''really must''''' be a clickable link. It won't work if you just type the URL yourself.) Here's a page [http://beelinetv.com/] with plenty of mms links including a delightfully-named '''Al Karma'''. Go there now and left-click on '''Al Karma'''. You'll see a window open. Double-click on '''Select an application''' and navigate through your file system to a media player you have installed which will handle mms streams. I have mplayer, and its pathname is /usr/bin/mplayershell. (You might have gxine, or totem, or VLC, or ... etc.) Click the box to '''Remember my choice'''. We're now done. Your new configuration info will get saved when you quit the browser. Now, whenever you click on a mms link, whether it's a movie, or radio or a television channel, the browser should automatically hand the job of playing it to your chosen player. ''Though I found I had to select the player a few times before it eventually remembered; firefox can be a slow learner.'' :( If you want your browser to also accommodate rtsp:// links, repeat the above. For handling rtsp audio stream, I use the helix player, through many will use realplayer. Don't forget, you'll need to find a page with a clickable rtsp link to set this up. Or you can create your own link, it doesn't need to have an actual stream. To do this, create a text file, say '''text.html''' containing this line of code: <p> '''<a href="rtsp://1.1.1.1/">rtsp link</a>'''</p> and open it in a new TAB in your browser, using a URL something like: '''file:///path/text.html'''. You should see a link to click on. The job is done. You can ignore the remainder of this thread. Any problems? Add a message to the end of this thread. <hr> Note: my solution has nothing to do with the gecko player

Modified by pawpaw

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.0 r42
  • Scalable Vector Graphics, as handled by RSVG-2.18.2. Views SVG images.This is alpha software. It will probably behave in many situations, but may also ride your motorcycle, drink all your milk, or use your computer to browse porn. Comments, feature requests, and patches are welcome.See http://librsvg.sourceforge.net/ for information.
  • mplayerplug-in 2010/1/17Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer JavaScript Enabled and Using GTK2 Widgets
  • The default plugin handles plugin data for mimetypes and extensions that are not specified and facilitates downloading of new plugins.

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

More Information

cor-el
  • Top 10 Contributor
  • Moderator
15583 solutions 141069 answers
You can try the Gecko Media Player.<br /> See [[Using the Windows Media Player plugin with Firefox]] http://kdekorte.googlepages.com/gecko-mediaplayer http://kdekorte.googlepages.com/gnomemplayer

Helpful Reply

Gecko is a front end for mplayer. I found that I can get firefox to accommodate mms streams without having to install gecko. You don't need gecko. See next message in this thread for the solution.

Gecko is a front end for mplayer. I found that I can get firefox to accommodate mms streams without having to install gecko. You don't need gecko. See next message in this thread for the solution.

Modified by pawpaw

Question owner

For your convenience, here's a radio station to try once you are correctly set up. You have to type it in yourself, this editor won't let me make it into a clickable link. mms://streaming.mytalk.com.au/3aw

The remainder of this thread relates to my original question, and can be ignored.


It turns out that with Firefox 3.6 they introduced a new statement that you need to add, making it a total of three lines you add after opening about:config in the browser. I have written it up in an article in the Puppy Linux forum; here's the direct link: http://www.murga-linux.com/puppy/viewtopic.php?t=31890&start=343

For mms support simply replace rtsp with mms in each line, and in the first set the path to your preferred mms-ready media player.

If you can find a butt to kick at mozilla, give it a good one from me too would you?

HTH

For your convenience, here's a radio station to try once you are correctly set up. You have to type it in yourself, this editor won't let me make it into a clickable link. mms://streaming.mytalk.com.au/3aw The remainder of this thread relates to my original question, and can be ignored. <hr> It turns out that with Firefox 3.6 they introduced a new statement that you need to add, making it a total of '''three lines''' you add after opening '''about:config''' in the browser. I have written it up in an article in the '''Puppy Linux forum'''; here's the direct link: [http://www.murga-linux.com/puppy/viewtopic.php?t=31890&start=343] For mms support simply replace '''rtsp''' with '''mms''' in each line, and in the first set the path to your preferred mms-ready media player. If you can find a butt to kick at mozilla, give it a good one from me too would you? HTH

Modified by pawpaw

Question owner

Don't leave yet, there's a follow-up to this saga, folks.........  :-))

So I upgraded to Firefox 3.6.8 and added the same 3 lines again for mms support. I restarted FF and, guess what .... ? It didn't work! I restarted again and clicked on a site with an mms:// URL and got the same old "no application associated with that protocol" whine all over again! I restarted FF a few times, still no go. I rebooted, still wouldn't budge.

While I fumed about this, I decided I might as well add the 3 lines for rtsp:// support also, but that also failed to endow FF with any ability to handle rtsp:// URLs.

But have patience, folk. Two days and about 4 reboots later, for no reason known, FF suddenly decided it would take notice of those lines and begin recognising mms:// URLs. Okay, so it still didn't recognise rtsp:// URLs but I was thankful for small mercies. I rechecked for spelling errors in the rtsp:// entries, but they are right.

Then, two days further on the weather conditions must have been just to its liking, because FF started to recognise rtsp:// URLs too!!

Whoo Hoo!

The moral of this message is ....... just be patient. It won't work right away; it probably won't work next day; but sooner or later, when you least expect it, it will start working!

Don't leave yet, there's a follow-up to this saga, folks......... :-)) So I upgraded to Firefox 3.6.8 and added the same 3 lines again for mms support. I restarted FF and, guess what .... ? It didn't work! I restarted again and clicked on a site with an mms:// URL and got the same old "no application associated with that protocol" whine all over again! I restarted FF a few times, still no go. I rebooted, still wouldn't budge. While I fumed about this, I decided I might as well add the 3 lines for rtsp:// support also, but that also failed to endow FF with any ability to handle rtsp:// URLs. But have patience, folk. Two days and about 4 reboots later, for no reason known, FF suddenly decided it would take notice of those lines and begin recognising mms:// URLs. Okay, so it still didn't recognise rtsp:// URLs but I was thankful for small mercies. I rechecked for spelling errors in the rtsp:// entries, but they are right. Then, two days further on the weather conditions must have been just to its liking, because FF started to recognise rtsp:// URLs too!! Whoo Hoo! The moral of this message is ....... just be patient. It won't work right away; it probably won't work next day; but sooner or later, when you least expect it, it will start working!

Modified by pawpaw

johns108 0 solutions 1 answers

For some reason I can't cut and paste anything from the internet using firefox, I just starting using it and it really a problem is there some setting I need to change. Had been using exployer 7 wanted to update

For some reason I can't cut and paste anything from the internet using firefox, I just starting using it and it really a problem is there some setting I need to change. Had been using exployer 7 wanted to update
the-edmeister
  • Top 25 Contributor
  • Moderator
5096 solutions 37574 answers

johns108,

Your posting is off topic for this thread. Use the Ask a new question button on the main forum page, to get your own thread.

johns108, Your posting is off topic for this thread. Use the '''Ask a new question''' button on the main forum page, to get your own thread.
justinkirby 0 solutions 1 answers

I have a similar problem and currently trying the "wait random number of days a pray." technique.

Is there a list of cached files in the profile that we can try deleting?

I have a similar problem and currently trying the "wait random number of days a pray." technique. Is there a list of cached files in the profile that we can try deleting?

Question owner

While awaiting the correct planetary alignment, why not post your Firefox version and also your PC's operating system? Also, post again when it starts working.  :-) I haven't tried adding mms and rtsp support in any Firefox's since I made the posts you refer to.

Just as a check: can you go to your media player and hand it an mms URI to confirm that it really will play that source when Firefox hands it on? Here's one to try: mms://streaming.mytalk.com.au/3aw It's windows media format, at 32kbs. You're going to get nowhere if the player itself won't handle mms://...

Fingers crossed!  ;-)

While awaiting the correct planetary alignment, why not post your Firefox version and also your PC's operating system? Also, post again when it starts working. :-) I haven't tried adding mms and rtsp support in any Firefox's since I made the posts you refer to. Just as a check: can you go to your media player and hand it an mms URI to confirm that it '''really will''' play that source when Firefox hands it on? Here's one to try: mms://streaming.mytalk.com.au/3aw It's windows media format, at 32kbs. You're going to get nowhere if the player itself won't handle mms://... Fingers crossed! ;-)

Modified by pawpaw

madjack65 0 solutions 1 answers

I'm having the same problem after adding the three lines. I guess now I'm in the waiting for star alignment mode. Anyway I'm using Ubuntu 11.04 and Firefox 5.0

I've been reading and this seems to have been an issue since ver 1, is there a reason why this hasn't been resolved after so many years?

I'm having the same problem after adding the three lines. I guess now I'm in the waiting for star alignment mode. Anyway I'm using Ubuntu 11.04 and Firefox 5.0 I've been reading and this seems to have been an issue since ver 1, is there a reason why this hasn't been resolved after so many years?

Question owner

Madjack. You say you added "the three lines", but there is only one I told you to add. After that, I wrote "ignore the rest of this thread". So go back and fix that if you can. (If I remember, it may be impossible to remove some of what you've added using about:config.)

Have you copied the URL of an mms:// stream (any working mms stream) and given it directly to your chosen media player? (Such as on the command line in a console?) As I explained, all FF does is say "I know nothing about mms but I'll pass it onto this media player which madjack has nominated to handle the mms stream".

If your media player does not handle mms properly when you directly hand it the mms:// URL, then it will be equally incapable of handling it when FireFox passes it that same mms:// URL

Let's not be too ambitious. How about trying this 32kbits/sec audio stream mms://66.70.119.243/2mmm (it's a Sydney radio station) before trying one of the beelinetv video streams I pointed out earlier.

Madjack. You say you added "the three lines", but there is only one I told you to add. After that, I wrote "ignore the rest of this thread". So go back and fix that if you can. (If I remember, it may be impossible to remove some of what you've added using '''about:config'''.) Have you copied the URL of an mms:// stream ('''any''' working mms stream) and given it directly to your chosen media player? (Such as on the command line in a console?) As I explained, all FF does is say "I know nothing about mms but I'll pass it onto this media player which madjack has nominated to handle the mms stream". If your media player does not handle mms properly when you directly hand it the mms:// URL, then it will be equally incapable of handling it when FireFox passes it that same mms:// URL Let's not be too ambitious. How about trying this 32kbits/sec audio stream '''mms://66.70.119.243/2mmm''' (it's a Sydney radio station) before trying one of the beelinetv video streams I pointed out earlier.

Modified by pawpaw

FedoraFFuser 0 solutions 1 answers

Helpful Reply

I've added The One Line :) and mms streams are now supported.
Thank you pawpaw for your effort! Much appreciated. The only thing to report is that when I click any mms link, 2 copies of VLC start up (I've associated with /usr/bin/vlc). What am I doing wrong?
Edit: Oh, interesting enough, if instead of clicking the link I open it in a new tab, only 1 copy of VLC starts...

I've added The One Line :) and mms streams are now supported.<br> Thank you pawpaw for your effort! Much appreciated. The only thing to report is that when I click any mms link, 2 copies of VLC start up (I've associated with /usr/bin/vlc). What am I doing wrong?<br> Edit: Oh, interesting enough, if instead of clicking the link I open it in a new tab, only 1 copy of VLC starts...

Modified by FedoraFFuser