X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox won't play videos from YouTube, Hulu, etc. w/latest Flash version.

Posted

Despite following both Firefox and Flash directions, Firefox won't play videos from YouTube, Hulu, etc. They either never load or they load and freeze within seconds. Before I got the latest versions of Firefox and Flash, I did not have this problem. So there must be a problem in one or both of them. Since I understand from various websites that this is a widespread problem, can Firefox fix this? It's a major flaw in the latest Firefox version.

Chosen solution

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • npmnqmp 989898989877
  • np-mswmp
  • NPTURNMED
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 10.1 r53
  • iTunes Detector Plug-in
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Java Plug-in 1.6.0 for Netscape Navigator (DLL Helper)

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

mike7721 0 solutions 1 answers

ok i was having the same problem but i literally just fixed it...the way i did it was i went into facebook and went to a video...but before i clicked play i right clicked on the video and went to settings and i disabled (unclicked) hardware acceleration

mikeykjr 0 solutions 1 answers

I didn't have this problem at all until I upgraded to FF v. 3.6.9 and after several attempts of looking for a solution, I finally found yours!

Thanks Mike, your solution worked for me too! I wonder if its something with the new version that hasn't been widely reported yet?

Muhanoid 0 solutions 1 answers

Another solution (VISTA users): 1. Do as mike7721 said, i.e disable adobe flash hardware acceleration 2. Go to file location (plugin-container.exe), right click and set compatibility mode with win 98 / ME

Default location is: C:\Program Files\Mozilla Firefox\plugin-container.exe

More. Used one of solutions posted here: http://support.mozilla.com/ru/questions/722072 Disable the "crash protection" http://kb.mozillazine.org/Plugin-container_and_out-of-process_plugins


Note: no such problems in Win 7

Modified by Muhanoid

righteousrose 0 solutions 1 answers

Thank you Mike! I never would have figured this one out! Such a simple solution for such a big problem! Thanks again!

Efreak101 16 solutions 182 answers

We now know that the problem has to do with with the latest flash versions. Here are two options to fix the problem:

  1. You can revert back to the previous version of Flash that worked. Here's the link to Flash Player 10.2.152.26: http://www.filehippo.com/download_flashplayer_firefox/9252/ If that doesn't work, choose a previous version.
  2. You can install the Firefox 4 RC.
RonQ 0 solutions 80 answers

Efreak is correct. All these other issues are chintzy workarounds. The problem lies in the latest flash updates, which the latest firefox updates "recommended" to have.

Disabling hardware acceleration or cookies has huge problems.

Revert to the old flash and you will likely not have these problems, until this problem is actually fixed.

I'm not sure I will trust ff 4, though, for a while, especially until the flash problem is solved.

sincitylocal 0 solutions 1 answers

Helpful Reply

If you are running Adblock Plus...

While on a YouTube page, right click the ABP icon and "open blockable items".

When the window opens at the bottom of the page, right click this line: http://s.ytimg.com/yt/swfbin/watch_as3-vfl9DouAr.swf (or some variation) , then "Disable Filter".

Modified by sincitylocal

pfsoto 0 solutions 5 answers

Culprit: Tweak Tube extension When i disabled it, all was well; no problem with youtubes.

I first ran Firefox in safe mode (without all my extensions loaded). No problem; so disabled them one by one. Tweak Tube is a problem

magnumrs 0 solutions 1 answers

I had the exact same problem and tried everything! Eventually I just uninstalled Firefox (keeping all settings) and re-installed it. Worked like a charm! All videos run now with now problem. Many people have found that this solved their problem too. Hope it works for you!

jjoyff 0 solutions 1 answers

This problem is caused by ABP (Ad Block Plus). Disable it and refresh. It should work

massasauga 0 solutions 1 answers

If you use Linux like I do, try going to:

http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html

Then scroll down to get an earlier version of Flash. (I tried 10.3.183.18)

Downloaded the archive .zip file and extract everything in an Adobe folder in your home directory (or some directory of your choice. There are folders for Windows and Linux.

The Linux folder contains the libflashplayer.so file, which is the plugin. Copy this into your adobe subfolder.

Open a terminal window and log on as root.

From the command prompt, enter: cd /usr/lib/mozilla/plugins.

There should be a file called libflashplayer.so, which is your old flash plugin. Go ahead and remove it (or hide it by giving it a name like libflashplayer.so.saved.

From the command prompt enter: ln -s /home/<username>/flash/adobe/libflashplayer.so

This will link your older version plugin to where your newer version plugin used to be. Your flasher player plugin should be downgraded now and it should work.

After you test Youtoube and Hulu, you can delete all the stuff from your adobe subfolder except for the libflashplayer.so file that you linked to.

This worked for me, but I also have a laptop where the newer flash plugin didn't cause this problem, so there are probably some hardware differences that cause varying problems.

jsnimurphy 0 solutions 3 answers

On 6/11/2012 an Adobe flash update caused Hulu and YouTube flash content to stop working in Firefox on one of our Win7 laptops. We confirmed this issue on a Vista desktop when we updated Adobe flash. We fixed both by 1) upgrading Firefox (I think we went from version 12 to 13) and 2) implemented the fix found here: http://forums.adobe.com/thread/1018071

Notes: step 2) above seems to be the critical factor. On one system, we had to run notepad as Administrator to update the mms.cfg file. We also did several uninstalls and reinstalls of flash, and reboots along the way to figuring this out, so it's possible there are some order dependencies. Also, when you edit mms.cfg, make sure the file extension is "cfg" and you don't create, for example, mms.cfg.txt.

For those who don't want to or can't follow the link above, here's the important snippet:

"... To disable, add the following line to your mms.cfg file located in:

Windows 32bit: C:\windows\system32\macromed\flash

Windows 64bit: C:\windows\syswow64\macromed\flash

ProtectedMode=0

If the mms.cfg file does not exist, create one using any standard text editor (e.g.. notepad) [...] Depending on your operating system, you might need to first save the mms.cfg file to a writable location (such as your documents or desktop folder) and then copy the file into the destination folder using Windows Explorer.

To enable Protected Mode, simply remove the line from the mms.cfg file."

TallyTom 0 solutions 3 answers

jsnimurphy....Thanks for your posting...but...I did this and still have the problem. This problem did occur after an Adobe Update effort, on June 11, 2012. I am using Vista. I reloaded Firefox, then edited the CFG file, and then rebooted the PC. And then, ...still the YouTube videos did not play, giving and error message. Also the game window on FarmVille does not display.

Do you have any additional suggestions??

TallyTom 0 solutions 3 answers

P.S. The YouTube videos do play correctly in IE and in CHROME. I tried to load and older version of FLASH PLAYER but I am prevented from doing so as I get a POP-UP window that stops me, stating that it is not the latest version ( doh!...so frustrating).

catalla 0 solutions 1 answers

I would love to just undo the stupid move that was "upgrading" Flash this morning, however, I can't seem to make Flash understand that I don't want the newest version. How do you convince it to let you use an older version? It just keeps telling me "The version ... you are trying to install is not the most current version. Please ... obtain the latest, most secure version."

TallyTom 0 solutions 3 answers

Helpful Reply

Ok, I have Youtube and FarmVille videos now displaying properly. I uninstalled FIREFOX and all ADOBE products (...all...). Then reloaded latest FIREFOX and then loaded version 10.3 of ADOBE FLASH PLAYER. The problem was finding an old version of FLASH PLAYER that could be loaded without a pop-up mandating that I use the newer version. Go here to get the "10.3 version for other browsers"

http://forums.adobe.com/message/3854689#3854689

Good luck everyone.

chevy309 0 solutions 1 answers

I had the same problem, how i fixed it was, i uninstalled my adobe flash, then went on there website and downloaded an older version of their adobe flash from back in march and then installed it and wall-LA works back normal now.

paydro2012 0 solutions 1 answers

uninstalled Flash 11 and used TallyToms's link to get Flash 10.3 all working again. Do Adobe not TEST these updates for their stupid programme? I can't wait until someone comes up with a stable rival to Flash.

Noah_SUMO
  • Moderator
50 solutions 304 answers

Chosen Solution

Please read the article linked below:
Flash 11.3 doesn't load video in Firefox