X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I can open Firefox, but then can't click on anything, not even the minimize/maximize buttons.

Posted

I can get Firefox to open and sometimes even browse properly for a few moments, but then I can't click on anything. Or, more accurately, I will click but then nothing happens. I can't even exit out of Firefox, because when I click on the minimize/maximize buttons or the red x, nothing happens. I then have to exit using ctrl/alt/delete, but the task handler even then claims that Firefox is running properly. I ctrl/alt/delete my way out anyway.

I've done everything I can think of. I've checked for updates, run CCleaner, defragged, run disk cleanup, and checked for malware. This persists in happening, but only in Firefox, not in IE.

I should mention I'm on a Dell laptop.

Additional System Details

This happened

Every time Firefox opened

This started when...

August 6, 2010

Application

  • User Agent:

More Information

Morbus 134 solutions 2338 answers

Helpful Reply

It's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode (don't forget to select Disable all add-ons when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and themes and this one for plugins.

If you need support for one of your add-ons, you'll have to contact its author.

If the problem does not disappear when all add-ons are disabled, please tell me, so we can work from there. Please have no fear of following my instructions to the line, as all can be easily undone.

Helpful Reply

Oh thank you for posting on how to enter safe browsing! I had tried to disable add-ons, but couldn't make anything click to do so. So frustrating!

Anyway, after putting on the safe browsing, it worked *immediately*, so clearly the add-ons were the issue! I deleted a bunch I don't use anyway, and it's been working fine for hours.

Thank you!!