X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Won't ask to save my tabs on closing all

Posted

Firefox no longer asks to save tabs before closing firefox. It warns me that it is about to close all tabs but no longer asks to save them.

Mike Kay (aka Elrikk)

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.1 r53
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • iTunes Detector Plug-in
  • DivX Web Player version 1.4.3.4
  • npdivxplayerplugin
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729)

More Information

Morbus 134 solutions 2338 answers

Are the tabs restored on startup if you quit? If they aren't, it's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode (don't forget to select Disable all add-ons when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and themes and this one for plugins.

If you need support for one of your add-ons, you'll have to contact its author.

If the problem does not disappear when all add-ons are disabled, please tell me, so we can work from there. Please have no fear of following my instructions to the line, as all can be easily undone.

If tabs are restored when you start again, even though you didn't click a Save and Quit button, then I think it's a setting on the options screen. Go into Tools > Options > Tabs and tick Warn me when closing multiple tabs.

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96694 answers

You can reset the warn prefs on the about:config page via the right-click context menu.


To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

paulj 0 solutions 3 answers

I've tried the safe-mode start, disabling everything except my history, yet still the issue persists. Firefox 3.6....I click the top-right x to close the browser, no prompt, and when I restart, no saved tabs.

Further assistance would be greatly appreciated.

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96694 answers

If you use Remove recent browsing, search and download history in Firefox 3.5 and later to clear the 'Browsing History' when you close Firefox then restoring tabs from the last session ("Save & Quit" or "Show my windows and tabs from last time") doesn't work.

paulj 0 solutions 3 answers

I also verified the about:config sections posted by cor-el, with zero success. Each one was already set to the default value. I toggled each one and toggled it back, hoping this might set a flag correctly, but that tactic also failed to yeild results. Any other ideas appreciated, otherwise I'll be removing firefox and hoping for the best after a reinstall.

paulj 0 solutions 3 answers

Ah, that was it! Thanks cor-el!

ferikfox 0 solutions 1 answers

Helpful Reply

My browser.showQuitWarning setting was set to False. I set it to True while ensuring that browser.warnOnQuit was still True. Now I am prompted to save my tabs when I exit.

Also, if you don't Save your session when you exit, you should still be able to restore it next time you start Firefox by clicking History > Restore Previous Session.

Source

Modified by ferikfox

car54 0 solutions 2 answers

Helpful Reply

Thanks ferikfox, as I understood your post more clearly, and your first fix worked (my QuitWarning was set on False). Your second idea is also a good reminder of the History/Restore option.  :-)

bricko 0 solutions 4 answers

Ive checked all the ABOUT items....all are set as you state. Still nothing works. Was just reading web, and tried to close like usual...now it wont save my tabs. Did nothing. Have you screwed it up by deleting this option.....put i back if so.

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96694 answers

Firefox 4 saves the previous session automatically, so there is no longer need for the dialog asking if you want to save the current session.
Use "File > Exit" or "Firefox > Exit" (Mac: "Firefox > Quit Firefox") if you want to restore multiple windows.
You can use "History > Restore Previous Session" to get the previous session at any time.
You may need to click the orange/gray Firefox button to see History.
There is also a "Restore Previous Session" button on the default about:home Home page.

Another possibility is to use:

Make sure that you do not use Remove recent browsing, search and download history to clear the 'Browsing History' when you close Firefox.

Taiyeung 0 solutions 1 answers

To show windows and tabs from last time, click top left Firefox tab, options, options, general tab: 'when firefox starts' click down to 'show my windows and tabs from last time' click ok. I know that these are the steps for vista, I don't know about XP.

Mr-Love 0 solutions 9 answers

I can't believe Mozilla doesn't tell about the "browser.showQuitWarning" solution in their help article http://support.mozilla.com/en-US/kb/Firefox%20does%20not%20ask%20to%20save%20tabs%20and%20windows%20on%20exit?s=ask+to+save+tabs&as=s - instead they're just suggesting various silly workarounds that don't solve the problem at all, while there actually is a very simple and perfect solution to it.

Modified by Mr-Love

nickelbooks 0 solutions 1 answers

I found this article: http://support.mozilla.com/en-US/kb/Session%20Restore#w_configuring-session-restore

it says that you need to configure it in the Tools menu when you've updated to the new version. I was a bit perturbed myself after updating to 7, that when I opened up the browser all of my tabs had gone. I use them at work, and now I have to go through the history to find the ones I lost!

dmart 0 solutions 3 answers

I think this worked on my old computer but I need to set it up again on my new computer to get tabs to save and close at the end of my session. I remeber the about config part the the rest of your description I cut off so I don't know what to change in those settings. Can you help me. I am now running windows 7 not xp like before when I did it.

dmart 0 solutions 3 answers

Ok I did not figure out to save and quit but I did find out you can restore your last session. Click on your history tab at the top tool bar then you should see restore last session. Second one down on the menu. Click that and it should get the tabs all back. Still want to save them if anyone has an answer.

dmart 0 solutions 3 answers

Absolutely worked. Love it thank you very much for fixing this for me.

TPAKTOPA 0 solutions 3 answers

Hi, I just have the same problem and I found a solution in the forums but never the whole thing in one post, so I'll post it: First as ToneE says "

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference browser.tabs.warnOnClose, if its value is set to false, double-click on it to change its value to true
  4. Repeat this for these 3 preferences browser.warnOnQuit, browser.warnOnRestart and browser.showQuitWarning"

and second. You need to set: Firefox/Tools > Options > General > Startup: "When Firefox Starts": "Show my home page". and your favourite firefox pop up "Save and Quit" question will appear again. If the last option is set on "Show my windows and tabs from last time" the browser want ask ou anything when you're closing it. ENJOY :)

tabtabthesilly 0 solutions 1 answers

I've tried that, and the window that asks whether you want to save the tabs still don't appear. I have selected it to save tabs and "don't ask again" before, and most times it does save my tabs, but sometimes it doesn't, so I want to get the window back to make sure it does save...any solution? Thanks!