X
Tap here to go to the mobile version of the site.

Support Forum

Can not display Japanese characters in Firefox, even though I chose Japanese in Tools-Content menu. Thank you for help!

Posted

Japanese characters on different websites are not displayed properly. I can only see squares with numbers instead.

Japanese characters on different websites are not displayed properly. I can only see squares with numbers instead.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 9.0 r28
  • Default Plug-in
  • Shockwave Flash 10.1 r53
  • Picasa plugin
  • Adobe Acrobat Plug-In Version 7.00 for Netscape
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

More Information

DaveRo 18 solutions 175 answers

Helpful Reply

You're probably viewing the website in the wrong character set.

Try View > Character Encoding > some Japanese encodings, or UTF8 or 16

The website itself should specify the encoding. The default encoding - in Options > Content - is only used if the website doesn't specify an encoding. Maybe the website you're looking at specifies the wrong encoding.

You're probably viewing the website in the wrong character set. Try View > Character Encoding > some Japanese encodings, or UTF8 or 16 The website itself should specify the encoding. The default encoding - in Options > Content - is only used if the website doesn't specify an encoding. Maybe the website you're looking at specifies the wrong encoding.
cor-el
  • Top 10 Contributor
  • Moderator
17768 solutions 160699 answers

Helpful Reply

Make sure that you have installed East Asian language support:

Make sure that you have installed East Asian language support: *http://en.wikipedia.org/wiki/Help:Multilingual_support_%28East_Asian%29 Wiki: Help:Multilingual support (East Asian) *http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/int_pr_install_languages.mspx?mfr=true - Microsoft Windows XP - Install East Asian language files on your computer

Question owner

Make sure that you have installed East Asian language support:

cor-el, I guess this is the point. However the wiki article says "In order to display Asian characters in your browser, download and install the Microsoft Global Input Method Editors (IMEs) ... This is the system extension that provides the language support to your English Windows system when you are using Internet Explorer." - does it mean that it will ONLY help in Windows Explorer while I prefer working in Mozilla Firefox?

''Make sure that you have installed East Asian language support:'' '''cor-el''', I guess this is the point. However the wiki article says "In order to display Asian characters in your browser, download and install the Microsoft Global Input Method Editors (IMEs) ... This is the system extension that provides the language support to your English Windows system when you are using Internet Explorer." - does it mean that it will ONLY help in Windows Explorer while I prefer working in Mozilla Firefox?

Modified by Ruth.Benedict

miwashi 0 solutions 5 answers

How would I do this in firefox 4, since there is no view toolbar?

How would I do this in firefox 4, since there is no view toolbar?
cor-el
  • Top 10 Contributor
  • Moderator
17768 solutions 160699 answers

You can access the character encoding via Firefox > Web Developer > Character Encoding


Press F10 or press and hold the Alt key down to bring up the "Menu Bar" temporarily.

You can access the character encoding via Firefox > Web Developer > Character Encoding ---- Press F10 or press and hold the Alt key down to bring up the "Menu Bar" temporarily.
KkHhSs 0 solutions 1 answers

I had absolutely no problem until about about a week ago, maybe less. Suddenly, I couldn't see Japanese characters anymore, just the boxes with4 numbers and/or letters inside them. So, has there been some update that interfered with viewing them?

The same thing is happening with Korean characters.

On my other computer, I have Firefox/3.6.17, and it continues to display Japanese and Korean characters correctly.

I had absolutely no problem until about about a week ago, maybe less. Suddenly, I couldn't see Japanese characters anymore, just the boxes with4 numbers and/or letters inside them. So, has there been some update that interfered with viewing them? The same thing is happening with Korean characters. On my other computer, I have Firefox/3.6.17, and it continues to display Japanese and Korean characters correctly.

Modified by KkHhSs

cor-el
  • Top 10 Contributor
  • Moderator
17768 solutions 160699 answers

Try to toggle some of the Boolean gfx font_rendering prefs on the about:config page to disable some features.

Filter: gfx

gfx.direct2d.disabled (f -> t)
gfx.direct2d.force-enabled (f)
gfx.font_rendering.cleartype.always_use_for_content (f)
gfx.font_rendering.cleartype.use_for_downloadable_fonts (t)
gfx.font_rendering.directwrite.enabled (f)
gfx.font_rendering.directwrite.use_gdi_table_loading (t) /questions/782325
gfx.use_text_smoothing_setting (f)

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.
You can use the Filter bar at to top of the about:config page to locate a pref more easily.

Try to toggle some of the Boolean gfx font_rendering prefs on the about:config page to disable some features. Filter: gfx gfx.direct2d.disabled (f -> t) gfx.direct2d.force-enabled (f) gfx.font_rendering.cleartype.always_use_for_content (f) gfx.font_rendering.cleartype.use_for_downloadable_fonts (t) gfx.font_rendering.directwrite.enabled (f) gfx.font_rendering.directwrite.use_gdi_table_loading (t) [/questions/782325] gfx.use_text_smoothing_setting (f) ---- To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br /> If you see a warning then you can confirm that you want to access that page.<br /> You can use the Filter bar at to top of the about:config page to locate a pref more easily.
d.osboo 0 solutions 3 answers

Alas, it was the "Constant Guard" security program that was provided by Comcast (my internet provider). As soon as I uninstalled that, the problem was fixed.

Alas, it was the "Constant Guard" security program that was provided by Comcast (my internet provider). As soon as I uninstalled that, the problem was fixed.