X
Tap here to go to the mobile version of the site.

Support Forum

more websites are using a link to a .ashx file to view a .pdf file. On a Mac this is only viewable using Safari. Firefox displays an error message saying the file type is not recognized. Can anyone help?

Posted

for examle: go to http://www.threeriversparks.org/parks/elm-creek-park.aspx Now try to open the .pdf links to Summer or Winter maps in firefox American Family insurance uses the same link type to view .pdf files for online billing and policy viewing.

for examle: go to http://www.threeriversparks.org/parks/elm-creek-park.aspx Now try to open the .pdf links to Summer or Winter maps in firefox American Family insurance uses the same link type to view .pdf files for online billing and policy viewing.

Additional System Details

Installed Plug-ins

  • Garmin Communicator Plug-in Version 2.9.1.0
  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • npmnqmp 071701000001
  • Office Live Update v1.0
  • iPhoto6
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Java Plug-In 2 for NPAPI Browsers
  • 3.0.50106.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.7
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r53

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

More Information

I can only do it from Safari on Mac or IExplorer on Windows, neither OS works with Firefox.

DaveRo 18 solutions 175 answers

I tried that link (on linux) and it invited me to download the pdf or view it in my pdf viewer (as a separate program because by choice I don't have a pdf viewer plugin)

The fact that it's an aspx web page is irrelevant to your problem - unless you mean that you can't view the page at all.

I don't know Macs, put I think you either need a separate pdf viewer program or a pdf plugin in Firefox. Adobe Reader will of course do both.

I tried that link (on linux) and it invited me to download the pdf or view it in my pdf viewer (as a separate program because by choice I don't have a pdf viewer plugin) The fact that it's an aspx web page is irrelevant to your problem - unless you mean that you can't view the page at all. I don't know Macs, put I think you either need a separate pdf viewer program or a pdf plugin in Firefox. Adobe Reader will of course do both.

Modified by DaveRo

maxglitz 0 solutions 4 answers

I wonder if the original poster meant ".aspx" rather than ".ashx" because I cannot view these .aspx files in Firefox no matter how I try to open them once downloaded. I tried his/her link with the same result, a downloaded .aspx file. Also, my Preview program which reads pdf files will not open .aspx files either. Only when I change the extension on the filename to ".pdf" will it open with my reader. Like the original poster, I have no problem viewing any of these files in Safari. I wouldn't think that Firefox would need an odd work-around like changing the downloaded file's extension to ".pdf" in order to see it in another program, like my Preview.

I wonder if the original poster meant ".aspx" rather than ".ashx" because I cannot view these .aspx files in Firefox no matter how I try to open them once downloaded. I tried his/her link with the same result, a downloaded .aspx file. Also, my Preview program which reads pdf files will not open .aspx files either. Only when I change the extension on the filename to ".pdf" will it open with my reader. Like the original poster, I have no problem viewing any of these files in Safari. I wouldn't think that Firefox would need an odd work-around like changing the downloaded file's extension to ".pdf" in order to see it in another program, like my Preview.
cor-el
  • Top 10 Contributor
  • Moderator
13085 solutions 119782 answers

The file is send as application/pdf , so if you have a program for that file type then it should work.

See View PDF files in Firefox without downloading them

The [http://www.threeriversparks.org/~/media/Maps/PDFs/Park%20Detail/Summer/elm_creek_summer.ashx file] is send as application/pdf , so if you have a program for that file type then it should work. See [[Opening PDF files within Firefox]]
lori1013@aol.com 0 solutions 1 answers

Helpful Reply

Okay, I had this problem and finally figured out what to do. Open the Finder window and in the User location choose Downloads. Once the icons pop up, look for the files with the .aspx extension. Right-click one of them. Click on Open with, then click Other. Scroll through until you see Adobe Reader, and click it. Most importantly, check the little box at the bottom of the window that says "Always open with". Click the Open button, and it will open in Adobe Reader. I did this with about 5 files, and then it started listing Adobe Reader in the "Open with" bar on its own. I tested it by trying to download a new .aspx file, and it worked! I hope you have success.

Okay, I had this problem and finally figured out what to do. Open the Finder window and in the User location choose Downloads. Once the icons pop up, look for the files with the .aspx extension. Right-click one of them. Click on Open with, then click Other. Scroll through until you see Adobe Reader, and click it. Most importantly, check the little box at the bottom of the window that says "Always open with". Click the Open button, and it will open in Adobe Reader. I did this with about 5 files, and then it started listing Adobe Reader in the "Open with" bar on its own. I tested it by trying to download a new .aspx file, and it worked! I hope you have success.

Question owner

lori1013, Your suggestion worked. It took trying 5 times as you said, then when I tried to open it the 6th time it opened itself without the other steps. Wierd! I had tried what you suggested before but only 1 time. Why would you try 5 times? Why does this work? I really don't care about the answer to these last 2 questions, I'm just so thankful that you tried it, told me and that it works now. Thank you, thank you, THANK YOU!

lori1013, Your suggestion worked. It took trying 5 times as you said, then when I tried to open it the 6th time it opened itself without the other steps. Wierd! I had tried what you suggested before but only 1 time. Why would you try 5 times? Why does this work? I really don't care about the answer to these last 2 questions, I'm just so thankful that you tried it, told me and that it works now. Thank you, thank you, THANK YOU!
kevfr 0 solutions 1 answers

Helpful Reply

I've had this problem for 3 years. And I can see that questions were posted by others in 2006. The only answer that works for me is to ignore the Firefox error message. Save the document from downloads onto my desktop. Change the .ashx ending to .pdf and confirm that. Then it opens in Preview.

Neither the Shockwave nor the Adobe tricks work on my mac.

How come Firefox can has not dealt with this error 4 years on and more "modernising" websites use this format? Please?

I've had this problem for 3 years. And I can see that questions were posted by others in 2006. The only answer that works for me is to ignore the Firefox error message. Save the document from downloads onto my desktop. Change the .ashx ending to .pdf and confirm that. Then it opens in Preview. Neither the Shockwave nor the Adobe tricks work on my mac. How come Firefox can has not dealt with this error 4 years on and more "modernising" websites use this format? Please?
informationau 0 solutions 1 answers

Great ideas, I'm sure, but the problem is with ".ashx" files, not .aspx files.

If somebody finds a method for Firefox to display these files, I'm sure it would be really useful for all us Mac users out here.

Great ideas, I'm sure, but the problem is with ".ashx" files, not .aspx files. If somebody finds a method for Firefox to display these files, I'm sure it would be really useful for all us Mac users out here.

Modified by informationau

dwdoug 0 solutions 1 answers

The original question is really for .ashx files (not .aspx files). Although the .ashx file is a pdf file, it cannot be opened by Preview. So I followed one of the suggestions above (thanks to lori1013) to associate the extension .ashx with Adobe Reader. (save the file, right-click on the file name, select "Open With", find Adobe Reader, check the "Always Open With" box).

Now when I click the link on a web site with a .ashx file, Firefox warns me it may be an application and will be opened by Adobe Reader. I click on Open and it works!

The original question is really for .ashx files (not .aspx files). Although the .ashx file is a pdf file, it cannot be opened by Preview. So I followed one of the suggestions above (thanks to lori1013) to associate the extension .ashx with Adobe Reader. (save the file, right-click on the file name, select "Open With", find Adobe Reader, check the "Always Open With" box). Now when I click the link on a web site with a .ashx file, Firefox warns me it may be an application and will be opened by Adobe Reader. I click on Open and it works!

Modified by dwdoug

Rich 0 solutions 3 answers

I had just switched to Firefox on my iMac and was having the same problem and your solution worked for me. But, as you say, if this problem has been around for four years why hasn't it been fixed? I will be forced to try Chrome or worse, go back to Safari. All my online bill pays use .aspx files.

I had just switched to Firefox on my iMac and was having the same problem and your solution worked for me. But, as you say, if this problem has been around for four years why hasn't it been fixed? I will be forced to try Chrome or worse, go back to Safari. All my online bill pays use .aspx files.
Rich 0 solutions 3 answers

My reply was to KEVFR. I'm sorry, I thought since I hit the "reply" at the bottom of his post that the reply would immediately follow his post.

My reply was to KEVFR. I'm sorry, I thought since I hit the "reply" at the bottom of his post that the reply would immediately follow his post.
Rich 0 solutions 3 answers

This is a reply to dwdoug. I just followed your instructions and they worked perfectly, eliminating the need to download the file, and then change the extension to .pdf,

Thank you so much.

Rich

This is a reply to dwdoug. I just followed your instructions and they worked perfectly, eliminating the need to download the file, and then change the extension to .pdf, Thank you so much. Rich
dhansens 0 solutions 1 answers

Here is a "brute force" solution if nothing else works. It appears that the applications settings (accessed in the preferences menu on the Mac) can get confused over a period of time so that Firefox isn't taking the right action with respect to some file types. This can be re-set by forcing Firefox to use new applications settings. Unless you've done a lot of specialization of your settings, this might be a useful solution.

If you go to the Troubleshooting Information directory under the Help menu and then click the Show In Finder button for your Profile Directory, you can find where your Firefox profile information is stored. Open the Profile Directory folder (it will have a computer-generated name like 6jmzwu5b.default) and find the mimeTypes.rdf folder. This folder contains all of the descriptions for links between filetypes and applications. Rename this file to something like mimeTypes old.rdf so you can go back to the old folder if you later wish to. This will force Firefox to generate a new mimeTypes.rdf file and will enable you to redefine how it treats aspx and ashx files (along with all other file types that you interact with on the internet). Close the folders and re-start Firefox. Now go to a link on the internet that offers you a ashx or aspx file for download. Firefox will now ask you how you want to treat these files, select download, or open with Adobe, or another option that you prefer, and voila, it now works.

If you don't like the result over-all, you can rename the old folder back to mimeTypes.rdf and you're back where you started. If you're smarter than I am, you might be able to figure out how to edit the mimeTypes.rdf file to fix the aspx and ashx file handling without losing everything else. I haven't been able to figure that out, yet.

Here is a "brute force" solution if nothing else works. It appears that the applications settings (accessed in the preferences menu on the Mac) can get confused over a period of time so that Firefox isn't taking the right action with respect to some file types. This can be re-set by forcing Firefox to use new applications settings. Unless you've done a lot of specialization of your settings, this might be a useful solution. If you go to the Troubleshooting Information directory under the Help menu and then click the '''Show In Finder button''' for your Profile Directory, you can find where your Firefox profile information is stored. Open the Profile Directory folder (it will have a computer-generated name like 6jmzwu5b.default) and find the '''mimeTypes.rdf''' folder. This folder contains all of the descriptions for links between filetypes and applications. Rename this file to something like '''mimeTypes old.rdf''' so you can go back to the old folder if you later wish to. This will force Firefox to generate a new '''mimeTypes.rdf '''file and will enable you to redefine how it treats aspx and ashx files (along with all other file types that you interact with on the internet). Close the folders and re-start Firefox. Now go to a link on the internet that offers you a ashx or aspx file for download. Firefox will now ask you how you want to treat these files, select download, or open with Adobe, or another option that you prefer, and voila, it now works. If you don't like the result over-all, you can rename the old folder back to '''mimeTypes.rdf''' and you're back where you started. If you're smarter than I am, you might be able to figure out how to edit the''' mimeTypes.rdf '''file to fix the aspx and ashx file handling without losing everything else. I haven't been able to figure that out, yet.

Modified by dhansens

DCHowell 0 solutions 1 answers

You should be able to open them with Foxit Reader or any other PDF reader

You should be able to open them with Foxit Reader or any other PDF reader