X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Navigation tool bar does not display URL

Posted

When I go to a web site, the section of the navigation tool bar that displays the URL of the page no longer shows the http://www URL address as it always did in the past. The size of that part has shrunk. The area where you type in URL for search engine has expanded. I have no problems with the navigation bar, history, bookmarks, tabs, etc. Only problem is the URL does not display the page. Even this page has no URL shown on the navigation bar. All it has is the logo for mozilla and when I put the cursor over it, it says "Web site does not supply identity information." The same thing shows for every site I go to. Yes, I can bookmark the page with no problems and can use bookmarks to return to the page. But no URL is actually displayed like it always did in the past. Oh, I have an IMac and use a razor keyboard.

Chosen solution

Hello.

You should be able to resize the location bar, if the search bar is to its right, by just dragging the space between the location bar and the search bar.

If that doesn't solve your problems, it's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode (don't forget to select Disable all add-ons when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and themes and this one for plugins.

If you need support for one of your add-ons, you'll have to contact its author.

If the problem is not disappears when all add-ons are disabled, please tell me, so we can work from there. Please have no fear of following my instructions to the line, as all can be easily undone.

Read this answer in context 8

Additional System Details

This happened

Every time Firefox opened

This started when...

a couple days ago

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • iPhoto6
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r53
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

More Information

Spent hours searching the Firefox support and couldn't find anything even remotely close.

Morbus 134 solutions 2338 answers

Chosen Solution

Hello.

You should be able to resize the location bar, if the search bar is to its right, by just dragging the space between the location bar and the search bar.

If that doesn't solve your problems, it's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode (don't forget to select Disable all add-ons when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and themes and this one for plugins.

If you need support for one of your add-ons, you'll have to contact its author.

If the problem is not disappears when all add-ons are disabled, please tell me, so we can work from there. Please have no fear of following my instructions to the line, as all can be easily undone.

Helpful Reply

Thank you. It was a simple matter of resizing the location bar so the URL address showed. I had no idea you could change it. I'm such a dunce, but then I'm not a geek! LOL

Thanks again.

WilmaFlintsone 0 solutions 1 answers

I tried disabling my add-ons, but it didn't work. I did see the location bar when I started up in safe mode, however. Not sure what to try next.

Morbus 134 solutions 2338 answers

Wilma, if the location bar was shown, what was the other problem? I'm kind of lost here, I'm sorry :\

kbear 0 solutions 1 answers

I had this problem when I switched to an external monitor with a different resolution. I tried to move my mouse to the area between the address and search fields but could not get the arrow icon that allows you to stretch/shrink the address bar. Turned out that a customised icon (from customise toolbar) which I had placed between the addr & search fields prevented this. As soon as I removed it, I was able to adjust the size again.