Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

MSN Hotmail emails will not print properly in Firefox 3.6.8, but do in IE

  • 5 replies
  • 61 have this problem
  • Last reply by carodon

more options

MSN Hotmail emails will not print properly in Firefox 3.6.8, but do in IE8. All Firefox add-on's and my printer driver are up to date. This just started yesterday. Firefox will only print a portion of the message with blank pages with a header in between.

This happened

Every time Firefox opened

== Yesterday

All Replies (5)

more options

I've confirmed this problem on Windows XP as well as Mac OS X (10.5.8).

more options

Firefox has some printing bugs that appear when the page designer uses certain style rules. There's no immediate prospect that Firefox will be fixed, but of course could be changed at any time. Until then, you can use the Stylish extension to override the styles on, and many other sites that could use a tweak.

If you're inclined to try this:

(1) Install Stylish

(2) Add a new user style

Tools > Add-ons > User Style tab > Write New Style button

Give it any name you like (e.g., Fix Hotmail Printing) and then copy and paste the following style rule text into the large edit area:

@namespace url(;

@-moz-document domain("") {

 .PrintContent .ReadMsgBody .ExternalClass {display:block !important}



Compare with my screen shot for reference.

Explanation: this overrides the style from display:inline-block back to display:block.

Works for me. Any luck?

Modified by jscher2000

more options

Thank you so much jscher2000. Your tips is really helpful.

Now I can print my Live mail from firefox without any problem.

more options

This fix resolved the problem with Firefox printing extra pages when using Hotmail (but no problem experienced when printing via IE browser)?

[Using Win7 - 32 bit & Firefox v3.6.10]

For example, it was printing then email header only on 1st page (with balance of page blank), email content on the 2nd page, and a blank page for 3rd page.

Excellent advice...thank you!

Modified by mtbright

more options

my solution is to just stop using firefox and switch to internet explorer works just fine