X
Tap here to go to the mobile version of the site.

Support Forum

My hotmail account isn't working so they advised me to upgrade my Firefox which I tried to do but the new version wouldn't download and I got a "corrupt file" message.

Posted

I tried to upgrade to a newer Firefox system because Hotmail told me they no longer supported my Firefox, but when I tried to upgrade, following the download, I got a message that said "corrupt file."

This happened

Every time Firefox opened

I tried to upgrade to a newer Firefox system because Hotmail told me they no longer supported my Firefox, but when I tried to upgrade, following the download, I got a message that said "corrupt file." == This happened == Every time Firefox opened

Additional System Details

Installed Plug-ins

  • -Netscape Navigator Default Plug-in
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 9.0 r124
  • Java 1.3.1 Plug-in
  • Java 1.3.1 Plug-in (CFM)
  • Macromedia Shockwave for Director Netscape plug-in, version 8.5.1

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20

More Information

There are 2 extensions: DOM Inspector 1.8.1.20 and Talkback 2.0.0.11.

Morbus 135 solutions 2340 answers

Hello Gary.

Yes, you should update as soon as possible. I have to remind you that the version of Firefox you are using at the moment has been discontinued and is no longer supported. On top of this, it has known unpatched bugs and security problems. I urge you to update to the latest version of Firefox, for maximum security, stability, performance and usability. You can get it for free, as always, at getfirefox.com.

Are you still getting corrupt file after downloading from the official site?

Hello Gary. Yes, you should update as soon as possible. I have to remind you that the version of Firefox you are using at the moment has been discontinued and is no longer supported. On top of this, it has known unpatched bugs and security problems. I urge you to update to the latest version of Firefox, for maximum security, stability, performance and usability. You can get it for free, as always, at [http://www.getfirefox.com getfirefox.com]. Are you still getting corrupt file after downloading from the official site?
TXGuy 87 solutions 861 answers

If your OSX version is 10.3.9 or older you have the latest version of Firefox (version 2.0.0.20) available for your OS. To upgrade to a newer version of Firefox, you will need to upgrade your operating system to OSX 10.4 or newer.

Your versions of Shockwave Flash (aka Adobe Flash or FlashPlayer) and Macromedia Shockwave for Director (aka Shockwave Player) are both way out-of-date and probably contain security risks.

Check (some NOT ALL) of your plugins here: http://www.mozilla.com/en-US/plugincheck/

See: http://support.mozilla.com/en-US/kb/Managing+the+Flash+plugin http://support.mozilla.com/en-US/kb/Using+the+Shockwave+plugin+with+Firefox

Also see: http://support.mozilla.com/en-US/kb/Using+the+Java+plugin+with+Firefox

If your OSX version is 10.3.9 or older you have the latest version of Firefox (version 2.0.0.20) available for your OS. To upgrade to a newer version of Firefox, you will need to upgrade your operating system to OSX 10.4 or newer. Your versions of Shockwave Flash (aka Adobe Flash or FlashPlayer) and Macromedia Shockwave for Director (aka Shockwave Player) are both <u>'''way out-of-date'''</u> and probably contain security risks. Check (some NOT ALL) of your plugins here: http://www.mozilla.com/en-US/plugincheck/ See: http://support.mozilla.com/en-US/kb/Managing+the+Flash+plugin http://support.mozilla.com/en-US/kb/Using+the+Shockwave+plugin+with+Firefox Also see: http://support.mozilla.com/en-US/kb/Using+the+Java+plugin+with+Firefox