X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

bing maps not working

Posted

Bing maps has stopped working completely. I,ve used this extensively in the past. Just stopped August 2, 2010. I Have mac 10.6.4 & Firefox 3.6.8. I don't see any comments or posts on this problem at Bing community forums.

URL of affected sites

http://www.bing.com/maps/

Additional System Details

Installed Plug-ins

  • -Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • DivX Web Player version 1.4.0.233
  • RealPlayer Plugin
  • iPhoto6
  • Java Plug-In 2 for NPAPI Browsers
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r53

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

More Information

help>troubleshooting information never comes up in my help inquiry w/firefox , though I don't see answers in previous questions.

Question owner

Same problem. Enter location, click, nothing. Working fine in Safari and Chrome.

Question owner

Not working in FF, working in IE but has a popup that is affecting the maps.

Morbus 134 solutions 2338 answers

Hello everyone.

It's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode (don't forget to select Disable all add-ons when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and themes and this one for plugins.

If you need support for one of your add-ons, you'll have to contact its author.

If the problem does not disappear when all add-ons are disabled, please tell me, so we can work from there. Please have no fear of following my instructions to the line, as all can be easily undone.

magicfrizbees 0 solutions 1 answers

Same problem here - Firefox 3.6.8 / Windows XP SP3 / Norton Internet Security 17.7.0.12. Safe mode with no add-ons does not help.

Worked fine a week or two ago. Still works fine in IE8.

Can't speak to those seeing the issue on Macs, but possibly some recent Windows or Norton update caused the issue - I tried reinstalled several older versions of Firefox (went back t0 3.6.3) which had worked fine. No go. You get to the main bing.com/maps page and nothing you enter or click on has any effect (other than the Bing tool bar across the top of the page "Web / Images / Video / Shopping / ... ")

bozilla 0 solutions 1 answers

Window 7 , microsoft security essentials, firefox 3.6.8. with the latest windows updates. Bing maps will not work. Disable all add-ons and extensions and ran firefox in safe mode but bing maps will not function. Bing map did work in the past

Knockpiker 0 solutions 3 answers

Me too, with Vista, FF3.6.8 & Avast Antivirus. Doesn't seem to be any constant set of factors, except Firefox + Bing Maps. Don't think it happened when I updated FF, so I suspect Microsoft have screwed something with an update. Not too may of us complaining tho'.

jorge11 0 solutions 1 answers

I added ghostery recently but have disabled that and adblock - rebooted etc Bing maps still do not function except in IE - also have not updated MS in some time so I don't think anything has changed at that end. Using Vista ff/3.6.6

Matt_O_ 0 solutions 2 answers

Bing Maps work great in Safari. Not in FF 3.6.6 or 3.6.8. Not working in "safe" mode either.

It's a rather recent issue. I've also tried changing "permissions.default.image" to 0, 1, and 2 in "about:config"

No success.

Modified by Matt_O_

Morbus 134 solutions 2338 answers

Can you please try it in a new (temporary) Firefox profile and see if the issue is still present? See this article to know how to create a new Firefox profile. Please report back the results.

Knockpiker 0 solutions 3 answers

Helpful Reply

Morbus - Bing maps now works fine with a new 'test' profile. Next step?

Morbus 134 solutions 2338 answers

That's an indicative that there's something wrong with your profile. You can try using safe mode to track down what it is, either by disabling add-ons, by putting your settings back to default and so on. Hopefully that will do it.

If it doesn't, you can always port your info from one profile to another:

http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

dmcff1 0 solutions 4 answers

Helpful Reply

SOLUTION . . . SOLUTION . . . SOLUTION

Short: Open "about:config", go to preference "dom.storage.enable" and reset or double click to "true".

However, read below and do your own searches for privacy issues.

Long: If you are on this page you probably went looking for an answer and found that Bing just changed its site http://www.bing.com/community/blogs/m.../bing-s-bringing-sexy-maps.aspx. They are now using dom.storage which is "a mechanism allowing web pages to store information with a web browser (similar to cookies) called “client-side session and persistent storage.” Although use of session storage is subject to a user’s cookie preferences, this preference allows it to be disabled entirely" http://kb.mozillazine.org/Dom.storage.enabled. You can set the default value, which is presently 5201 (5Mb) with the preference "dom.storage.default_quota" http://kb.mozillazine.org/Dom.storage.default_quota.

DOM Storage - DOM storage allows web sites to store information in a persistent manner on your computer, much like cookies but with greater capacity and efficiency. Some articles call the items supercookies. However, I disagree. I had the preference set to false, meaning theoretically nothing should be loaded and supercookies, LSO's, were still being found after the fact with the Better Privacy add on. This is something different.

Back in 2006 it was discussed that it was a bug (link not provided, hey, it was 2006) because if the cookies setting was set to block, then this info should be blocked too, otherwise an unscrupulous website could just circumvent cookies by using this storage. And, since you cannot limit its use to specific sites, you must disable it (set it to false) or find other security. I could not find why the ultimate resolution (to enable the storage) was reached, but the description of the preference seems to say it all, that is, they did not fix it because it "allows {the cookie preferences} to be disabled entirely". Not very comforting.

Once I found the offending preference, I searched it to see if others had a problem. Here, http://www.google.com/support/forum/p.../thread?tid=409d8ad649e1ef4e&hl=en it is a problem with google images. I had the same problem and do not now. The pages scroll and are properly paginated. As for the privacy issue, at least with the google site it was not entirely inoperable AND there was an alternative (a link to switch to the basic version).

This link http://www.dslreports.com/forum/r20186386-DOM-Storage-a-browser-priv... has a post by SUMware that addresses this:

"Understand your concerns.

The following will not alleviate all privacy issues, but there are two 'lesser known' Firefox addons that attempt to limit information leakage.

SafeCache is a Mozilla Firefox browser extension that protects your privacy by silently defending against cache-based tracking techniques. It allows embedded content to be cached, but segments the cache according to the domain of the originating page.

SafeHistory is a Mozilla Firefox browser extension that protects your privacy by silently defending against visited-link-based tracking techniques. It allows offsite visited links to be marked only if the browser's history database contains a record of the link being followed from the current site.

Modified by dmcff1

Knockpiker 0 solutions 3 answers

This is getting more complicated than I want to know about. However, I don't like the privacy implications of enabling this feature. On my default profile this line is set to false, on my 'test' profile (on which Bing works OK) this is indeed set to true. Unfortunately, the safecache/safehistory add-ons are not currently available for FF 3.6.8, so for the moment I'll rename the FF test profile to Bing Maps & use it only for that. I'll keep watching the thread tho.

shiyifan 0 solutions 1 answers

Thank you, dmcff1. My "dom.storage.enable" setting was "true', but Bing Map didn't work. I just change it to false and then to true. Bing map works in my Firefox now! Thank you.

c_laverne 0 solutions 7 answers

I FINALLY SOLVED MY HANGING, "STOPPED" LOADING AND FORCE QUIT PROBLEMS AFTER TRYING EVERYTHING SHORT OF ARCHIVE AND INSTALL.

I FINALLY SOLVED MY HANGING, "STOPPED" LOADING AND FORCE QUIT PROBLEMS AFTER TRYING EVERYTHING SHORT OF ARCHIVE AND INSTALL: I HAD TO RESTART "FORCED" TEN TIMES A DAY:

I UPDATED JAVA:

Java for Mac OS X 10.5 Update 9 http://support.apple.com/kb/HT4438

also

JavaEmbeddingPlugin 0.9.7.5

I have a PPC G5 dual 2.0 OSX 10.5.8

Firefox 3.6.16

Baddesley 0 solutions 1 answers

SOLVED, FIXED AT LAST! None of the above fixes worked for me but I have finally fixed the problem!

1. download the latest version of Firefox (I used 5.01) to your PC. 2. In Firefox, backup your Bookmarks (bookmarks/show all bookmarks/import & backup/backup) to somewher safe on your PC. 3. Uninstall Firefox, making sure you select to remove your current settings and preferences - it won't work if you don't do this! 4. Reboot your PC 5. Re-install Firefox from the file you've just downloaded. 6. Reboot your PC. 7. Restore your bookmarks from the backup you just made. 8. Test maps in Bing - it should now work! 9. Enjoy....

moose53 2 solutions 39 answers

I'm using Firefox 7.0.1 on top of Windows XP Professional. I, too, was not able to get Bing maps to work until I followed your suggestion, "dom.storage.enable" setting was "true', but Bing maps didn't work. I just changed it to false and then to true. Works beautifully now. Something seemed to be stuck.

Thanks.

Barb

Modified by moose53