X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I prevent Firefox from automatically starting when I boot-up my Mac in the morning?

Posted

Whenever I boot up my Mac in the morning Firefox automatically starts and displays my home page. I would only like to see the desk top with no applications running. I am running OSX 10.4.11 on my laptop.

== Started possibly a few weeks ago.

Additional System Details

Installed Plug-ins

  • -Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Java 1.3.1 Plug-in
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Shockwave Flash 10.0 r45
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.3) Gecko/20100401 YFF35 Firefox/3.6.3

More Information

zadmiral2 0 solutions 1 answers

This is something that started with the latest version of firefox. I'm very disappointed in mozilla on this one. This is a shameless attempt to gain browser market share. I hope that mozilla wakes up and removes this from the next update or people will start moving onto google chrome.


Click on the link below to learn how to stop this.


http://www.wikihow.com/Stop-an-Application-from-Opening-at-Startup-With-Mac-OS-X

Modified by zadmiral2

cavokdotcom 0 solutions 2 answers

I'm not sure about it being a shameless ploy, but that link, while a good first step doesn't solve this problem for me. There is no firefox object in my startup items to even remove..

I've tried digging through about:config to see if I could find anything there but with little luck. Perhaps someone with a better handle on the config screen could do a bit more digging..

For the record, my machine is a brand new powerbook with OSX Lion 10.7.2 and a fresh install of Firefox 9.0.1

cavokdotcom 0 solutions 2 answers

Hmm.. Okay I've done a bit more digging and tried the following two things before the last restart.. Not sure which one actually worked but give these a shot (one at a time) and let us know which is the actual solution! :)

1. Open Safari -> Preferences -> General

- change "Default Web Browser" to Safari
- Close all applications
- Relaunch Safari and change default browser back to Firefox. 

2. Remove the check from "Reopen windows when logging in" in the logout dialog and logout of the computer..

I suspect step 2 is actually the proper solution, but I did both so, hopefully one of them works for everyone else!