X
Tap here to go to the mobile version of the site.

Support Forum

Upgrade 3.6.7 - changed scrolling with arrow keys.

Posted

My arrow keys no longer function normally, but seem to have a new action assignment. I would like to go back to the default operation of these keys. I can't find any info for that. (using XP and new Firefox 3.6.7)

My arrow keys no longer function normally, but seem to have a new action assignment. I would like to go back to the default operation of these keys. I can't find any info for that. (using XP and new Firefox 3.6.7)

Chosen solution

Spoke too soon!

It appears that if you go to Tools->Options then click on Advanced and select the General tab, there is a check box "Always use the cursor keys to navigate within a page". Uncheck this and it scrolls with the arrow keys just as it used to.

Read this answer in context 1

Question owner

I liked using the up/down arrow keys for smooth scrolling. They do not seem to do this any more. Instead, they seem to move a cursor like in a word processor. The only thing is that due to many page layouts, pressing down arrow goes straight to the end of the document.

Also, because of this stupid "cursor" thing, I often see pages with a long blinking vertical line on the left of the layout. This is just plain distracting.

I liked using the up/down arrow keys for smooth scrolling. They do not seem to do this any more. Instead, they seem to move a cursor like in a word processor. The only thing is that due to many page layouts, pressing down arrow goes straight to the end of the document. Also, because of this stupid "cursor" thing, I often see pages with a long blinking vertical line on the left of the layout. This is just plain distracting.

Chosen Solution

Spoke too soon!

It appears that if you go to Tools->Options then click on Advanced and select the General tab, there is a check box "Always use the cursor keys to navigate within a page". Uncheck this and it scrolls with the arrow keys just as it used to.

Spoke too soon! It appears that if you go to Tools->Options then click on Advanced and select the General tab, there is a check box "Always use the cursor keys to navigate within a page". Uncheck this and it scrolls with the arrow keys just as it used to.
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

Helpful Reply

You toggle caret browsing, as that feature is called, with the F7 key.

See http://kb.mozillazine.org/Scrolling_with_arrow_keys_no_longer_works

You toggle caret browsing, as that feature is called, with the F7 key. See http://kb.mozillazine.org/Scrolling_with_arrow_keys_no_longer_works