X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

IDM CC 6.7 Extension blocked after upgrading to FireFox 3.6.6

Posted

Well everything was going fine till i upgraded to ver 3.6.6. After running two-three times,it says Firefox blocked IDM CC for your protection. And i really want that add on enabled as i use IDM as my download manager. Please hel me.

Additional System Details

Installed Plug-ins

Java and Flash Player

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

More Information

You can see this image for extra info.
http://bigpic.info/images/32375988541141924010.jpg

Helpful Reply

Hey pleasse help, i need that plugin to work! My internet connection really sucks and it helps me get my antivirus updates etc faster.

Helpful Reply

Situation/Fix-

The block was in error, and should have only applied to beta versions of Firefox 4.0 due to the large number of crashes it caused on that version. However, a programming error resulted in the extension being blocked on all Firefox versions.

The change has already been rolled back according to Bug 578433 listed here.

https://bugzilla.mozilla.org/show_bug.cgi?id=578443

However, browsers that have already blocked the extension may not immediately register the change. All Firefox browsers connected to the internet should have unblocked the extension within 24 hours, to my understanding.

"I need a fix for this right away though!"

First, restart your browser and see if the block persists.

Second, a new possible fix was just posted in that bug which may enable you to update your blocklist on demand, thus re-enabling the extension. Please see Comment #35 (directly linked).

https://bugzilla.mozilla.org/show_bug.cgi?id=578443#c35

Those in desperate need of the extension may wish to disable the extension blocklist functionality in Firefox, which should re-enable the extension (according to reports unconfirmed by me).

Instructions on how to do that are provided here.

http://support.mozilla.com/en-US/kb/Firefox+makes+unrequested+connections#Extension_blocklist_updating

I would personally encourage re-enabling the extension blocklist in a day or two, as it normally provides a valuable defense against the possibility of dangerous extensions being run.

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96771 answers

Copy and Paste this code in the Code field in the "Tools > Error Console" and click the Evaluate button to refresh that list.


Components.classes['@mozilla.org/extensions/blocklist;1'].getService(Components.interfaces.nsITimerCallback).notify(null);

Modified by cor-el

babalubas09 0 solutions 1 answers

The solution is: install the idm 6.04 of http://thepiratebay.org/torrent/6069471/Internet_Download_Manager_6.04_Build_2__Serial_%5BUT%5D.htm

Modified by babalubas09