X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox not showing all history

Posted

I can search History successfully if I know the right search terms, but Show All History is not working, it remains blank, so I cannot browse for sites I visited earlier.

Additional System Details

Installed Plug-ins

  • -Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • WebEx General Plugin Container Version 169
  • http://www.facebook.com/fbplugin/
  • RealPlayer Plugin
  • iPhoto6
  • DivX Web Player version 1.4.1.4
  • 4.0.50401.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Shockwave Flash 10.1 r53
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 GlobalMojoExt/2.0

More Information

Application Basics
Name
Firefox
Version
3.6.6
Profile Directory
Show in Finder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
DownloadHelper
4.6.5
true
Foxmarks Bookmark Synchronizer
0.84
false
foxmarks@kei.com
Read it Later
0.9929
false
isreaditlater@ideashower.com
GlobalMojo
2.0
true
{54c1cf71-dc28-408b-9fae-680a79fd3216}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage
http://www.weather.com/outlook/recreation/outdoors/hourbyhour/graph/USOR0118#
browser.startup.homepage_override.mstone
rv:1.9.2.6
browser.tabs.autoHide
true
browser.tabs.loadInBackground
false
extensions.lastAppVersion
3.6.6
font.minimum-size.x-western
12
font.name.serif.x-western
New York
font.size.fixed.x-western
15
network.cookie.prefsMigrated
true
places.last_vacuum
1274758002
print.macosx.pagesetup-2
PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUgQ29tcHV0ZXIvL0RURCBQTElT…
print.print_bgcolor
true
print.print_bgimages
true
print.print_command
print.print_downloadfonts
true
print.print_evenpages
true
print.print_footerleft
print.print_footerright
print.print_headerleft
print.print_headerright
print.print_in_color
true
print.print_margin_bottom
0.5
print.print_margin_left
0.5
print.print_margin_right
0.5
print.print_margin_top
0.5
print.print_oddpages
true
print.print_orientation
0
print.print_pagedelay
500
print.print_paper_data
0
print.print_paper_height
11.00
print.print_paper_size
2147385343
print.print_paper_size_type
1
print.print_paper_size_unit
0
print.print_paper_width
8.50
print.print_printer
print.print_reversed
false
print.print_scaling
1.00
print.print_shrink_to_fit
true
print.print_to_file
false
print.print_unwriteable_margin_bottom
56
print.print_unwriteable_margin_left
25
print.print_unwriteable_margin_right
25
print.print_unwriteable_margin_top
25
privacy.popups.showBrowserMessage
false
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Make sure that you not run Firefox in Private Browsing - Browse the web without saving information about the sites you visit mode. In Private Browsing mode some menu items are disabled (grayed) and features like visited links and disabled and not available. You are in Private Browsing mode if you see "Tools > Stop Private Browsing", possibly grayed. See Private Browsing - Browse the web without saving information about the sites you visit and http://kb.mozillazine.org/Issues_related_to_Private_Browsing ..... You enter Private Browsing mode if you select: Firefox > Preferences > Privacy > History: Firefox will: "Never Remember History" To see all History settings, choose: Firefox > Preferences > Privacy, choose the setting Firefox will: Use custom settings for history Uncheck: [[ ] "Automatically start Firefox in a private browsing session"


You can look at these prefs on the about:config page. http://kb.mozillazine.org/browser.history_expire_days (180) (also affects saved form data) http://kb.mozillazine.org/browser.history_expire_days_min (90)

To open the about:config page, type about:config in the location (address) bar and press the Enter key, just like you type the url of a website to open a website. If you see a warning then you can confirm that you want to access that page.

Question owner

Thanks, I have double-checked the settings you suggested, and recent history is still blank. I've attached screenshot of my settngs. I tried to visit the link, but The requested URL could not be retrieved While trying to retrieve the URL: http://kb.mozillazine.org/browser.history_expire_days The following error was encountered: * Connection Failed

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Did you check the setting of browser.history_expire_days ? That pref determines what is actually kept as history in places.sqlite and overrides browser.history_expire_days_min, which specifies what is kept in memory for quick access.

If the MozillaZine KB site is having problems then try again at a later time (seems to working fine now).

It is also possible that there is a problem with places.sqlite. See http://kb.mozillazine.org/Locked_or_damaged_places.sqlite