X
Tap here to go to the mobile version of the site.

Support Forum

Every time I log on to Fire fox I get the last page I viewed instead of my home page. This gets annoying. Are there any fixes for this?

Posted

Every time I log on to fire fox I get the last previewed page I was on when I logged off. I shut down all entries before logging off but it still does not go to the page I have as a home page.

This happened

Every time Firefox opened

== about a week ago

Every time I log on to fire fox I get the last previewed page I was on when I logged off. I shut down all entries before logging off but it still does not go to the page I have as a home page. == This happened == Every time Firefox opened == about a week ago

Chosen solution

Open the Options dialog and go to the General tab.

Check the setting "When Firefox Starts:" and make sure it is set to "Show my home page"

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • -Garmin Communicator Plug-In 2.9.2.0
  • 1.5.0532.0
  • Office Plugin for Netscape Navigator
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • np-mswmp
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • Default Plug-in
  • Shockwave Flash 10.1 r53
  • GEPlugin
  • Picasa plugin
  • 4.0.50524.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • Rhapsody Player Engine Plugin
  • Google Update
  • Java(TM) Platform SE binary
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729)

More Information

TonyE
  • Moderator
1044 solutions 8863 answers

Chosen Solution

Open the Options dialog and go to the General tab.

Check the setting "When Firefox Starts:" and make sure it is set to "Show my home page"

Open the Options dialog and go to the General tab. Check the setting "When Firefox Starts:" and make sure it is set to "Show my home page"