Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have DSL High-Speed with Earthlink, but it takes nearly 30 minutes for Firefox to bebin loading, including getting message "unresponsive script": I then press "continue" and wait three more minutes. This happens every time I turn on my PC (Windows XP Ho

  • 2 replies
  • 0 have this problem
  • Last reply by Morbus

more options

see above

This happened

Every time Firefox opened

== since downloading Firefox at an alternative to Internet Explorer

All Replies (2)

more options

Hello Howard.

It's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode (don't forget to select Disable all add-ons when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and themes and this one for plugins.

If you need support for one of your add-ons, you'll have to contact its author.

If the problem is not disappears when all add-ons are disabled, please tell me, so we can work from there.

more options

I have no add-ons I have checked DSL download speeds and they are normal, i.e. 0760 0380