X
Tap here to go to the mobile version of the site.

Support Forum

Firefox Downloads Do Not Work.

Posted

Firefox downloads don't open. When they appear in the download box and appear to finish downloading, I cannot click them. When I right click, the "Open" option is gray. I had this problem when I was using my Downloads folder so I switched to my Desktop folder but I have the same problem. Nothing appears on my Desktop or anywhere. This sucks.

This happened

Every time Firefox opened

== I downloaded earlier versions of Firefox.

Firefox downloads don't open. When they appear in the download box and appear to finish downloading, I cannot click them. When I right click, the "Open" option is gray. I had this problem when I was using my Downloads folder so I switched to my Desktop folder but I have the same problem. Nothing appears on my Desktop or anywhere. This sucks. == This happened == Every time Firefox opened == I downloaded earlier versions of Firefox.

Additional System Details

Installed Plug-ins

  • -Shockwave Flash 10.1 r53
  • Google Update
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • GEPlugin
  • 4.0.50524.0
  • Office Live Update v1.5
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Yahoo! activeX Plug-in Bridge
  • np-mswmp
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.3
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

Adblock Plus
FastestFox
Feedback
iWinGames Plugin
Media Converter
Microsoft .Net Framework Assistant

the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40310 answers

When you right-click a file in the Downloads window, can you use the Open Containing Folder menu item?

When you right-click a file in the Downloads window, can you use the '''Open Containing Folder''' menu item?
cor-el
  • Top 10 Contributor
  • Moderator
17585 solutions 159079 answers

It is possible that your anti-virus software is corrupting the downloaded files or otherwise interfering with downloading files by Firefox. You can try to disable the real-time (live) scanning of files in your anti-virus software temporarily to see if that makes downloading work. Do not forget to re-enable the scanning in your anti-virus software after you are finished with downloading and installing. .......... See http://kb.mozillazine.org/Unable_to_save_or_download_files (Disable virus scanning in Firefox preferences - Windows)

It is possible that your anti-virus software is corrupting the downloaded files or otherwise interfering with downloading files by Firefox. You can try to disable the real-time (live) scanning of files in your anti-virus software temporarily to see if that makes downloading work. Do not forget to re-enable the scanning in your anti-virus software after you are finished with downloading and installing. .......... See http://kb.mozillazine.org/Unable_to_save_or_download_files (Disable virus scanning in Firefox preferences - Windows)
ahzim8 0 solutions 1 answers

Helpful Reply

I know this was written a long time ago but I just came across the same problem today and thought I'd let everyone know how to fix it. It is actually said in the website provided above, but it's under "Disable virus scanning in Firefox preferences - Windows".

Open a new tab in Firefox and type about:config in the address bar. Then scroll down to browser.download.manager.scanWhenDone and change it to false. I just doubled clicked on it and it changed it to false immediately. Then close the tab and download away!

Prior to doing this, I had gone through all of my anti-virus software and disabled the real-time scanning but the "open" and "open containing folder" were still gray and it wouldn't show on my desktop either. As soon as I did the about:config, it worked. I hope this helps! :)

I know this was written a long time ago but I just came across the same problem today and thought I'd let everyone know how to fix it. It is actually said in the website provided above, but it's under "Disable virus scanning in Firefox preferences - Windows". Open a new tab in Firefox and type '''about:config''' in the address bar. Then scroll down to browser.download.manager.scanWhenDone and change it to false. I just doubled clicked on it and it changed it to false immediately. Then close the tab and download away! Prior to doing this, I had gone through all of my anti-virus software and disabled the real-time scanning but the "open" and "open containing folder" were still gray and it wouldn't show on my desktop either. As soon as I did the about:config, it worked. I hope this helps! :)