Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do I get "what happened:TypeError: this.installDir is null" message in a box when I open a new window?

  • 19 replies
  • 344 have this problem
  • Last reply by asif

more options

Whenever I try to open a new window, I get the following message: "what happened:TypeError: this.installDir is null". I have to click on OK for it to disappear and the new window to open.

== About a week ago

Whenever I try to open a new window, I get the following message: "what happened:TypeError: this.installDir is null". I have to click on OK for it to disappear and the new window to open. == About a week ago

All Replies (19)

more options

Same problem here, anybody help?

more options

i think SysAid software makes this.

more options

Same problem. It started last week.

more options

When i open new window i got

what happened:TypeError: this.installDir is null

more options

Same error since firefox updated so I am thinking it's not our fault...

more options

same thing... maybe happened after i installed ask toolbar by accident

more options

what happened:TypeError: Components.classes[';1'] is undefined

is the exact error

sry for two posts.(just woke up)

more options

hey guys click tools-options- u can see add-ons

click manage disable the java script

u will slove problems if u not u can contact me @


      by anurag kumre
more options

Its not a solution!! when clickin on addon firefox hangs up completely and after a while send a message:

Ein Skript auf dieser Seite ist eventuell beschäftigt oder es antwortet nicht mehr. Sie können das Skript jetzt stoppen oder fortsetzen, um zu sehen, ob das Skript fertig wird.

Skript: file:///C:/Program%20Files%20(x86)/Mozilla%20Firefox/components/nsExtensionManager.js:623

more options

uninstalling Firefox completly and new installation does not solve the problem neither!!!

more options

a comple uninstall of the ask-toolbar solved the problem!!

more options

I started Firefox in safe mode because when I tried clicking addons, nothing happened except I got a script on this page is busy and is not responding. Once in safe mode I clicked addons and then the extensions tab, I got rid of about 5 I never use and the problem was solved. Don't remember which but if you do them one at a time and restart in regular mode you could figure it out, I got rid of ones I don't use so it didn't matter to me. Thankfully one of them was the culprit!

more options

I suspect I saw (where?) a post from the manager of offering a solution. I took this to be an apology for damaging so many computers, but uninstalling has not fixed it.

more options

I recently started having that problem too. And it can't get any of the solution listed change the problem. Its pretty annoying. Why is the support not already out with a solution.

more options

Hi I finally started Firefox in Safe Mode as it was the only way to edit the Add-ons without it hanging. I uninstalled Yahoo and Gretech (no idea where the last one came from but it was there!) and an incompatible Deposit File toolbars, restarted Firefox and the problem was solved and all other addons that had stopped working are now ok.

I hope this helps

more options

I got this message: What happened:type error: this.installDir is nul after I installed MyWebSearchToolbar. Firefox says he was not able to install the toolbar and asks to re-install. Since then I cannot use my addons anymore , can someone help me?

more options

If you delete any toolbar with the "TypeError" problem goes away. I deleted it outside of Firefox using the normal Control Panel -> Add or Remove Programs system as it was listed there.

However, when you try to open the "add-on" section in the Firefox menu, there is a problem with reading a script...


You have to start Firefox in SafeMode with all add-ons disabled. Then delete any add-on that has an part to it (for me it was the toolbar).

This gets rid of the script problem.

Modified by WTHeck

more options

''comple uninstall of the ask-toolbar solved the problem''