X
Tap here to go to the mobile version of the site.

Support Forum

Firefox4Beta cannot stream netflix?

Posted

Netflix does not operate under firefox 4.0. I am running windows XP.

This happened

Every time Firefox opened

Netflix does not operate under firefox 4.0. I am running windows XP. == This happened == Every time Firefox opened

Additional System Details

Installed Plug-ins

  • -npmnqmp 07103010
  • Google Update
  • Shockwave Flash 10.1 r53
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • DivX Web Player version 2.0.2.40
  • 4.0.50524.0
  • Office Live Update v1.4
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Wacom Dynamic Link Library
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

More Information

Question owner

ditto

Watching instantly on your computer

Our apologies — streaming is not supported on this browser. Complete System Requirements

To watch instantly, you'll need a computer that meets the following minimum requirements:

   Windows
       Windows XP with Service Pack 2, Vista or Windows 7
       Internet Explorer 6.0 or higher; or Firefox 2 or higher
       1.2 GHz processor
       512 MB RAM
   Mac
       An Intel-based Mac with OS 10.4.8 or later
       Safari 3 or higher; or Firefox 2 or higher
       1 GB RAM
ditto Watching instantly on your computer Our apologies — streaming is not supported on this browser. Complete System Requirements To watch instantly, you'll need a computer that meets the following minimum requirements: Windows Windows XP with Service Pack 2, Vista or Windows 7 Internet Explorer 6.0 or higher; or Firefox 2 or higher 1.2 GHz processor 512 MB RAM Mac An Intel-based Mac with OS 10.4.8 or later Safari 3 or higher; or Firefox 2 or higher 1 GB RAM

Question owner

Same problem. Doesn't work on FF 4.0b1 running on Windows 7 Pro.

Same problem. Doesn't work on FF 4.0b1 running on Windows 7 Pro.

Question owner

same here

same here
loaba 0 solutions 1 answers

OS: Win 7 Pro Browser: Firefox 4 b2

Issue: same as OP

OS: Win 7 Pro Browser: Firefox 4 b2 Issue: same as OP
jscher2000
  • Top 10 Contributor
8797 solutions 71958 answers

Web sites use a number of different techniques to detect your browser version. If you want to see whether it is checking the user agent string, you could change it to the current string for Fx 3.6.8.

Normally I'd suggest Chris Pederick's User Agent Switcher add-on, but it isn't yet released for Firefox 4. So instead, you have to do a little work in the about:config pane.

First, select and copy the following to the clipboard:

general.useragent.override

Second, press Ctrl+t to open a new tab, type about:config in the location bar and press Enter. Click the button promising to be careful.

Right-click and choose New then String. Paste the name of the preference that you copied above, then put in a temporary value for the user agent string (e.g., temp).

Now switch back to this tab and copy the following:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 (.NET CLR 3.5.30729)

Now switch back to about:config and enter agent into the Filter box. A short list should appear containing your new entry in bold. Double-click to edit and paste the above.

To see your new fake user agent string in action, you can check this page:

http://dev.jeffersonscher.com/jstest.html

So, does all that make any difference with Netflix?

When you are done faking out web sites, you should clear that preference. Return to about:config, filter on agent, then right-click and choose Reset to remove the string and return Firefox to its normal behavior.

Web sites use a number of different techniques to detect your browser version. If you want to see whether it is checking the user agent string, you could change it to the current string for Fx 3.6.8. Normally I'd suggest Chris Pederick's User Agent Switcher add-on, but it isn't yet released for Firefox 4. So instead, you have to do a little work in the about:config pane. First, select and copy the following to the clipboard: general.useragent.override Second, press Ctrl+t to open a new tab, type about:config in the location bar and press Enter. Click the button promising to be careful. Right-click and choose New then String. Paste the name of the preference that you copied above, then put in a temporary value for the user agent string (e.g., temp). Now switch back to this tab and copy the following: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 (.NET CLR 3.5.30729) Now switch back to about:config and enter agent into the Filter box. A short list should appear containing your new entry in bold. Double-click to edit and paste the above. To see your new fake user agent string in action, you can check this page: http://dev.jeffersonscher.com/jstest.html So, does all that make any difference with Netflix? When you are done faking out web sites, you should clear that preference. Return to about:config, filter on agent, then right-click and choose Reset to remove the string and return Firefox to its normal behavior.
iiisis 0 solutions 1 answers

Helpful Reply

Check that you are using the current version of the Silverlight plug-in. The most recent update, as of 03/27/11, can be found here: http://www.microsoft.com/getsilverlight/get-started/install/default.aspx

Check that you are using the current version of the Silverlight plug-in. The most recent update, as of 03/27/11, can be found here: http://www.microsoft.com/getsilverlight/get-started/install/default.aspx
ABR423 0 solutions 2 answers

Helpful Reply

In order to get netflix streaming to work under Firefox 4 go to Tools-Options-Privacy Tab- Select use custom settings for history and uncheck Permanent private browsing mode. Refresh your netflix and your all set.

In order to get netflix streaming to work under Firefox 4 go to Tools-Options-Privacy Tab- Select use custom settings for history and uncheck Permanent private browsing mode. Refresh your netflix and your all set.
saneman 1 solutions 55 answers

Although this is for 4.0 beta, now the 5.0b2 does not stream, so I reverted back to 4.0.1 and left Nightly, Aurora and 5.0b2 on a separate HD. Guess I'll just be roughing it for a bit. If anyone knows how to fix it do tell.

Although this is for 4.0 beta, now the 5.0b2 does not stream, so I reverted back to 4.0.1 and left Nightly, Aurora and 5.0b2 on a separate HD. Guess I'll just be roughing it for a bit. If anyone knows how to fix it do tell.

Modified by saneman