X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Sometimes, when I click on the opened tab, it disappears or closes down.

Posted

Sometimes, when I click on inactive opened tab, it disappears or closes down. I am not able to reproduce it at will. So don't know whats causing it.

This happened

Not sure how often

== couple of months ago

Additional System Details

Installed Plug-ins

  • -Shockwave Flash 10.0 r32
  • The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • The IcedTea NPR Web Browser Plugin (using IcedTea6 1.8 (6b18-1.8-0ubuntu2)) executes Java applets.
  • Shockwave Flash 10.1 r53

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.2.6) Gecko/20100628 Ubuntu/10.04 (lucid) Firefox/3.6.6

More Information

Mozilla Firefox 3.6.6, 2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 08:03:28 UTC 2010 x86_64 GNU/Linux.

Ryan 20 solutions 231 answers

Are you sure your not clicking on the X to close the tab?

Question owner

I'm sure, I'm not clicking at 'x' marks, initially I thought I accidentally clicked where the 'x' is...and am very careful where i click now...but Its not the case. Because, no matter where u click an inactive tab, it first gets active, then only 'x' for closing the tab appears.

thanks, Cheers!!

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Do you have any tab related extensions?

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. You can use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions. You have to close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

Question owner

Hi, Thanks for the reply. No I do not have any tab related 'Add-on', but I will follow the procedure you mentioned.

Here is the scrshot of the add-ons I have..

cheers!!

Question owner

Sunny, we have an incomplete description of your problem, but it's possible that the inactive tab was for a dummy page opened when an application (e.g. the local PDF reader -- depending on your system) is started. I think it was called About.htm on my system. It should close automatically, I think, when the application is closed, but I have found instances when I found it needed to be closed manually. If this is the case then it's not a problem with your system, but a bug in the web programming.

Question owner

To Anonymous : Well its onle that, some times when I click on an inactive tab the tab disappears or closes down. These were not dummy pages tabs...these are real pages, which I have checked or opened moments before. someone in chrome forum mentioned about having same problem, but I know nothing about with firefox.

This is very random occurrence and I seriously have not been able to reproduce it at my will. I have also tried working with disabling all the add-ons, and will post my observations soon.

Thanks. Cheers!!

Question owner

I have the same problem. Upgraded to Mandriva 2010.1 and firefox 3.6.6. I have tried to unloade add-ons. but somtime old tabs closes when i click on them. Sometimes when i click on a link or only browsing on a page, and click on things in the page more tabs can open. Sometimes i can open a new tab, but when i click on the tab i will get a page i don't knew about. For example, today i was surfing on facebook. I scroll down on the page and in the next moment i was on a page i never before have gone to. And it there were no links to that page on facebook.

TKH 0 solutions 1 answers

I have the same problem. Started when I upgraded to Firefox 4 beta. Now I'm at b7, but this random problem persists. Ubuntu 10.10 with all updates on Acer Extensa 5220 laptop. Usually the tab which closes is in progress of loading a page (Open in New tab -> activate it -> it's gone).

Other issue introduced at the same time is that sometimes, randomly, repeated drag/click in, for example in Openstreetmap, changes the URL of the page. The URL that the page changes to is always the first URL opened in that tab, no matter how many page changes were in-between.

john2985 0 solutions 1 answers

I'm running ubuntu 10.10 and Firefox 3.6.12. It's a clean install.

I'm experiencing this as well. The tabs mysteriously disappear when I click on them. I swore that I was not clicking on the x's in the tabs. They would just mysteriously close. (I had already disabled the tapping on the touch pad, so I knew that wasn't causing it).

I went to about:config and switched browser.tabs.closeButtons from 1 to 3.

I still have that problem. It doesn't happen all of the time, but it is happening a lot. I did the install of Ubuntu 10.10 last night, and I was experiencing it then, and again this morning.

It is possible that when I'm clicking on another tab, the tab next to it disappears, or I'm not being observant as I should be.  Also I'm getting paste on left-clicks that I make within forms, but that could be something else that is causing that.

It might be this: http://ubuntu-virginia.ubuntuforums.org/showthread.php?p=10144891

Modified by john2985

gtschubert 0 solutions 1 answers

Helpful Reply

Does anybody know of a way to disable the 'close tab' action when both the left and right buttons are clicked on a tab at the same time? I'm pretty sure I have a not-so-perfect trackpad driver on my ubuntu 10.10 system and I think its causing this problem for me. Any help?

rbs75 0 solutions 1 answers

this is a problem with all browsers that use tabs, on the machine i am having the problem with anyways. the machine is an hp dv8000 and i suspect it spawns from the touchpad and keyboard. i have not experienced this problem with my desktop. also, while typing there seems to be several dropped characters.

timmytim 0 solutions 1 answers

this happens to me too (ubuntu 10.10 plus firefox). It is when you use the touchpad and click on a tab with the top-right corner of the touchpad - closes the tab. don't know how to disable this feature

rolo.macias 0 solutions 1 answers

I have this problem as well, whether I run a flash video on it or just a regular Webpage. Most of the times I have a flash video running on at least one tab, though. I noticed that by using Ctrl+Up/Down to switch between tabs the problem doesn't appear. Actually, this is the method I found on dealing with this bug. The issue also appears in Opera. I'm running kubuntu 10.04, firefox 3.x

Modified by rolo.macias

throwawayacct 0 solutions 1 answers

Helpful Reply

Hey, I can confirm that this happens to me. I am also running Ubuntu 10.10 on Firefox 3.6.13. When I click on a tab at the top right of my touchpad on my laptop the tab closes.

Edit: After further research this appears to be some sort of feature of firefox. The upper right of a touchpad is the middle click of a mouse. The middle click (upper right of a touchpad) closes an open tab in firefox. There are some neat features with this middle click and firefox, so far I haven't found an easy way to disable this without having to install an add-on.

Modified by throwawayacct

egermani 0 solutions 2 answers

This happens to me so often that makes Firefox impractical to use . Very annoying.

I have Ubuntu 10.10 + Firefox 3.6.13 + Toshiba Satellite A105. With Ubuntu 10.4 the problem did not occur.

One thing that I have noticed is that sometimes when I click on an input field in a web page, it paste some random text in it.

I appreciate any help to solve this problem.

Thanks!

egermani 0 solutions 2 answers

Found a workaroud that worked for me at: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/636720

Quoting:

"I solved the problem temporarily by typing in terminal:

sudo synclient ClickFinger3=1

and for persistence over reboot added

Option "ClickFinger3" "1"

to the InputClass in

/usr/share/X11/xorg.conf.d/50-synaptics.conf"
Eugene J. Markow 0 solutions 1 answers

I had the same issue with randomly closing tabs in both Firefox and Pidgin using Linux, and I finally found the solution. Other issues were a sticky cursor and random copying and pasting as well. The issue is with the Xorg synaptics driver, xf86-input-synaptics, versions higher than 1.2.2, and not with Firefox.

My solution was to change the parameter value of the EmulateTwoFingerMinZ property in the 10-synaptics.conf file from the default of 29 to 280. My working synaptics driver (1.2.2-2) had a default value of "280", while the newer driver (1.4.0-2) uses "29". Here is my correcting "10-synaptics.conf" file:

/etc/X11/xorg.conf.d/10-synaptics.conf:

Section "InputClass"

       Identifier "touchpad catchall"
       Driver "synaptics"
       MatchIsTouchpad "on"
       MatchDevicePath "/dev/input/event*"
       Option "TapButton1" "1"
       Option "TapButton2" "2"
       Option "TapButton3" "3"
   # Added Manually:
       Option "EmulateTwoFingerMinZ" "280"

EndSection


Since this change, my synaptics touchpad has been working very well without any closing tabs or other irregular issues. Hope this solution works for more people. Here is a link to my original post on the Arch Linux forums:

https://bbs.archlinux.org/viewtopic.php?id=105821&p=2

Modified by Eugene J. Markow