X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox icon missing from desktop and dock, computer shows applications folder generic icon instead-- the solution offered in the previous thread on this issue did NOT work for me, need alternative solution.

Posted

n/a

This happened

Every time Firefox opened

== a few months ago-- coincided with most recent upgrade

Additional System Details

Installed Plug-ins

  • -Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • npmnqmp 071505000006
  • Shockwave Flash 10.0 r45
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Java Plug-In 2 for NPAPI Browsers
  • 2.0.40115.0
  • Pando Web Installer
  • eMusic Remote Plugin
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.10) Gecko/20100504 Firefox/3.5.10

More Information

addsons menu does not offer extensions panel.

Chris Ilias
  • Moderator
115 solutions 1064 answers

OS X usually shows the generic app icon if you have just installed an app. Once you reboot, the icon should be the Firefox icon.

I don't know what previous thread you're referring to. No link. :-(

Question owner

Um there was a large discussion thread on this issue, not sure what the title was-- but rebooting does nothing to fix it. The icon disappeared after an update to the latests firefox. In the other thread no one else had any luck fixing the problem either. I eventually gave up and switched to Safari.

Thanks though!

ShaggyRug 0 solutions 1 answers

Helpful Reply

I have a similar problem - steps taken.

First the problem: After installing (updating) FF to 3.6.10, the icon in my Taskbar Tray changed from the FF World icon to some bland something or other.

1. Right-click the icon - Properties 2. Change Icon - Error message. Can't find: Program Files\Mozilla Firefox 3. When you click OK, you are presented with the location of default icons. Click Browse and locate C:\Program Files (x86) \Mozilla Firefox 4. Select firefox.exe and apply

Hope this helps.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

This thread is about Mac, so instructions for Windows won't help.

craftsmyn 0 solutions 1 answers

Helpful Reply

This site had the down-and-dirty quick solution for Windows 7 Users (and I'm ALSO A MAC USER BTW but Google also points to this thread for windows inquiries so, here's the info for WIN 7 users too!): http://www.waveofweb.com/windows/fix-missing-firefox-icon-issue-in-windows-7/

In brief the article says to:

   Close all currently open folders.
   Use CTRL+SHIFT+ESC to launch Task Manager.
   In Process tab find explorer.exe and right click on it and then select End Process.
   Then click on the End Process button on the confirmation window.
   Now from Task Manger go to File>New Task (Run…) and type cmd.exe and click OK.
   In the command prompt enter below commands one by one
   CD /d %userprofile%\AppData\Local
   DEL IconCache.db /a
   EXIT 
   Then again go to Task Manger>File>New Task (Run…).
   Type explorer.exe and select OK.


Fixed the problem in seconds, so thanks Wave of Web!

Modified by craftsmyn

galiup 0 solutions 2 answers

It didnt help me The black box of RUN didnt accept this command 'd %userprofile%\AppData\Local

  DEL IconCache.db /a
galiup 0 solutions 2 answers

The particular donloaded file doesnt have option to Icon. You can do on the folder or on shortcut only.

carsonic 0 solutions 1 answers

I fixed mine after updating to FF7 by logging out, logging in and then clicking on the generic icon (in my dock). As soon as I clicked on it, it changed back to the FF icon.

Snow Leopard, Mac Mini

harriet_thespy 0 solutions 1 answers

I fixed mine easily. Remove the bad icon from the dock. Go to your applications folder and start Firefox from there. You'll see the correct icon for FireFox on the far right side of the dock - just move to where you usually keep it.

secondeye 0 solutions 1 answers

Had the same problem on Windows 7. I renamed the firefox.exe file, unpinned, re-pinned, named it back to firefox.exe. It works now.