Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google search on Mac not working

  • 5 replies
  • 33 have this problem
  • 1588 views
  • Last reply by Chris Ilias

more options

I have a Mac running MacOS 10.5.8 and Firefox version 3.6.6 I cannot search Google. When I add something into the search field it comes back with no results and it's says done on the lower/bottom bar. I can however search on items in the upper right hand corner search bar in Google and it works fine. Other websites seem to be working fine.

URL of affected sites

http://www.google.com

All Replies (5)

more options

Let's try something simple. Try clearing your cache and cookies.

  1. Open the Tools menu, then select Clear Recent History... .
  2. In the Time Range to clear: drop-down, select Everything.
  3. Click the arrow next to Details to display the list of items that can be cleared.
  4. Select both Cookies and Cache.
  5. Click Clear Now .
more options

I am having the same problem, except I am running Windows Vista instead of Mac. I am using FireFox 3.6.6 as well.

I have tried clearing both the cookies and cache multiple times. After I clear the cookies and cache Google works for a little while, but then goes back again to not working. I can still search Google via the GoogleToolbar, but not being able to search via the Google homepage is driving me crazy.

The issue reported at http://www.google.com/support/forum/p.../thread?tid=5c09b35d00656052&hl=en appears to be the same problem, although the users in question are no longer experiencing it.

more options

Ok...I've done some testing and think I have found the problem. Not sure why, but it appears Google is currently serving up a bad version of the Google homepage to Firefox users. (The Google homepage works fine in IE and Chrome.) I have discovered that if you override the user-agent via about:config and remove Firefox from it, the Google homepage works again.

This is problem is really Google's, but here is a temporary workaround so you can have the Google homepage up and working again:

1. Type "about:config" in the Firefox address bar 2. Right click within the list and choose New -> String 3. Enter general.useragent.override as the preference name 4. Enter some value. It could be blank or you could visit a website such as http://show-ip.net/browserinfo/, get your current user agent and remove the Firefox entry.

For example, my user agent was

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 GTB7.1 ( .NET CLR 3.5.30729; .NET4.0E)

Taking out the Firefox/3.6.6 entry leaves me with.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.6) Gecko/20100625 GTB7.1 ( .NET CLR 3.5.30729; .NET4.0E)

5. Close the dialog. The google homepage should now be working.

Note: When Google fixes this problem it would be a good idea to revert the user agent override by right clicking on "general.useragent.override" and choosing "Reset".

Related issue: https://support.mozilla.com/en-US/for.../715532

more options

Adding "general.useragent.override" is a very dangerous thing to do, and will probably prevent other websites from working. Let's hear what rak says about clearing cache and cookies first.

more options

Strangely my firefox is working.. Not sure if google corrected something...?? I don't know..

Thanks for your input.