X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get firefox to stup adding WWW to the beginning of a URL that does not start with WWW?

Posted

I have a URL I need to access "http://vb.bytware/forums/index/php" but fire fox keeps adding WWW to he beginning of the URL returning "http://www.vb.bytware/forums/index.php" whis is worng and therefore returns a Site not Found error.

This happened

Every time Firefox opened

== today - the first time I entered the URL

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • Office Plugin for Netscape Navigator
  • Shockwave Flash 10.0 r32
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

More Information

Question owner

If this is the URL you want - http://vb.bytware.com/forums/index.php - I've managed to access it with and without www.

But I found this that will most certainly help you: Stop FireFox from adding www. or .com It tells you step by step how to do this and it turns out it's really simple.

edward.manning 0 solutions 2 answers

"Stop FireFox from adding www. or .com" - The domain has expired & the link is no longer valid.

edward.manning 0 solutions 2 answers

Helpful Reply

Looked at a cached copy and this was the original text:

"Stop FireFox from adding www. or .com

Ever wish FireFox would stop trying to fix "broken" URLs by prepending www. (or appending .com) to the server name? If, like me, you find that more irritating than helpful, you can disable it globally:

more ...

  1. In FireFox, go to http://about:config (this is a special manual configuration page all Mozilla-based browsers have; be careful, as you can really much things up!)
  2. In the Filter box, type in fixup and hit Enter (this will hide all the config elements except those that match this term)
  3. Click on the browser.fixup.alternate.enabled element; you'll see it change from Default to User Set, and from True to False.
  4. Done!

To re-enable this, just repeat -- it'll toggle the other way. Changes are saved automatically. "

Update #1: I've tried this but it doesn't solve the issue (v 3.6.13).

Update #2 : There's two additional config entries:

  1. browser.fixup.alternate.prefix - (www.)
  2. browser.fixup.alternate.suffix - (.com)

Changing these / removing the entries makes no difference either. Even after a reboot. Looks like a bug.

Update #3 : Even when copying the correct url - verified to work in IE. It still insists on rewriting the url by removing the port number and adding www. and .com. e.g. "http://localhost:8080/issues" becomes "http://www.localhost.com/issues". Really lame.

Modified by edward.manning

cheartfield 0 solutions 1 answers

I have done all three things mentioned above and still cannot get to our intranet home page because it continues to add www in the URL

kb123 0 solutions 1 answers

You could try bookmarking your intranet home page. Then when you start typing it in the url bar, it should appear first in the drop-down list. Or just click the bookmark where you've saved it.