X
Tap here to go to the mobile version of the site.

Support Forum

I would really appreciate any assitance on this,I am unable to backup my bookmarks due to a system crash. I can access the data on trhe crashed disk. Do my bookmarks reside in a file that I can copy and then replace in a new installation, if so, where is

Posted

Windows has crashed and I have to reinstall Vista. I cannot therefore make a backup of my bookmarks but I assume there is a file somewhere on my crashed disk that carries that detail. If so, can I copy that file and replace it in my new installation of firefox. If this file exists I would appreciate knowing the name of the file that I should copy, and the directory that I might find it in.

Windows has crashed and I have to reinstall Vista. I cannot therefore make a backup of my bookmarks but I assume there is a file somewhere on my crashed disk that carries that detail. If so, can I copy that file and replace it in my new installation of firefox. If this file exists I would appreciate knowing the name of the file that I should copy, and the directory that I might find it in.

Chosen solution

The path that Anonymous gives is for Vista not XP.

The file "places.sqlite" is the file that contains your Bookmarks and History. It is located in your profile folder.

See: http://support.mozilla.com/en-US/kb/Profiles#How_to_find_your_profile Show hidden files and folders

In XP the path is generally: C:\Documents and Settings\UserName\Application Data\Mozilla\Firefox\Profiles\xxxxxxxx.default ("xxxxxxxx" being a unique alpha-numeric identifier)

When copying data from your OLD profile to your NEW profile, copy individual FILES (some require more than 1 FILE). DO NOT copy the entire OLD PROFILE folder; it will not work.

See: Recovering important data from an old profile


Other Issues: ~~red:You have installed plug-ins with known security issues. You should update them immediately.~~

Update Java: your ver. 1.4.2 (~~red:very old~~); current ver. 1.6.0.20 (important security update 04-15-2010) (Firefox 3.6 and above requires Java 1.6.0.10 and above; see: http://support.mozilla.com/en-US/kb/Java-related+issues#Java_does_not_work_in_Firefox_3_6 ) (Windows users: Do the manual update; very easy.) Check your version here: http://www.mozilla.com/en-US/plugincheck/ See: Updating Java Do the update with Firefox closed.

Install/Update Adobe Flash Player for Firefox: your ver. 10.0 r45; current ver. 10.1 r53 (important security update 2010-06-10) Check your version here: http://www.mozilla.com/en-US/plugincheck/ See: Updating Flash -use Firefox to download and SAVE to your hard drive (save to Desktop for easy access) -exit Firefox (File > Exit) -check to see that Firefox is completely closed (Ctrl+Alt+Del, choose Task Manager, click Processes tab, if "firefox.exe" is on the list, right-click "firefox.exe" and choose End process, close the Task Manager window) -double-click on the Adobe Flash installer you just downloaded to install/update Adobe Flash -when the Flash installation is complete, start Firefox, and test the Flash installation here: http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_15507&sliceId=1

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Office Plugin for Netscape Navigator
  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • 3.0.40818.0
  • Java Plug-in 1.4.2 for Netscape Navigator (DLL Helper)
  • Adobe Acrobat Plug-In Version 6.00 for Netscape
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10) Gecko/20100504 Firefox/3.5.10

More Information

Question owner

appdata>roaming>mozilla>firefox>profiles>click the next folder with random letters and numbers.default>bookmark backups and backup the .json files...

appdata>roaming>mozilla>firefox>profiles>click the next folder with random letters and numbers.default>bookmark backups and backup the .json files...
TXGuy 87 solutions 861 answers

Chosen Solution

The path that Anonymous gives is for Vista not XP.

The file "places.sqlite" is the file that contains your Bookmarks and History. It is located in your profile folder.

See: http://support.mozilla.com/en-US/kb/Profiles#How_to_find_your_profile Show hidden files and folders

In XP the path is generally: C:\Documents and Settings\UserName\Application Data\Mozilla\Firefox\Profiles\xxxxxxxx.default ("xxxxxxxx" being a unique alpha-numeric identifier)

When copying data from your OLD profile to your NEW profile, copy individual FILES (some require more than 1 FILE). DO NOT copy the entire OLD PROFILE folder; it will not work.

See: Recovering important data from an old profile


Other Issues: ~~red:You have installed plug-ins with known security issues. You should update them immediately.~~

Update Java: your ver. 1.4.2 (~~red:very old~~); current ver. 1.6.0.20 (important security update 04-15-2010) (Firefox 3.6 and above requires Java 1.6.0.10 and above; see: http://support.mozilla.com/en-US/kb/Java-related+issues#Java_does_not_work_in_Firefox_3_6 ) (Windows users: Do the manual update; very easy.) Check your version here: http://www.mozilla.com/en-US/plugincheck/ See: Updating Java Do the update with Firefox closed.

Install/Update Adobe Flash Player for Firefox: your ver. 10.0 r45; current ver. 10.1 r53 (important security update 2010-06-10) Check your version here: http://www.mozilla.com/en-US/plugincheck/ See: Updating Flash -use Firefox to download and SAVE to your hard drive (save to Desktop for easy access) -exit Firefox (File > Exit) -check to see that Firefox is completely closed (Ctrl+Alt+Del, choose Task Manager, click Processes tab, if "firefox.exe" is on the list, right-click "firefox.exe" and choose End process, close the Task Manager window) -double-click on the Adobe Flash installer you just downloaded to install/update Adobe Flash -when the Flash installation is complete, start Firefox, and test the Flash installation here: http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_15507&sliceId=1

The path that '''Anonymous''' gives is for Vista not XP. The file "places.sqlite" is the file that contains your Bookmarks and History. It is located in your profile folder. See: http://support.mozilla.com/en-US/kb/Profiles#How_to_find_your_profile [http://kb.mozillazine.org/Show_hidden_files_and_folders Show hidden files and folders] In XP the path is generally: C:\Documents and Settings\''UserName''\Application Data\Mozilla\Firefox\Profiles\xxxxxxxx.default ("xxxxxxxx" being a unique alpha-numeric identifier) When copying data from your OLD profile to your NEW profile, copy individual FILES (some require more than 1 FILE). DO NOT copy the entire OLD PROFILE folder; it will not work. See: [[Recovering important data from an old profile]] ---------------------------- <u>'''''Other Issues'''''</u>: ~~red:You have installed plug-ins with known security issues. You should update them immediately.~~ <u>'''Update Java'''</u>: your ver. 1.4.2 (~~red:very old~~); current ver. 1.6.0.20 (<u>important security update 04-15-2010</u>) (Firefox 3.6 and above requires Java 1.6.0.10 and above; see: http://support.mozilla.com/en-US/kb/Java-related+issues#Java_does_not_work_in_Firefox_3_6 ) ''(Windows users: Do the manual update; very easy.)'' Check your version here: http://www.mozilla.com/en-US/plugincheck/ See: '''[http://support.mozilla.com/en-US/kb/Using+the+Java+plugin+with+Firefox#Updates Updating Java]''' Do the update with Firefox closed. <u>'''Install/Update Adobe Flash Player for Firefox'''</u>: your ver. 10.0 r45; current ver. 10.1 r53 ('''important security update 2010-06-10''') Check your version here: http://www.mozilla.com/en-US/plugincheck/ See: '''[http://support.mozilla.com/en-US/kb/Managing+the+Flash+plugin#Updating_Flash Updating Flash]''' -'''<u>use Firefox to download</u>''' and <u>'''SAVE to your hard drive'''</u> (save to Desktop for easy access) -exit Firefox (File > Exit) -check to see that Firefox is completely closed (''Ctrl+Alt+Del, choose Task Manager, click Processes tab, if "firefox.exe" is on the list, right-click "firefox.exe" and choose End process, close the Task Manager window'') -double-click on the Adobe Flash installer you just downloaded to install/update Adobe Flash -when the Flash installation is complete, start Firefox, and test the Flash installation here: http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_15507&sliceId=1 *<u>'''NOTE: On Vista and Windows 7'''</u> you may need to run the plugin installer as Administrator by starting the installer via the right-click context menu if you do not get an UAC prompt to ask for permission to continue (i.e nothing seems to happen). See this: http://vistasupport.mvps.org/run_as_administrator.htm *'''<u>NOTE for IE:</u>''' Firefox and most other browsers use a Plugin. IE uses an ActiveX version of Flash. To install/update the IE ActiveX Adobe Flash Player, same instructions as above, except use IE to download the ActiveX Flash installer. *Also see: http://kb.mozillazine.org/Flash ~~red:'''''AND'''''~~ [[How do I edit options to add Adobe to the list of allowed sites]]
jianf 0 solutions 4 answers

I too have this problem with finding old lost bookmarks, only I have windows XP and not Vista, is there still a way to retrieve them? Many thanks - Wendy

I too have this problem with finding old lost bookmarks, only I have windows XP and not Vista, is there still a way to retrieve them? Many thanks - Wendy
cor-el
  • Top 10 Contributor
  • Moderator
17691 solutions 160067 answers

Do you want to retrieve bookmarks from a crashed disk that is mounted as a second (slave) drive?

See:

Profiles - How to find your profile
http://kb.mozillazine.org/Profile_folder_-_Firefox

"Application Data" in XP/Win2K and "AppData" in Vista/Windows 7 are hidden folders
See http://kb.mozillazine.org/Show_hidden_files_and_folders

Go to: Control Panel > Folder Options > "View" tab > under "Hidden files and folders", select "Show hidden files and folders"
You may want to un-check the box "Hide extensions for known file types" temporarily to see the file extensions of all files.

XP: C:\Documents and Settings\<user>\Application Data\Mozilla\Firefox\Profiles\<profile>
Vista/Windows 7: C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>
Do you want to retrieve bookmarks from a crashed disk that is mounted as a second (slave) drive? See: [[Profiles#How_to_find_your_profile|Profiles - How to find your profile]] http://kb.mozillazine.org/Profile_folder_-_Firefox "Application Data" in XP/Win2K and "AppData" in Vista/Windows 7 are hidden folders<br /> See http://kb.mozillazine.org/Show_hidden_files_and_folders Go to: Control Panel > Folder Options > "View" tab > under "Hidden files and folders", select "Show hidden files and folders"<br /> You may want to un-check the box "Hide extensions for known file types" temporarily to see the file extensions of all files. <pre><nowiki>XP: C:\Documents and Settings\<user>\Application Data\Mozilla\Firefox\Profiles\<profile> Vista/Windows 7: C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile> </nowiki></pre>