Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why Firefox is changing the main window border color by itself ?

  • 16 replies
  • 62 have this problem
  • 1298 views
  • Last reply by ehrdan

more options

I´m using Windows vista home premium. I´m using Firefox with Aero theme. my defaults windows are all with black borders. Few days ago only Fire fox decides by itselft to change the window border from black to light blue !!! It is very boring because it is only Fire Fox that is acting like that. I want to use it with black borders. Every time, I need to close Fire Fox to start using with normal colors... and sudenly, its changes again from black to blue... Please help.

This happened

Every time Firefox opened

== few minutes after firefox is running...couple of days ago...

All Replies (16)

more options

I'm having the same problem in Windows 7. I think it started with Firefox 3.6.4, I didn't see it prior to that.

more options

any fix to this yet?

more options

Im Having the same problem, very annoying.. (win 7, firefox 3.6.6)

more options

You may have installed a persona or theme that made those changes.

You can uninstall that Persona and revert to the Default theme (Tools > Add-ons > Themes). See Use themes to change the look of Firefox and http://kb.mozillazine.org/Themes (Lightweight theme)

more options

It finally happened again. I just noticed that other windows opened by Firefox are still the correct color, it's just the main window that has this problem.

Here's the screenshot.

more options

using default theme same prob

more options

problem is the same even with other themes-- ie all themes use the baby blue border changing the main windows theme does not affect it either

more options

I have the same problem and I have noticed that the size of the max/min/close buttons also changes when this happens. You can see this in the screenshot that Rusty posted on 7/9.

more options

Any updates on this problem yet? It doesn't cause any loss of browser functionality, but it is very annoying.

more options

so far, no comments from mozilla developers team... The issue remains the same It is so annoying that I´m using win XP again...

more options

I think your problem has less to do with firefox and more to do with your appearance settings, try this.

On vista

Type "sysdm.cpl" in the start search bar

Click "Advanced" tab

Click "Settings" in the Performance section

In the Visual Effects tab select "Adjust for best Appearance"

Click "Ok"

Now go test it out. My guess is windows is switching Aero off to save system resources.

Hope this helps

more options

I tried this, but the problem still exists. I pretty much expected this, because the only window that ever shows this problem is Firefox (and particularly the Firefox window that has had focus for a very long time). I'm pretty sure that it doesn't have anything to do with Windows Aero appearance settings. The time to failure is really strange also . . . I have tried to determine if it happens after returning from the screen saver, or returning from S3, but it doesn't seem to be tied to either of those events. It just seems to happen after x amount of time that the browser window is open. (I am not obsessed with it enough to have tried to figure out what x is : )

For what it's worth, I'm seeing this problem on multiple systems that are running Windows 7, not Vista. Again, it's more of an annoyance than anything else, but it does seem to be associated with the Firefox browser window that has focus.

Hope this helps.

more options

Upgraded recently to Firefox 3.6.7, still having the same problem (running Vista).

more options

My custom themes look poxy with a baby blue border, please change it back !

more options

I have the same problem using vista and firefox 3.6.8 I don't remember the version that I had before cause I formatted my computer. Any solution yet?

more options

It happens to me after I resize the window. More specifically, I've noticed that it happens after resizing the window using the EasyWindowDragKDE autohotkey script.