X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When maximizing videos to full screen, the entire screen turns white

Posted

When maximizing videos to full screen, the entire screen turns white (sound is fine, just can't see anything). This happens on YouTube or any other video site.

This happened

Every time Firefox opened

== Seems to have started happening once the latest Adobe Flash player was installed

Additional System Details

Installed Plug-ins

  • -Office Plugin for Netscape Navigator
  • 1.9.0042.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.1 r53
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • 4.0.50524.0
  • Office Live Update v1.5
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

Question owner

Same problem after Adode flash update

Question owner

Same issue, 3.5.10

Question owner

same problem

Question owner

Brett here again...

SO, is this just a "this problem sucks" forum, or, does someone at Firefox actually take care of these?

Never submitted a problem before!  :)

Question owner

Since there are just a handful of us so far...who knows?

Question owner

Same problem. What is the fix?

Question owner

same problem using xp...

Question owner

7.9.10 I have the same issue also.

Question owner

Having the same problem for about a week. Don't remember what it was, but something was updated like Adobe.

Question owner

Same freaking problem!!

Question owner

same problem wtf???

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Helpful Reply

Try to disable the hardware acceleration in the Flash Player: Flash video won't play full screen on YouTube, Facebook and other websites Flash "Display settings" window: http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html


See also http://kb.mozillazine.org/Plugin-container_and_out-of-process_plugins ..... You can try if it works if you disable OOPP (Out-Of-Process-Plugins). You can set the prefs dom.ipc.plugins.enabled.* to false on the about:config page to disable the plugin-container process. dom.ipc.plugins.enabled (currently false in Firefox 3.6.x) dom.ipc.plugins.enabled.npswf32.dll (Flash) dom.ipc.plugins.enabled.npctrl.dll (Silverlight) dom.ipc.plugins.enabled.npqtplugin.dll (QuickTime)

Question owner

cor-el must be from Krypton, b/c they are Super! (terrible joke, I know...)

Seriously, though, the "Disable hardware acceleration" on Flash worked like a charm...

I'll see what I can see about updating my drivers, but they should be good to go!

Thanks again, cor-el !!

Question owner

it's only this solution:

1. Right-click in the standard youtube video window (non-full screen). 2. Choose 'Settings...' from the Flash Player's pop-up menu. 3. Uncheck the 'Enable Hardware Acceleration' 4. Click 'Close'.

the second solution from cor-el is affects only the plugin-container.exe. if you have problems with firefox and its plugin-container after updating to firefox 3.6.4, then you have to change the config in this way.

Question owner

THANK YOU!!! This solved it!


guest Firefox user

it's only this solution:

1. Right-click in the standard youtube video window (non-full screen). 2. Choose 'Settings...' from the Flash Player's pop-up menu. 3. Uncheck the 'Enable Hardware Acceleration' 4. Click 'Close'.

the second solution from cor-el is affects only the plugin-container.exe. if you have problems with firefox and its plugin-container after updating to firefox 3.6.4, then you have to change the config in this way.

canadianfunkymunky 0 solutions 1 answers

Helpful Reply

I just disabled "Enable Hardware Acceleration" under the settings window when right clicking on video playing in Youtube. The settings in Internet Explorer were set to enabled hardware acceleration, so I presumed it wasn't a problem with Flash Player itself. Upon disabling in Firefox, I was able to see fullscreen video in Youtube, but it was choppy and laggy sometimes. Then I re-enabled the hardware acceleration, and everything was fine. Small bug from flash and mozilla, but an easy workaround. Hope that helps you!