X
Tap here to go to the mobile version of the site.

Support Forum

Images in Firefox lack Colour Depth

Posted

This past week, I've noticed that the photos displayed in FireFox seem to have low colour depth. I thought it might be a problem with my display driver or monitor, but it turns out that images are displayed properly in Chrome. This link shows two histograms of the same photo displayed in each browser: https://docs.google.com/leaf?id=0BxfvoJeWisXjMGJjZDRkNDItMDEwOS00NWU2LTg3NGYtNjNkZDNlZGEzYTU4&hl=en. I uninstalled and reinstalled the latest version (3.6.4), but it didn't make any difference. What's going on?

This happened

Every time Firefox opened

About a week ago.

User Agent

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.70 Safari/533.4

This past week, I've noticed that the photos displayed in FireFox seem to have low colour depth. I thought it might be a problem with my display driver or monitor, but it turns out that images are displayed properly in Chrome. This link shows two histograms of the same photo displayed in each browser: https://docs.google.com/leaf?id=0BxfvoJeWisXjMGJjZDRkNDItMDEwOS00NWU2LTg3NGYtNjNkZDNlZGEzYTU4&hl=en. I uninstalled and reinstalled the latest version (3.6.4), but it didn't make any difference. What's going on? == This happened == Every time Firefox opened == About a week ago. == == User Agent == Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.70 Safari/533.4

Chosen solution

What happens if you do this?:

Enter about:config into the address bar, click through any warning page, then into the filter box paste:

gfx.color_management.mode

Double-click the line listing that preference to change the value to 0

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.70 Safari/533.4

More Information

Application Basics
Name
Firefox
Version
3.6.4
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Java Console
6.0.20
true
Modified Preferences
Name
Value
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
https://www.google.com/accounts/ServiceLogin?service=mail&passive=true&rm=false&continue=http%3A%2F%2Fmail.google.com%2F…
browser.startup.homepage_override.mstone
rv:1.9.2.4
extensions.lastAppVersion
3.6.4
network.cookie.prefsMigrated
true
privacy.sanitize.migrateFx3Prefs
true

Chosen Solution

What happens if you do this?:

Enter about:config into the address bar, click through any warning page, then into the filter box paste:

gfx.color_management.mode

Double-click the line listing that preference to change the value to 0

What happens if you do this?: Enter '''about:config''' into the address bar, click through any warning page, then into the '''filter''' box paste: '''gfx.color_management.mode''' Double-click the line listing that preference to change the value to '''0'''

Question owner

Brilliant! Worked like a charm, thank you!

Brilliant! Worked like a charm, thank you!
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157436 answers

See http://kb.mozillazine.org/gfx.color_management.mode

See https://developer.mozilla.org/En/ICC_color_correction_in_Firefox

Caveats: The new QCMS color management system introduced in Firefox 3.5 currently only supports ICC version 2 color profiles, not version 4.
See http://kb.mozillazine.org/gfx.color_management.mode See https://developer.mozilla.org/En/ICC_color_correction_in_Firefox <blockquote>Caveats: The new QCMS color management system introduced in Firefox 3.5 currently only supports ICC version 2 color profiles, not version 4.</blockquote>