X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Real Player Video Downloader does not work anymore - isn't even accessible anymore - after Firefox / Adobe Flash Player update, how to fix this?

Posted

Real Player Video Player no longer provides option to download after my Firefox / Adobe Flash Player updated. How can this be fixed?

This happened

Every time Firefox opened

== After FireFox / Adobe Flashplayer Update

Chosen solution

Very simple. Open your Firefox Browser,then click Tools on the upper left side,then click on Add-ons then click extensions then enable your add-ons. Reopen your Firefox browser and real player down loader should work.

Read this answer in context 9

Additional System Details

Installed Plug-ins

  • -Shockwave Flash 10.0 r45
  • Office Plugin for Netscape Navigator
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • Adobe PDF Plug-In For Firefox and Netscape
  • getplusplusadobe16263
  • Default Plug-in
  • 6.0.12.732
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • npmnqmp 989898989877
  • 4.0.50401.0
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Version 1.0.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • Next Generation Java Plug-in 1.6.0_19 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.4

More Information

Real Player Video Downloader does not work, is not accessible now. How to fix this, something that occurs upon each update.

Question owner

I had the same problem found this from another source online it worked for me:- type about:config in the address bar Then in the filter box type dom.ipc.plugins.enabled.npswf32.dll.

Then change the value to false.

After doing this restart firefox and now the realplayer flash downloader should start working again.

Question owner

hi, anonymous, apparently that value can't be changed. there is no button or whatsoever to do that. Can you please provide further info? Thanks.

Question owner

Thanks anonymous, I can't believe it but your fix worked. I don't know why nobody thought of this earlier. Thanks again, I really appreciate it.

Question owner

I would just add, for steandric, that you just click on the entry that comes up and the value changes to user-defined and false

Question owner

Nice, this worked great for me, excellent work. Was annoying not being able to use the downloader plugin.

Question owner

Hi Anonymous - had the same problem and followed your instructions - all works fine now - magic - thanks a lot. :)

Question owner

Worked for me too thanks

Question owner

Thanks that fix worked...rediculous but it did! haha

Question owner

this worked for me too, but won't this manual change affect any functionality on the plug-ins or something?

Question owner

Thank you soooooooooooo much.. u're a genious!

Question owner

hi, i have the same problem. but what 'address' bar are you talking about?

Question owner

I made the change, but it does not work. Melissa, the "address" bar is the URL bar. There is also a filter bar in the config window.

Double-click on the value or right click and select "Toggle" to toggle between true and false. "Status" will also toggle between "default" and "user set."

Question owner

Can someone provide a little assistance with this? It'd be very much appreciated.

after getting to the about:config window I can enter dom.ipc.plugins.enabled.npswf32.dll. in the filter bar but no results are returned?

I'm sorry if I'm being very dim but this is all way beyond me but I can't help being super annoyed that the Realplayer "download this" disappears almost every time Firefox updates.

also, I'm using win 7 not xp, would this need a different fix?

Helpful Reply

Hi David, try dropping the .dll extension, in fact you can just enter dom.ipc.plugins and it should come up. Or enter the whole thing and then backspace until it comes up. Also, I have Windows 7(x64) and this fix worked fine for me.

Question owner

thanks....it is a great solution:

1) type about:config in the address bar 2) Then in the filter box type dom.ipc.plugins.enabled.npswf32. (remember, no need the ".dll.") 3) Double-click on the value and it will change from "true" to "False"..... 4) restart fire fox. And the real player down loader will appear again!!!!

Question owner

Thanks so much for the fix. Dropping the .dll extension didn't work at first but another thread advised uninstalling then reinstalling Realplayer & everything appears to be working now.

Question owner

Great tip from anonymous!!! Now if I can only get Firefox to auto search without putting in .com, I'd be happy!

Question owner

Real Player Video Player no longer provides option to download after my Firefox / Adobe Flash Player updated. How can this be fixed? currently i m using firefox 3.6.8 version

patfla 0 solutions 3 answers

The effect of the about:config change seems to be to turn off the plugin-container.exe subprocess which was new circa 3.6.whatever at which point the realplayer video download plugin no longer worked properly.

The only downside I can see is that this brings plugins back into the browser's own process memory space which I don't have a problem with since I've never really had issues (that I was aware of) with browser instability due to plugins.

JC 0 solutions 1 answers

Hey AnonymousUser Guy/Gal. Thank You! It has been broken for some time now. To all you novices out there remember to set /turn on /adjust these features in the preferences of real player. Tools Menu-Preferences-Download & Recording --- the settings are there.

             Surf Strong

JC

Modified by JC