Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I make Firefox NOT my default browser and restore Internet Explorer as default browser?


I used to have Internet Explorer as my default browser and when I went to Firefox it asked me if I wanted Firefox as my default browser and I always sad no. I must haves screwed that up somehow and I want to go back to Explorer as default.

This happened

Not sure how often

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape
  • Office Plugin for Netscape Navigator
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.0 r12
  • Picasa plugin
  • 4.0.50524.0
  • Bing Bar
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Motive Plugin for Mozilla Browsers
  • Google Updater pluginhttp://pack.google.com/
  • Rhapsody Player Engine Plugin
  • Google Update
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers
  • Java(TM) Platform SE binary


  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100315 Firefox/3.5.9 GTB7.0 ( .NET CLR 3.5.30729)

More Information

Gryllida 76 solutions 892 answers

To make Internet Explorer your default web browser, you can click on Tools from the toolbar at the top and select Internet Options. Then select the Programs tab from the top of the window to access the default browser settings. You might want to also choose to be alerted if Internet Explorer is not your default browser. Click OK to save your changes.

Please also be aware of that Firefox's latest version is 3.6.4 while you're running 3.5.9.

Question owner

When I go to Programs, the Default Browser section is grayed out. How do I activate it so I can change my default browser back to IE?

Question owner

I have the same problem as kkhusker I do not have the option to reset the browser -- it is grayed out and will not let me select it.