Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I updated Firefox and now Realplayer can't download any videos( download button in upper right corner of video don't pop up and there is no download option if I right click) if I use Internet explorer it works fine, I also went in to make sure I had it ch

  • 42 replies
  • 292 have this problem
  • 1946 views
  • Last reply by roderick74

more options

I updated Firefox and now Realplayer can't download any videos( download button in upper right corner of video don't pop up and there is no download option if I right click) if I use Internet explorer it works fine, I also went in to make sure I had it checked to pop up it is?! So it's not just youtube for me its all videos!

This happened

Every time Firefox opened

== the last firefox update

locking due to the age of this thread

Modified by the-edmeister

All Replies (20)

more options

I love you HEST!

more options

This worked for me

type about:config in the address bar Then in the filter box type ''''''''''dom.ipc.plugins.enabled.npswf32.dll''''''''''

more options

I just downloaded version 3.66 thinking they had a glitch in 3.64 being it was only a couple of days between updates. Still can't download youotube videos. I don't understand the msconfig thing, so I guess it's back to IE.

more options

I will try to explain how to use the msconfig command. You can open another tab in firefox so as to have this page still available for reference. In the address bar type the following

                            about:config

A warning will appear. Click on "I'll be careful. I promise". A Filter box will appear. In this box type the following

                 dom.ipc.plugins.enabled.npswf32.dll

A line should appear with the above line followed by "user set" "boolean" and "true" Right click on the word "true". A box will appear. The first word in this box is "Toggle" Left click on the word "Toggle". This will change "true" to "false" Close Firefox completely & then reopen it. Your RealPlayer download button shoud now appear in YouTube.

more options

I have the same problem with the Realplayer tool button having vanished.

Should the fix that's been posted here also work for firefox 3.6.6 on win 7?

After I enter the command in the filter box I I don't get any values listed or change options.

This makes me sadpanda. Such a frequent problem when Firefox updates. Can't Mozilla or real or both synchronise better?

more options

David, I am running XP, but the first time I tried using "about config" it didn't show the line or any values either. I downloaded & reinstalled RealPlayer. Then when I used the "about:config" command & typed "dom.ipc.plugins.enabled.npswf32.dll" (w/o quotations), the line w/the values was listed. Hope this helps!

more options

dom.ipc.plugins.enabled.npswf32.dll dint work >.< my mozzilla is v3.6.6... i toggled the values,restarted firefox, nth changed, can anyone help me?

more options

bbkanga90, I had the same thing happen. But i reinstalled Real Player & then used the about:config command, restarted firefox & it worked. The value you is "false". hope this helps.

more options

It worked for me thanks Hest!

more options

same problem but when I use another page and follow instructions it's all fine until I hit the right click on the filter line (after typing in dom.ipc.plugins.enabled.npswf32.dll nothing appeared and there was no box to toggle and change from true to false.

more options

Try entering dom.ipc.plugins.enabled.npswf32 in the filter line, omitting the .dll extension. I had the same problem & this was suggested in another thread & worked fine for me.

more options

Hest, This worked for me, but are there consequences to doing this? What do I lose by changing the value to false?

type about:config in the address bar Then in the filter box type dom.ipc.plugins.enabled.npswf32.dll.

Then change the value to false.

Restart FireFox

more options

Changing the setting for dom.ipc.plugins.enabled.npswf32.dll will only keep Adobe Flash from running in plugin-container.exe, the the crash prevention introduced in Firefox 3.6.4. -Leaving it set to true, if a tab running Adobe Flash crashes, only that tab stops with an error message and you can reload the tab. -Setting it to false, if a tab running Adobe Flash crashes, your whole Firefox browser will crash.

There is an update on the Real site to supposedly fix the lack of the "download this now" or whatever button.

See (read next to the big red "A"): http://real.custhelp.com/app/answers/detail/a_id/7303/p/3/c/2222/r_id/119487

more options

thanks a big help for me...

more options

The fix works, but as for downloading from Real's site, I reinstalled the entire program last week with their tech on the line and it made no difference. I still had to use the fix given.

more options

I simply uninstalled Realplayer and then uploaded the latest version. Worked for me and I use Mozilla.

more options

Hey, it worked for me.

I think this is the simplest way with probably no side effects?

Many thanks for your kind assistance.

more options

what i did to solve the problem is trying to go to firefox windows and go to file then click import -click IE-click next-finish..it work for me..and hopelly work for you as well.thanks

more options

Uninstall your old version of Real Player and download the newest Real Player SP ver. 1.1.5, it should work.

Modified by wooraymond

more options

you're a genius!!!

thank you so much for the helpful instruction.

  1. 1
  2. 2
  3. 3