Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 3.6.4 will constantly set window to aero basic interface, rather than aero glass, in Windows 7

  • 21 replies
  • 73 have this problem
  • 48 views
  • Last reply by Morbus

more options

Since updating to the most recent Firefox 3.6.4 I have noticed that it will sporadically set the windows interface to the aero basic rather than the aero glass interface I have my Windows 7 set up in (and in which Firefox itself opens). To clarify, the browser opens with the window frame as aero glass, but over the course of ten minutes or so of browsing, I will look up and notice it has reverted to basic. I have not been able to determine what happens when it shifts, or if it is a specific add-on (but I have been deleting or disabling any add-on I think might be causing it). Has anyone else experienced this? Is it a known problem? Any work arounds? Thanks!

This happened

Every time Firefox opened

== After 3.6.4 update

All Replies (20)

more options

Hello Josh.

You may be having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not coming from one of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode and select Disable all add-ons. If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and theme. You can troubleshoot plugins the same way.

If you want support for one of your add-ons, you'll need to contact its author.

more options

Happens to me as well I think it happens like when Firefox slows a bit then it changes it not sure if its the case though...

more options

I've seen this problem too, in the meantime. I've found that if I disable Shockwave Flash, the problem disappears. Of course, it also means I can't see Flash objects in the web. I've already contacted Adobe about this, but they haven't replied yet. In any case, it does seem to happen when we put Firefox under particular load with Flash objects.

more options

Been noticing the same thing since updating to 3.6.4. I haven't made any changes to my add-ons since the update and it was working fine before.

more options

I can confirm that Flash is the cause. I was using an extremely old version of Flash, apparently, and it always causing problems. Then I updated and the problems went way... for the most part. Who do I need to ask for help for Flash? As soon as I disable Flash, these problems go away.

more options

I am having the exact same problem. I am running Windows 7 ultimate. It seems even an updated flash player will not fix this. Things are really starting to point to a browser issue, maybe a change that was made to it perhaps? Could it be the new plug-in container causing a conflict? All speculation but would be nice to hear from the Mozilla team what they think is the cause of this problem.

I did not have this problem in Firefox 3.6.3. I have ran 3.6.4 in safe-mode and disabled all my extensions then reactivated them one by one to check if one of them was the culprit but all to no avail. Is there any news from Mozilla about this issue being investigated?

more options

It's probably Flash. I only have Java SE 6 U20, Quake live 01.0.277, Silverlight 4.0.50524.0 and Flash 10.1.53.64 installed. No other add-ons or plugins.

I don't use tabs, ad blockers, etc...

The window with this dialog box has an Aero look.

more options

it seems like if you have alot of flash items (video / games), after a while firefox will "flash" and turn into aero basic.

I was watching world cup online from CBC, since it uses a flash video player, after a few minutes into the game, the screen will "flash" and turn into aero basic.

it doesn't really hurt me to use aero basic with firefox, but may be it's a bigger problem? (the memory usage seems high too.)

more options

Same problem, Windows 7 64 bit, started after Firefox 3.6.4. Anyone find a way to restart Firefox's Aero without closing and restarting Firefox?

more options

Same here, disabling Optimize Google didn't help at all.

Firefox 3.6.6 on W7 x64 Ultimate, but problem started for me since 3.6.5.

more options

"Same problem, Windows 7 64 bit, started after Firefox 3.6.4. Anyone find a way to restart Firefox's Aero without closing and restarting Firefox?"

Sorry, I'm an idiot, thought the current version was 3.6.4. I first noticed it after 3.6.6.

more options

This happens to me whenever I extend my desktop to a second monitor.

more options

I have two monitors, but I didn't notice any link between that and the issue.

more options

Well, that is the only time it happens for me. Perhaps we are experiencing the same symptom with an unrelated root cause.

more options

Maybe. Whatever it is they should fix it, because it's very annoying.

more options

same problem. everything updated to latest.

when i open page with flash on it... bam! firefox switches to aero basic.


annoying.

more options

I also have the same issue using FF 3.6.6 and Windows Vista. It only seems to happen when there are a lot of Flash objects/adverts, such as http://icanhascheezburger.com

I've disabled all plugins etc. and it still occurs. Definitely seems to be a browser issue, rather than anything to do with individual plugins. It seems to have been introduced at the same time as the new Plugin Container.

more options

Same problem here with the recently released 3.6.7.

Possible fix : disable crash protection for Flash by changing dom.ipc.plugins.enabled.npswf32.dll to "false" in about:config.

more options

Yes, that actually helped!

more options

I have the same problem, it start with version 3.6.4. The same version that included OOPP. It's obvious this new feature that is causing the problem, because it's disabled the problem goes away. The problem exists even in 3.6.7, It would be great if mozilla took a look at this and fixed it in 3.6.8.

  1. 1
  2. 2