X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I keep getting an error message that says "You need cookies to login to this site. Please enable cookies." I checked cookies and they're enabled. I went through and did what it said to fix errors like this and it still says that. How can I fix this?

Posted

I am trying to login to a website and every time I go to login I get a message that says "You need cookies for this site. Please enable cookies." I've checked cookies and they're enabled, I even put that specific website on allow. I searched for information on how to correct this error and did all that it said, yet I still get this message.

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Java(TM) Platform SE binary
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • Shockwave Flash 10.1 r53
  • iTunes Detector Plug-in
  • My Web Search Plugin Stub for 32-bit Windows
  • Java Plug-in 1.6.0_11 for Netscape Navigator (DLL Helper)
  • Npdsplay dll
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)

More Information

Moses
  • Top 10 Contributor
  • Moderator
117 solutions 1298 answers

Make sure 3rd party cookies are enabled as well. Go to Tools > Options > Privacy Click on Firefox will remember history and set it to Use custom settings for history then check the box where it says Accept cookies from sites and accept third party cookies

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Can you post a link to that page?

Question owner

I have the exact same problem! With just one website. It's when I have a second account on it. I can sign in with my original (old) account, but not with my new account that I wish to sign in on. I've talked to a lot of people members of the website who have second accounts and this doesn't happen with them, it's only with my firefox. I've done everything I can to enable cookies, 3rd party cookies, no exceptions, etc.

But it must be something to do with my computer because I did the same thing on Internet Explorer and Google Chrome and it's exactly the same. :/

Question owner

Even though I have the same problem, your solution does not work for me. I have all the settings exactly as you describe and You Tube still won't let me sign into my account, saying my cookies are non-functional. I have been unable to download or upload from and to You Tube for over a week. Please help me fix this problem soon. Thank you.

PS: I don't know how to do a screen shot from my Firefox settings page and get it into this page.

Virginia Meyer

Karos 0 solutions 1 answers

I get the same issue every once in a while, on specific websites. My cookie settings are set so that it allows all cookies, including third party ones, but every once in a while (not all the time), it gives me pages like in the attached picture. I'll clear my history and cookies, just to be sure that the temporary internet files aren't full, but it doesn't do anything, even if I use ctrl+F5...

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers
  • If you use extensions like Adblock Plus or NoScript or Flash Block that can block content then make sure that such extensions aren't blocking content.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See: