Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My Add-ons window opens but doesn't work properly

  • 3 replies
  • 4 have this problem
  • 2 views
  • Last reply by Morbus

more options

This started about a year ago when I had FF 2.0 and I thought it would correct itself when I updated to 3.6 but it didn't.

I have several add-ons that I wanted to remove. When I clicked on Uninstall they stopped functioning and the add-on window said they would be removed when FF restarts, but they don't do that and are still visible after a year or so.

I have no-script and wanted to disable it once to see if it was affecting another program. Clicking on the disable button doesn't do anything so I have to click on Uninstall so it will stop functioning, and then click on disable to enable it again.

If I click onno-script Options, it locks up FF and I have to use the task manager to get out of FF.

Is there a way to put this back in working order?

Chosen solution

I don't know of a fix for this, but you may want to try creating a new Firefox profile:

http://support.mozilla.com/en-US/kb/Managing+profiles

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

I don't know of a fix for this, but you may want to try creating a new Firefox profile:

http://support.mozilla.com/en-US/kb/Managing+profiles

more options

Thanks. I created a new profile and everything works in that profile.

Now I have to figure out if it's worth all the trouble transferring my bookmarks, themes, and so forth, and also losing my Form autocomplete info, or if I'll just live with it, but it's good to know there's a simple solution.

more options