X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox very slow to load pages, how do I correct?

Posted

I have noticed recently that Firefox is taking upwards of 20sec. to load pages and often cannot find the server(I have to reload the page). I did not realize how low it had gotten until I start using safari and it seemed so fast in comparison. Does anyone know what is going on? Also, I have read a DIY fix on another conversation which states to fix the problem "To disable OCSP go to about:config from firefox and change security.OCSP.enabled to be 0. " Is this the fix? and is it safe? Does mozilla field any of these questions or is it all user help?

This happened

Every time Firefox opened

== Not sure when specifically as I try to use firefox exclusively

Additional System Details

Installed Plug-ins

  • -Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • iPhoto6
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.2
  • Java Plug-In 2 for NPAPI Browsers
  • 3.0.50106.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.0 r42
  • Version 1.1.1.9134

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

To disable OCSP go to about:config from firefox and change security.OCSP.enabled to be 0.

Question owner

Pages are very slow to load (even bookmarks sites that I go to all the time).

Video playback is very choppy also. I watch the thing called "TMZ Live," which is live streaming video and it stops and starts to the point of distraction.

These issues have been happening for about a week or two now.

amsterdammer 0 solutions 1 answers

so this is the firefox support forum, i guess that my slow firefox is related to the slow moving reaction speed on the offidial firefox support forum.

No reaction from firefox staff, although there are posts with problems from July 2010, i guess i have to change to Chrome...

Sorry firefox you have been a good friend for a long time but i have had issues for about a month now and it is starting to get a bit frustrating to have frozen pages.

i will continue checking some forums and hope to hear its solved soon.

good luck

ian3116 0 solutions 1 answers

SOLVED! - I found the AVG anti-virus Link Scanner was the problem. I first disabled the link scanner completely and saw a dramatic improvement. I then rebooted the computer and reactivated the link scanner and everything is running fine. Hope that helps.

woolly 0 solutions 1 answers

Easily solved i just installed chrome and took off firefox and hey presto chrome loads really quick and no waiting for bloody ages to work

uinsin42 0 solutions 4 answers

I disabled Java Consol and Firefox is back to it's excellent self!

Ozzi 0 solutions 1 answers

Helpful Reply

Solved - What Worked for me was in the address bar type about:config and change the network.http.keep-alive setting to false

Modified by Ozzi

locky 0 solutions 2 answers

Helpful Reply

I did what Ozzi said "What Worked for me was in the address bar type about:config and change the network.http.keep-alive setting to false " and it worked, it stopped the constant spinning and pages finish loading.

Modified by locky

scorpa54 0 solutions 4 answers

I did this as well and it seems to have helped. It's sad, though, that one has to resort to digging around to fix something that should and use to just work :(

edit: I just tried bringing up this page in both Firefox8 and IE9, I've logged in and am making this edit in IE9 because Firefox hasn't even left Google yet. Bloody pathetic!

nother edit; Sorry Firefox, I have to eat crow. I have tried different browsers and find that they all start to slow down dramatically. I then went over to the Mac side and browsed. Firefox is quick as usual. My wife's system isn't quite as slow for browsing which made me wonder. She's still on XP, I had to upgrade to 7 in order to check webpage compatibility, I truly hate IE (and Windows for forcing me to upgrade yet again). Anyway I now know that Windows 7 is the culprit for slow web. If I wasn't a site developer I'd go back to XP in a heart beat or, better yet, stay on the Mac side and lose Windows altogether.

Modified by scorpa54

c22600 0 solutions 1 answers

Thanks guys, was having the same problem.IE9, Opera & Safari were all like greased lightening by comparison. The fix above worhed for me. ANZ.com.au would take 30+ seconds to load the main page. The other browsers and my iPhone were almost instantaneous. I was at a point where I was going to dump Firefox. The other browsers mentioned are ok but all have their odd "things" that I don't like.

Thanks again... big big help for me.... saved Firefox from the eternal uninstall feature..

Sivvey 0 solutions 1 answers

I have tried the config edit, it seems to be a fix. how ever, I am unsure of what caused this problem, and if Firefox knows its going on, please respond!

shivakiran 0 solutions 1 answers

I followed the following link for tweaking firefox 9 and ff is now blazing fast. Though there are quite a number of changes to be made but they are worth the try. Here goes the link...

http://newsandhow2s.wordpress.com/2011/05/25/how-to-speed-up-firefox-4-0-tweaks-tricks/

The link's for FF 4 but i managed to change whatever is applicable in FF 9. So far (after the changes) so good:)

Modified by shivakiran

in2thevast1975 0 solutions 1 answers

I began having the problem with Firefox just as everyone has explained. As someone who has come to LOVE firefox, I desperately tried all the remedies I could find. We are talking about hours and hours of the many about:config options, extensions adding, disabling, spyware, reg cleaning, etc....... I have tried to resort back to Firefox 4 and for some mysterious reason, everyone of those links report the 505 or the automatically redirect to an"oops how did you get here" page by Mozilla. I am very sad to report that the only remedy that I found that has completely restored a fast, constant browsing experience was not a Firefox fix. I was to uninstall and try the Opera browser. It is absolutely fantastic so far. Not one page has hesitated loading. Not even one. I made no other changes. Just installed and started tryin it. I have even tried to bog it down with multiple requests, and yes it slow down as all loaded, but with Firefox and IE (any version especially 9) I would (not responding) or some errors about the server, some mslq weird errors( i dont think they mslq, but some strange erors). So far with Opera, NOT ONE. It so eerily reminds of my first time trying Firefox after becoming soooo frustrated with IE. Hope some of you try it and finally put some of that frustration behind you. Cheers

Rack 0 solutions 4 answers

Ozzi you're a legend! That fix worked a treat.

Steve

scorpa54 0 solutions 4 answers

I went Opera too. Much better!

Jayleb 0 solutions 1 answers

The solution Ozzi supplied seems to of worked for me to. Thanks a bunch Ozzi!

tonybmw 0 solutions 1 answers

I went through my addons and noticed that I had a couple of duplicates of the Jave console and disabled one of them. seems to have fixed it for now.