X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

help me get rid of this!

Posted

This Connection is Untrusted

You have asked Firefox to connect securely to support.mozilla.com, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.

What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

Technical Details

support.mozilla.com uses an invalid security certificate.

The certificate will not be valid until 7/16/2008 7:27 AM.

(Error code: sec_error_expired_certificate)

I Understand the Risks

This happened

A few times a week

== months ago

Modified by cor-el

Chosen solution

Check the date / time on your computer.

Read this answer in context 29

Additional System Details

Installed Plug-ins

  • -getplusplusadobe16263
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • DivX Web Player version 1.5.0.52
  • npdivxplayerplugin
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • Yahoo Application State Plugin version 1.0.0.7
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

none

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24400 answers

Chosen Solution

Check the date / time on your computer.

anand847 0 solutions 1 answers

kindly clear this probable of get certificate

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96757 answers

anand847
Please do not use existing threads to ask a question, but start a new thread instead.
Then you also can provide troubleshooting information like your operating system and installed plugins (about:plugins), and extensions (Tools > Add-ons) and we will be better able to help you.

msavoy 1 solutions 3 answers

While I can't say for sure this is the solution to what I've been experiencing as described in this post, I'd say it is highly likely that the problem will not re-occur as indeed my computer's date and time was not properly set.

the3blairs 0 solutions 1 answers

Helpful Reply

Ya know what? I guess Mozilla considers itself untrusted. Because guess, just guess, what screen I got when I tried to log in! You guessed it! "This page is untrusted." This is rediculous! My computer was fine and I never had this problem until I decided to disconnect my computer last week to repaint my room. Then when I hooked everything back up, all the sites I used to visit WITH NO PROBLEMS , now Firefox has an issue with. Telling my they're all untrusted. This is making me crazy. I corrected the date and time, restarted. Now they're saying I have to mess around with all these certificates? I just want to disable what they're blocking. The only reason they're certificates in there is because of when I've visited sites and was able to at least browse by clicking to get these damn certificates. I STILL can't pay my capital one card!

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96757 answers

Some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button to inspect the certificate and check who is the issuer.

Only leave the mark in the box at the bottom to "Permanently store this exception" if you trust that certificate.

  • Click "Confirm Security Exception" to enter the site if you still want to go to that website.

If the issuer is your security software then you either have to disable that check in your firewall or install the root certificate of that firewall. See Configure firewalls so that Firefox can access the Internet

scrabbledemon 0 solutions 2 answers

Even when I permanently confirm the security exception, Firefox does not recognize the same site the next time, or the time after that, or the time after that--each time permanently confirming security exception.

I want to know what setting to make to disable this altogether.

scrabbledemon 0 solutions 2 answers

Happened to me, too.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96757 answers

If the date and time on your computer are correct then another possible cause is security software (firewall).

Some firewalls monitor secure connections and send their own certificate instead of the certificate from the web server.
You can check that if you click through the steps and get the certificate and look at the issuer.
In such cases you need to install the root certificate of that firewall to make Firefox recognize the issuer of the certificate or disable monitoring secure connections (port 443).

See also http://kb.mozillazine.org/Firewalls and Configure firewalls so that Firefox can access the Internet

Therese 0 solutions 1 answers

THANK YOU!!!!!!!!!! As soon as I checked that I saw I was on the wrong year and didn't notice and have no idea why my PC did that but it fixed this problem immediately, thank you so much!