Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 3.6.3 does not bring up the "add exception" option for a self-signed certificate

  • 8 replies
  • 94 have this problem
  • 2252 views
  • Last reply by JustinZ

more options

Hello. The company website I use has moved to a new server. The new server required some changes apparently, and now I am receiving the message CompanyXYZ.net:987 uses an invalid security certificate. The certificate is not trusted because it is self-signed. The certificate is only valid for Now, on 1 of my 3 computers, I received the I understand the risks, and an option to Add an Exception. However, on the other 2 computers, I simply receive the previously described popup window and no option to proceed. Any suggestions would be appreciated. Thank you for your genius.

URL of affected sites

private company server

Chosen solution

If you can't add an exception, but get a pop-up with the error message then you can check the pref browser.xul.error_pages.enabled on the about:config page and make sure that the value is set to the true (default).

To open the about:config page, type about:config in the location (address) bar and press the Enter key, just like you type the url of a website to open a website. If you see a warning then you can confirm that you want to access that page.

Read this answer in context 👍 2

All Replies (8)

more options

My sentence got munged, "The certificate is only valid for CompanyXYZ.

Now, on 1 of the 3 computers -
more options

Chosen Solution

If you can't add an exception, but get a pop-up with the error message then you can check the pref browser.xul.error_pages.enabled on the about:config page and make sure that the value is set to the true (default).

To open the about:config page, type about:config in the location (address) bar and press the Enter key, just like you type the url of a website to open a website. If you see a warning then you can confirm that you want to access that page.

more options

Firefox 3.6.1's Add-ons page does not have a valid certificate so you cannot browse add-ons within Firefox. Instead you receive a certificate error. See images. I hope Firefox fixes this quickly.

more options

Do you see the default root certificates in the Certificate Manager?

Tools > Options > Advanced > Encryption: Certificates > View Certificates : Authorities

If not then do a clean reinstall and download a fresh Firefox copy from http://www.mozilla.com/firefox/all.html and save the file to the desktop.
Uninstall your current Firefox version and remove the Firefox program folder before installing that copy of the Firefox installer.
Don't remove personal data when uninstalling.

It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.

You can skip the step to create a new profile, that is not necessary for this issue.

See http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall

more options

I already have the browser.uxl.error_pages.enabled setting set to true, but I still do not get the option to add an exception for an internal certificate. I'm trying to connect to the iLO port on an HP server. Thanks.

more options

I have this problem, too, and it's driving me insane, not being able to access websites I normally visit!

In the past, I've had the option to add an exception, but that option doesn't appear.

I've followed every instruction on this page and others - done the browser.uxl thing, uninstalled Firefox and deleted the programme folder, downgraded to a previous version of Firefox, fiddled with the dates on my computer - nothing fixes it.

I've attached a screenshot of the dialogue box, just to be clear about what the problem is.

Modified by jsp_1983

more options

Did you check the value of the pref browser.xul.error_pages.enabled on the about:config page to make sure that it is set to true?

more options

I have this same problem on Firefox 4.0 Beta 12. I'm unable to access https://market.android.com because Google is providing a google.com certificate for android.com browser.xul.error_pages.enabled is set to true, but I found that browser.xul.error_pages.expert_bad_cert was set to false. When I set that to true, the "Add Exception..." button appears. However, the security exception still doesn't get stored, and I still can't access https://market.android.com