Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

does not ask to remember passwords

  • 6 replies
  • 42 have this problem
  • 83 views
  • Last reply by cor-el

more options

Apple safari remembers every one of my frequently used passwords on every web page. I just downloaded and installed version 3.6.3 for Snow Leopard. I transferred all my bookmarks to Firefox yet some websites do not ask to be remembered. I went to your help page and was directed to a "bookmarklet" - but couldn't figure out how to use it???

URL of affected sites

http://nwa401k.ingplans.com/

Chosen solution

1. You need to right-click the remember password button and then select Bookmark this Link . If you right-click anywhere else on that page it will show as Bookmark this Page - you don't want to bookmark the entire page.

2. You can save that "Link" by click-hold on that remember password button and dragging it into the Bookmarks toolbar or into the Bookmarks menubar dropdown.

Read this answer in context 👍 1

All Replies (6)

more options

Yes, that website uses JavaScript to add autocomplete=off to the login form.

Look at this article for a bookmarklet to remove that autocomplete attribute. http://kb.mozillazine.org/User_name_and_password_not_remembered (bookmarklet)

You can create a bookmark with the javascript bookmarklet code as the location with a right-click on the "Remember Password" link on the squarefree.com website and choose "Bookmark This Link" to make it easier to use the bookmarklet.

You can use the "Remember Password" bookmarklet before or after filling the name and password field on the website with the form, but before submitting the form.

If the site is using autocomplete="off" then you see a number not equal to 0 (i.e. attributes were removed) on the pop-up alert from the bookmarklet and Firefox should offer to remember the name and password via an info bar at the top.

more options

This are the instructions from the mozillazine web page: Using a bookmarklet

  1. Bookmark the "remember passwords" link on this page.
  2. Go to the log in page of the site you want to save your details.
  3. Enter your login and password, but do not submit.
  4. Open the bookmark you just made. (Nothing will appear to happen).
  5. Submit. 

Here's what happens: 1. I right clicked and and bookmarked the "remember passwords" 2. I went to the site I wish to have remembered 3. I entered the login and password and did not submit 4. I clicked on (opened) the bookmark I just made - and it opened the square-free.com page - I clicked remember password. A drop down box appears that says: Removed autocomplete=off from 0 forms and from 0 form elements, and removed onsubmit from 0 forms. After you type your password and submit the form, the browser will offer to remember your password. I click OK. I click the bookmark of the site I want remembered - fill in all the data and submit. BUT IT DOES NOT ask if I want to remember!!

I don't know what i'm doing wrong - please help!

more options

You need to create a bookmark with the JavaScript code of the bookmarklet and not a bookmark to the squarefree page where that bookmarklet is listed. That bookmarklet needs to be run on the page where that login form is present. That bookmarklet makes changes to the code on the page where it is run, so running it on another page won't do anything.

more options

Chosen Solution

1. You need to right-click the remember password button and then select Bookmark this Link . If you right-click anywhere else on that page it will show as Bookmark this Page - you don't want to bookmark the entire page.

2. You can save that "Link" by click-hold on that remember password button and dragging it into the Bookmarks toolbar or into the Bookmarks menubar dropdown.

more options

A Thousand Thank You's - IT WORKED.

What was happening is this: even though I had Firefox running, when I clicked on the link you gave me, I didn't notice that it opened in Safari - which is still my default browser. So when I right clicked the only command was to "copy link". Which I did and then even pasted into Firefox - but it was a web page not the Java script. Again, Thank you

more options

You're welcome