X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

why does firefox keep making it my default browser when I keep changing it to IE it changes back to firefox

Posted

So every time I go to firefox it makes it my default broser but I dont want it to i changed it to IE but it changes back to firefox again. And I dont want firefox as default.

This happened

Every time Firefox opened

about a week or so ago

User Agent

Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6.4; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; MDDC; .NET CLR 3.5.30729; .NET CLR 3.0.30729; OfficeLiveConnector.1.4; OfficeLivePatch.1.3)

Additional System Details

Application

  • User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6.4; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; MDDC; .NET CLR 3.5.30729; .NET CLR 3.0.30729; OfficeLiveConnector.1.4; OfficeLivePatch.1.3)

More Information

Application Basics
Name
Firefox
Version
3.6.3
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Search Settings Plugin
1.2.2
false
search@searchsettings.com
Dealio Toolbar Plugin
4.0.1
false
{01398B87-61AF-4FFB-9AB5-1A1C5FB39A9C}
Java Console
6.0.17
true
Java Console
6.0.19
true
Java Console
6.0.20
true
Microsoft .NET Framework Assistant
1.2.1
true
{20a82645-c095-46ed-80e3-08825760534b}
RealPlayer Browser Record Plugin
1.1.4
true
Move Media Player
7
true
moveplayer@movenetworks.com
Modified Preferences
Name
Value
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.mozilla.com/en-US/firefox/3.6.3/firstrun/
browser.startup.homepage_override.mstone
rv:1.9.2.3
extensions.lastAppVersion
3.6.3
general.useragent.extra.microsoftdotnet
( .NET CLR 3.5.30729)
network.cookie.prefsMigrated
true
places.last_vacuum
1274470105
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false

Morbus 134 solutions 2338 answers

Hello Mandy.

I can't think of a scenario where Firefox would make itself the default browser against the user's consent. Still, go into Tools > Options > Advanced > General > System defaults and untick that small box at the bottom of the window that talks about Firefox asking you each time it starts.

Hopefully that will fix the issue.

ccrashh 0 solutions 4 answers

Well, it isn't necessarily making itself the default browser. What it is doing is ignoring the settings in Control Panel/Add Remove Programs/Set Program Access and Defaults - Custom. Even if I set IE as my default, FF still is.