Search Support

I need an upgrade from Firefox 1 to Firefox 2. I have windows ME, so I know version 3 does not work

  • 3 replies
  • 4 have this problem
  • 14 views
  • Last reply by Morbus

more options

I am stuck with Window ME on my computer, and have version 1 of Firefox. I know version 3 does not work with ME, however many of the things I need are supported with version 1.5 or 2. How can I upgrade Firefox 1 to a version that will run with Windows ME?

This happened

Every time Firefox opened

All Replies (3)

more options

Hello Melissa.

I will have you know that versions prior to Firefox 3.5 have been discontinued and are no longer supported by Mozilla. Furthermore, they have known bugs and security problems. Use them with caution and please make sure you are aware of these problems.

It is true, however, that new versions of Firefox (I believe anything above Firefox 2.0) do not work with older versions of Windows (Windows Me included). However, I will remind you that Windows Me (in fact, any version of Windows prior to Windows XP) is no longer supported by Microsoft, and, like older versions of Firefox, has known problems and security issues.

As such, I urge you to update your operating system. Windows XP is still widely used, will be supported until 2014, is relatively cheap and should run ok on your computer (please check the system requirements first). Older computers are normally not capable of running Windows Vista and above. If upgrading to a new version of Windows is not possible or you simply don't want to, there are many different distributions of Linux that will easily work in your computer, and easily surpass Windows Me in terms of software compatibility (if you use Wine - a software compatiblity layer to use Windows applications). Getting and installing Linux is completely free and is very easy too. I personally recommend Ubuntu, but you may want to try Xubuntu, a lightweight version of the former. If you need help getting started in the world of Linux, you can use the official support forums and take advantage of Linux's fantastic community.

Ok. Now that I've got the part where I tell you that your OS is not supported and you should update, I also have to tell you that Firefox 3.5 and above, despite being supported in newer versions of Windows and other operating systems (including, of course, Linux), is not supported in Windows Me, and is not supposed to work under it (since it was not developed with it in mind). If there is a way to make it work (somehow), it will not be supported and we probably won't be able to help you in fixing any problems you might have. You can search the web for ways to installed Firefox 3.0/3.5/3.6 in Windows Me, but it won't be in Firefox's support forums.

You can, however, install without any predictable issue, Firefox 2.0, which is the last Firefox release for Windows Me. To get it, you will need to access Mozilla's FTP servers. Here's a link for the 2.0 release directory:

ftp://ftp.mozilla.org/pub/firefox/releases/2.0.0.20/win32/

However, and again, I will remind you that version 2.0 of Firefox has been discontinued and is no longer supported. It has known bugs and security problems, and, again, I urge you to update to the latest version of Firefox, for maximum stability, performance, security and usability. You can get it for free, as always, at getfirefox.com.

more options

You linked to the wrong Firefox 2, it should be ftp://ftp.mozilla.org/pub/firefox/releases/2.0.0.20/win32/

more options