X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 3.6.4 Mac OSX 10.6.3 bogs down

Posted

After a few days of use where Firefox 3.6.4 is never closed it seems to bog down and scrolling becomes slow and choppy. If I quit Firefox and not save tabs and data it is fine on the next start. But I usually have around three to four tabs that I need to remain open. Is there something I can do to fix or prevent this without closing tabs?

This happened

A few times a week

== All along never free from problem

Additional System Details

Installed Plug-ins

  • -Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • iPhoto6
  • Allows webpages to support pressure-sensitive drawing on Wacom pen tablets.
  • Garmin Communicator Plug-in Version 2.9.1.0
  • Java Plug-In 2 for NPAPI Browsers
  • Coupons Inc. Plugin
  • Shockwave Flash 10.0 r42
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.4) Gecko/20100513 Firefox/3.6.4 GTB7.0

More Information

Morbus 134 solutions 2338 answers

Hello Joel.

This kind of issues are, unfortunately, more common and the we'd like. Thankfully, 99% of the cases are very easy to solve. However, you do need to diagnose what your exact problem is. Do this:

  1. run Firefox in safe-mode to disable all extensions, themes and plugins. If this fixes your issues, be them with RAM or CPU usage, then you know it's a problem with plugins, themes or extensions. Proceed to number 2. If safe-mode doesn't fix the issues, then read bellow, after this list;
  2. update all extensions, themes and plugins in your Firefox. If this doesn't solve the issues, proceed to the following number;
  3. disable all extensions, themes and plugins in your Firefox (not running safe-mode). Being certain that, as in safe-mode, the problems you're having have gone away, enable one plugin at a time. You should be certain that you WANT that plugin to be enabled, so keep your overall number of plugins as low as possible. When you encounter the problems, you know you've found a problematic plugin, so disable it for good. Keep enabling all plugins (except problematic ones) until you've gone through them all.
  4. enable one extension at a time. Again, be certain that you WANT that extension to be enabled, so keep your overall number of extensions as low as possible. Also, try the theme you want to have installed so see if that is what's causing the problem. When you encounter the problems, you know you've found a problematic extension/theme, so disable it for good. Keep enabling all your extensions (except problematic ones) until you've gone through them all;
  5. you're done! You've fixed your problems with problematic add-ons. If you want to keep using those problematic add-ons, please contant their author for support.

Ok, if disabling all extensions and plugins through safe-mode didn't work to bring Firefox's CPU and RAM usage to good levels, then you have different issue. The most likely scenario is that you have a third party software running on your computer that is messing with Firefox. Do as follows:

  1. try reinstally Firefox. No data will be lost. You can get the latest version for free at getfirefox.com. If that doesn't fix the problem, proceed;
  2. do a virus/malware check on your computer. If this doesn't fix it, proceed;
  3. disable all software running in the background that you don't want to have running in the background (in windows, this is done by pressing WINDOWS+R in your keyboard, typing "msconfig" (without the commas) and pressing enter. Now, under the "Startup" tab, you can uncheck the software you don't want, and reboot your system for changes to take effect. If you're unsure of what software you want running, ask someone with more experience). If this doesn't fix your issues with Firefox, proceed;
  4. check your firewall/antivirus/security suite for enabled functions/features that you don't want and/or may be conflicting with Firefox. You'll find that these features are most likely tied to Internet Security features, such as link scanners or URL checkers and the like. If you're not sure they are conflicting with Firefox, simply try to disable them to see whether or not that's true. As long as you don't browse the web with your antivirus completely off and your firewall completely turned off, there should be no problems. If this doesn't solve the issues, proceed to the following number;
  5. check your operating system security options, mainly advanced options that are not configured by default. While it's very unlikely that this may be the cause of the problem (after all, it's the last item on the list), it's remotely possible. If this doesn't work, proceed to the following point;
  6. clean up your OS registry, using appropriate software. If this doesn't do it, I'm out of ideas. Except make sure you've followed my instructions correctly.

Question owner

Problem solve for Firefox 3.6.3 and Mac OS X 10.6.3

1. Un-install your modem/driver. 2. Re-install your modem/driver. 3. Firefox 3.6.3 will then work as pre normal for Mac OS X 10.6.3

Enjoy.

Question owner

I have tried all the above and the only fix seems to be to close Firefox and restart. I will next try a deep cache cleaning using Snow Leopard Cache Cleaner. I don't have a modem but I have removed my Ethernet and restored it under OSX.

Morbus 134 solutions 2338 answers

Joel, if you tried all of the above (including what I suggested in hthis post), do your problems persist even with a new profile?

Question owner

Yes I tried a new profile, with same problem. I am going to remove Firefox and start from scratch as I am at a loss as to why this happens.

Morbus 134 solutions 2338 answers

I thought you had already done that. Please also follow the second part of my post:

  1. try reinstalling Firefox. No data will be lost. You can get the latest version for free at getfirefox.com. If that doesn't fix the problem, proceed;
  2. do a virus/malware check on your computer. If this doesn't fix it, proceed;
  3. disable all software running in the background that you don't want to have running in the background (in windows, this is done by pressing WINDOWS+R in your keyboard, typing "msconfig" (without the commas) and pressing enter. Now, under the "Startup" tab, you can uncheck the software you don't want, and reboot your system for changes to take effect. If you're unsure of what software you want running, ask someone with more experience). If this doesn't fix your issues with Firefox, proceed;
  4. check your firewall/antivirus/security suite for enabled functions/features that you don't want and/or may be conflicting with Firefox. You'll find that these features are most likely tied to Internet Security features, such as link scanners or URL checkers and the like. If you're not sure they are conflicting with Firefox, simply try to disable them to see whether or not that's true. As long as you don't browse the web with your antivirus completely off and your firewall completely turned off, there should be no problems. If this doesn't solve the issues, proceed to the following number;
  5. check your operating system security options, mainly advanced options that are not configured by default. While it's very unlikely that this may be the cause of the problem (after all, it's the last item on the list), it's remotely possible. If this doesn't work, proceed to the following point;
  6. update your modem/router software. There have been some reports that some modem/router software may cause Firefox and other browsers to loose performance and/or stability. If updating doesn't fix your issue, try other versions of the software, if possible. If you need support with this, contact your modem/router manufacturer. If this doesn't help, proceed;
  7. clean up your OS registry, using appropriate software. Make sure you've followed my instructions correctly, but if this all doesn't work, create a new Firefox profile (this can be temporary, of course) and see if the issues persist. Report here the results, so we can't help you further.

(this list is a bit different, so follow this one, please)

Question owner

No this time I am removing all traces of Firefox. I am using Mac OSX not Windows. My Router is an Apple Airport Extreme Base Station with the latest firmware.

Morbus 134 solutions 2338 answers

You may want to back up your personal information before you do that, or you'll loose it:

http://support.mozilla.com/en-US/kb/Backing+up+your+information

Question owner

I have the same problem and it started with the upgrade to the 3.6 series.

My strong suspicion is that it is due to a change in policy for JavaScript scripts in tabs that do not have focus. Is it possible that some clever bunny has decided that they need to keep running? If so, as you accumulate tabs for various sites (or even multiple tabs for some sites), each of those will add (often substantial) CPU load.

Macs are painfully designed so that high CPU loads are short and rare. With the recent changes to Firefox they are now continuous and frequent.

Question owner

I have the exact same problem too. I've run through all the items on the list that pertain to my system (MacBook Pro).

Morbus 134 solutions 2338 answers

What were the results of point 7 in the second list?

joel112 0 solutions 1 answers

From operating systems to multimedia, PC & mobile games to anti-virus, from drivers to registry cleaners and internet tools our website features all the latest soft wares for safe and <a href="http://download-daddy.com"> free downloading </a> enjoy.