X
Tap here to go to the mobile version of the site.

Support Forum

Takes half an hour or more for new window to open, toolbar functions stop working and I sometimes have to "force quit" to exit.

Posted

A couple of months ago I forgot I had left my computer on when I walked away while browsing the web. When I came back some hours later there were pop-ups promoting porn sites on the screen. Firefox was locked up and I had to "force quit". Since then I have problems getting a new window. If I make repeated attempts, multiple windows open simultaneously sometime later. Toolbar menu buttons and add-on toolbar buttons work at first but often stop functioning after half an hour or so. When this happens, I generally have to "force quit" to escape Firefox. I have tried deleting Firefox from my computer and downloading a fresh version but the problem continues. No other program seems affected. I have Integro Virus Barrier X5, and I am running a trial version of X6, but I have found no sign of any malicious software. Suggestions?

A couple of months ago I forgot I had left my computer on when I walked away while browsing the web. When I came back some hours later there were pop-ups promoting porn sites on the screen. Firefox was locked up and I had to "force quit". Since then I have problems getting a new window. If I make repeated attempts, multiple windows open simultaneously sometime later. Toolbar menu buttons and add-on toolbar buttons work at first but often stop functioning after half an hour or so. When this happens, I generally have to "force quit" to escape Firefox. I have tried deleting Firefox from my computer and downloading a fresh version but the problem continues. No other program seems affected. I have Integro Virus Barrier X5, and I am running a trial version of X6, but I have found no sign of any malicious software. Suggestions?

Chosen solution

Since July 25, 2010, when I try to access my mutual fund accounts at Dodge and Cox, they reject my user ID. If I do this using Internet Explorer, it works just fine. The D&C person I talked to said I should check Firefox to ensure it has 128 bit security. How do I do this?

Robert

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • -Cooliris embbedded in a tab
  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Unity Web Player lets you experience dazzling interactive 3D right in your browser. For more information, visit Unity .
  • iPhoto6
  • 2.0.31005.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Version 1.1.2.9282
  • Shockwave Flash 10.0 r45

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB7.0

More Information

Application Basics
Name
Firefox
Version
3.6.3
Profile Directory
Show in Finder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
AniWeather
0.7.4
true
{4176DFF4-4698-11DE-BEEB-45DA55D89593}
Better Gmail 2
1.2
true
bettergmail2@ginatrapani.org
Cooliris
1.11.7
true
piclens@cooliris.com
CoolPreviews
3.0.1
true
Download Statusbar
0.9.6.8
true
DownThemAll!
1.1.9
true
Google Desktop Search
1.1
false
googleDesktop-1.9@google.com
Google Toolbar for Firefox
7.0.20100326M
true
{3112ca9c-de6d-4884-a869-9855de68056c}
Greasemonkey
0.8.20100408.6
true
Hyperwords
6.0.2
true
{9A752782-D706-479b-98F8-3F66BF921692}
SearchMenu - Search Faster in Firefox
1.3.2.49
true
kosa@kallout.com
SearchPreview
4.3
true
StumbleUpon
3.64
true
AddThis
3.0.1
true
{3e0e7d2a-070f-4a47-b019-91fe5385ba79}
Modified Preferences
Name
Value
accessibility.blockautorefresh
true
browser.fixup.alternate.enabled
false
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage
http://www.google.com/ig
browser.startup.homepage_override.mstone
rv:1.9.2.3
dom.disable_open_during_load
false
extensions.lastAppVersion
3.6.3
javascript.options.showInConsole
true
network.cookie.cookieBehavior
1
network.cookie.prefsMigrated
true
network.protocol-handler.expose.mailto
true
network.protocol-handler.external.mailto
false
places.last_vacuum
1272063466
print.macosx.pagesetup-2
PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO…
print.print_bgcolor
false
print.print_bgimages
false
print.print_command
print.print_downloadfonts
false
print.print_evenpages
true
print.print_in_color
true
print.print_margin_bottom
0.5
print.print_margin_left
0.5
print.print_margin_right
0.5
print.print_margin_top
0.5
print.print_oddpages
true
print.print_orientation
0
print.print_pagedelay
500
print.print_paper_data
0
print.print_paper_height
11.00
print.print_paper_size_type
1
print.print_paper_size_unit
0
print.print_paper_width
8.50
print.print_printer
print.print_reversed
false
print.print_scaling
1.00
print.print_shrink_to_fit
true
print.print_to_file
false
print.print_unwriteable_margin_bottom
56
print.print_unwriteable_margin_left
25
print.print_unwriteable_margin_right
25
print.print_unwriteable_margin_top
25
privacy.sanitize.migrateFx3Prefs
true
security.OCSP.disable_button.managecrl
false
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false

Morbus 135 solutions 2340 answers

Hello Gordon.

This kind of issues are, unfortunately, more common and the we'd like. Thankfully, 99% of the cases are very easy to solve. However, you do need to diagnose what your exact problem is. Do this:

  1. run Firefox in safe-mode to disable all extensions and plugins. If this fixes your issues, be them with RAM or CPU usage, then you know it's a problem with plugins or extensions. Proceed to number 2. If safe-mode doesn't fix the issues, then read bellow, after this list;
  2. update all extensions and plugins in your Firefox. If this doesn't solve the issues, proceed to the following number;
  3. disable all extensions and plugins in your Firefox (not running safe-mode). Being certain that, as in safe-mode, the problems you're having have gone away, enable one plugin at a time. You should be certain that you WANT that plugin to be enabled, so keep your overall number of plugins as low as possible. When you encounter the problems, you know you've found a problematic plugin, so disable it for good. Keep enabling all plugins (except problematic ones) until you've gone through them all.
  4. enable one extension at a time. Again, be certain that you WANT that extension to be enabled, so keep your overall number of extensions as low as possible. When you encounter the problems, you know you've found a problematic extension, so disable it for good. Keep enabling all your extensions (except problematic ones) until you've gone through them all;
  5. you're done! You've fixed your problems with problematic add-ons.

Ok, if disabling all extensions and plugins through safe-mode didn't work to bring Firefox's CPU and RAM usage to good levels, then you have different issue. The most likely scenario is that you have a third party software running on your computer that is messing with Firefox. Do as follows:

  1. do a virus/malware check on your computer. If this doesn't fix it, proceed;
  2. disable all software running in the background that you don't want to have running in the background (in windows, this is done by pressing WINDOWS+R in your keyboard, typing "msconfig" (without the commas) and pressing enter. Now, under the "Startup" tab, you can uncheck the software you don't want, and reboot your system for changes to take effect. If you're unsure of what software you want running, ask someone with more experience). If this doesn't fix your issues with Firefox, proceed;
  3. check your firewall/antivirus/security suite for enabled functions/features that you don't want and/or may be conflicting with Firefox. You'll find that these features are most likely tied to Internet Security features, such as link scanners or URL checkers and the like. If you're not sure they are conflicting with Firefox, simply try to disable them to see whether or not that's true. As long as you don't browse the web with your antivirus completely off and your firewall completely turned off, there should be no problems. If this doesn't solve the issues, proceed to the following number;
  4. check your operating system security options, mainly advanced options that are not configured by default. While it's very unlikely that this may be the cause of the problem (after all, it's the last item on the list), it's remotely possible. If this doesn't work, proceed to the following point;
  5. clean up your OS registry, using appropriate software. If this doesn't do it, I'm out of ideas. Except make sure you've followed my instructions correctly.
Hello Gordon. This kind of issues are, unfortunately, more common and the we'd like. Thankfully, 99% of the cases are very easy to solve. However, you do need to diagnose what your exact problem is. Do this: #run Firefox in safe-mode to disable all extensions and plugins. If this fixes your issues, be them with RAM or CPU usage, then you know it's a problem with plugins or extensions. Proceed to number 2. If safe-mode doesn't fix the issues, then read bellow, after this list; #update all extensions and plugins in your Firefox. If this doesn't solve the issues, proceed to the following number; #disable all extensions and plugins in your Firefox (not running safe-mode). Being certain that, as in safe-mode, the problems you're having have gone away, enable one plugin at a time. You should be certain that you WANT that plugin to be enabled, so keep your overall number of plugins as low as possible. When you encounter the problems, you know you've found a problematic plugin, so disable it for good. Keep enabling all plugins (except problematic ones) until you've gone through them all. #enable one extension at a time. Again, be certain that you WANT that extension to be enabled, so keep your overall number of extensions as low as possible. When you encounter the problems, you know you've found a problematic extension, so disable it for good. Keep enabling all your extensions (except problematic ones) until you've gone through them all; #you're done! You've fixed your problems with problematic add-ons. Ok, if disabling all extensions and plugins through safe-mode didn't work to bring Firefox's CPU and RAM usage to good levels, then you have different issue. The most likely scenario is that you have a third party software running on your computer that is messing with Firefox. Do as follows: #do a virus/malware check on your computer. If this doesn't fix it, proceed; #disable all software running in the background that you don't want to have running in the background (in windows, this is done by pressing WINDOWS+R in your keyboard, typing "msconfig" (without the commas) and pressing enter. Now, under the "Startup" tab, you can uncheck the software you don't want, and reboot your system for changes to take effect. If you're unsure of what software you want running, ask someone with more experience). If this doesn't fix your issues with Firefox, proceed; #check your firewall/antivirus/security suite for enabled functions/features that you don't want and/or may be conflicting with Firefox. You'll find that these features are most likely tied to Internet Security features, such as link scanners or URL checkers and the like. If you're not sure they are conflicting with Firefox, simply try to disable them to see whether or not that's true. As long as you don't browse the web with your antivirus completely off and your firewall completely turned off, there should be no problems. If this doesn't solve the issues, proceed to the following number; #check your operating system security options, mainly advanced options that are not configured by default. While it's very unlikely that this may be the cause of the problem (after all, it's the last item on the list), it's remotely possible. If this doesn't work, proceed to the following point; #clean up your OS registry, using appropriate software. If this doesn't do it, I'm out of ideas. Except make sure you've followed my instructions correctly.

Chosen Solution

Since July 25, 2010, when I try to access my mutual fund accounts at Dodge and Cox, they reject my user ID. If I do this using Internet Explorer, it works just fine. The D&C person I talked to said I should check Firefox to ensure it has 128 bit security. How do I do this?

Robert

Since July 25, 2010, when I try to access my mutual fund accounts at Dodge and Cox, they reject my user ID. If I do this using Internet Explorer, it works just fine. The D&C person I talked to said I should check Firefox to ensure it has 128 bit security. How do I do this? Robert