Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I clicked to allow a popup and now I can't "reblock" it.

  • 3 replies
  • 5 have this problem
  • 119 views
  • Last reply by vic4archie

more options

Firefox gave me a message that a popup was blocked. I opened it and found it to be an ad for Netflix. I want to block this popup but it won't stop coming up. It comes up once a day when I open my local newpaper's website.

All Replies (3)

more options

Tools > Options > Content, "Block pop-up windows" > Exceptions.

Click on the site in the list, click the "Remove site" button. Any sites on the list are allowed to display pop-ups even when there is a check mark next to Tools > Options > Content, "Block pop-up windows".

See: Pop-up blocker - Pop-up blocker options

Also see: http://kb.mozillazine.org/Popups_not_blocked#Other_software_disables_the_popup_blocker

more options

Hi TXGuy. I tried your suggestion and the popup for Netflix is still coming up. It has the Firefox logo in the upper left corner and has a URL that I've tried placing into my AdBlocker Plus program to filter the site and that doesn't work either. This popup only appears once a day so if I lose it I can't get it back until the next day. I tried to get a screen shot and hit the wrong key and lost the site. Any other suggestions?

more options

Hello people. I am new to Firefox but am trying! However, I too get that Netflix window once a day. I never get any other popups. What to do to get rid of this?? Can anyone help. Thanks.